SLES10sp2-64 OES2 cluster

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

SLES10sp2-64 OES2 cluster

Сообщение Антон Бурмистров » 03 фев 2009, 16:42

Вроде бы всё работет. При отключении узла ресурсы передаются другому и т.д. , но перестаёт работать сервис в iManager. Вылезает ошибка File Protocol Error occurred: cannot open the NCS version file on the selected cluster. The Cluster software may not be running on this server.
После включения узла iManager опять начинает нормально работать. Подозреваю, что проблема в том, что пропадает ldap-сервер. Если это там, то почему не берётся локальный, т.к. реплики на обоих серверах?
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург

Сообщение Иван Левшин aka Ivan L. » 03 фев 2009, 17:10

Версия OES2 и иманагера? В 2.7.2, судя по описанию, ошибка эта устранена
Иван Левшин aka Ivan L.
 
Сообщения: 2399
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение Антон Бурмистров » 04 фев 2009, 12:04

oes2sp1-64, imanager 2.7.2
Продолжил изыскания.
node 0 - master, node 1 - rw
1 делаю shutdown. ресурсы перебрасываются imanager работает без ошибок.
0 делаю shutdown. ресурсы перебрасываются imanager работает без ошибок.
1 вынимаю сетевой кабель. 1 перезагружается, ресурсы перебрасываются, imanager на 0 работает без ошибок, на 1 - ошибка
0 вынимаю сетевой кабель. 0 перезагружается, ресурсы перебрасываются, imanager на 0 и 1 - ошибка.
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург

Сообщение Иван Левшин aka Ivan L. » 04 фев 2009, 12:45

Судя по описанию - кластер работает ОК. С иманагером - пока не скажу. Проблема была, в ридми отмечена как "решено". Насколько хорошо решено - загадка. Обе ноды точно один и тот же состав и версии ПО имеют?
Иван Левшин aka Ivan L.
 
Сообщения: 2399
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение Антон Бурмистров » 04 фев 2009, 13:28

оба сервера на одинаковом железе и с тавились с одного дистрибутива. Разница только в том, что у одного (проблемного) установлен русский язык в качестве основного.
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург

Сообщение Иван Левшин aka Ivan L. » 04 фев 2009, 14:12

Иманагер - в каком браузере и на каком языке открывается?
Иван Левшин aka Ivan L.
 
Сообщения: 2399
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение Антон Бурмистров » 04 фев 2009, 14:16

открывается на английском
локально - firefox
удалённо - IE 7
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург

Сообщение Иван Левшин aka Ivan L. » 04 фев 2009, 14:36

Есть возможность сервер переставить с английской локалью? Вообще в кластере сервера должны быть идентичны до последней запятой. Это, конечно, не обязательное - но весьма и весьма настоятельное требование
Иван Левшин aka Ivan L.
 
Сообщения: 2399
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение solomin » 05 фев 2009, 12:46

кластер тут непричем. подозрение что какие-то проблемы с LUM. На сколько я понимаю, эта ошибка выдается тогда, когда пользователь, зарегестрированный в иманагере пытается прочитать файлик на оси. Если не удастя определить uid пользователя(через LUM) то и прочитать он его не сможет. ГДе пытались смотреть ошибки?
solomin
 
Сообщения: 80
Зарегистрирован: 11 мар 2008, 11:24
Откуда: Екатеринбург

Сообщение Антон Бурмистров » 05 фев 2009, 13:26

/var/log/messages
Unable to bind to alternative LDAP servers either
LDAP bind failed, trying to connect to alternative LDAP
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург

Сообщение solomin » 05 фев 2009, 13:50

кто ругается? какое сервис?
Попробуй прописать в /etc/nam.conf
alternative-ldap-server-list=IP альтернативного LDAP сервера(репилки тобишь).
после этого надо сервис namcd перегрузить, если не ошибаюсь.

З.Ы. Еще была проблема в неправильном порядке загрузки сервисов при старте системы. Для исправления надо в /etc/sysconfig/boot менять в RUN_PARALLEL="no".
solomin
 
Сообщения: 80
Зарегистрирован: 11 мар 2008, 11:24
Откуда: Екатеринбург

Сообщение Антон Бурмистров » 05 фев 2009, 18:08

/etc/nam.conf поправил
RUN_PARALLEL="no" не помогло

Feb 5 16:28:01 linux-cluster-2 /usr/sbin/namcd[7705]: ldap_initconn: LDAP bind failed (error = [81]), trying to connect to alternative LDAP server
Feb 5 16:28:01 linux-cluster-2 /usr/sbin/namcd[7705]: nam_ldap_init(): retrieval of trusted root cert failed. Make sure you have LDAP server certificate in /var/lib/novell-lum directory.
Feb 5 16:28:01 linux-cluster-2 /usr/sbin/namcd[7705]: nss_ldap_init: Unable to get LDAP handle.
Feb 5 16:28:01 linux-cluster-2 /usr/sbin/namcd[7705]: ldap_initconn: Unable to bind to alternative LDAP servers either, error [226].

нашел тид 7001988. завтра попробую.
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург

Сообщение Антон Бурмистров » 13 фев 2009, 08:51

Пришлось всё-таки переставить сервер. Всё заработало. Поменял только основной язык и в LUM указал локальный адрес.
Антон Бурмистров
 
Сообщения: 140
Зарегистрирован: 21 окт 2002, 15:07
Откуда: С-Петербург


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron