Проблема с томами

Обсуждение технических вопросов по продуктам Novell

Проблема с томами

Сообщение Andrey_27 » 28 мар 2005, 10:04

Недавно навернулся сервер NW 5.1 (аппаратный отказ). Пришлось заново ставить его в существующее дерево. В дереве два сервера - NW 5.1 и NW 4.1 (главный). Грохнулся NW 5.1. При его новой установке была допущена ошибка: до установки NW 5.1 его старое имя удалили из дерева, имена томов этого сервера из дерева удалены не были. Так вот после установки сервера и задания ему старого имени в дереве тома NW 5.1 стали отображаться со знаком вопроса (нельзя было посмотреть свойства, создать в них что-либо и т.д.). После удаления имён этих томов со знаком вопроса из дерева и создания заново томов с теми же именами они стали видеться и доступны для разного рода действий над ними. Но вот беда - в dsrepair при выполнении unnatended full repair выдаётся следующая ошибка:

Repairing volume object for volume SYS
Directory services volume object ID: 00000000
ERROR: The volume has never been installed
ERROR: Could not find or add a Directory Services volume object , error
-610
Trustees are not checked on this volume

И на второй том DATA пишет тоже самое...
И в конце:
Volumes checked: 2

Также имеют место быть ряд других ошибок:
При backup'е Root на ленту выдаётся сообщение: SMS errors;
Не запускаются брокеры;
А также проблемы с сервером сертификатов (не был создан)...
Хотя раньше со старым сервером подобных проблем не было, установка шла также без каких-либо проблем...
Как-нибудь это можно вылечить, или только повторной переустановкой с предварительным удалением имён сервера и томов из дерева?
Аватара пользователя
Andrey_27
 
Сообщения: 107
Зарегистрирован: 14 янв 2004, 11:55

Сообщение Константин Ошмян » 28 мар 2005, 10:55

Andrey_27 писал(а):Но вот беда - в dsrepair при выполнении unnatended full repair выдаётся следующая ошибка:

Repairing volume object for volume SYS
Directory services volume object ID: 00000000
ERROR: The volume has never been installed
ERROR: Could not find or add a Directory Services volume object , error
-610
Trustees are not checked on this volume
Судя по этим симптомам, очень похоже на то, что объекты "том" (Volume) в NDS при установке сервера были созданы как-то не очень корректно - по крайней мере, нет чёткой привязки этих объектов к реально существующим томам сервера. Я бы посоветовал ещё раз проделать эту процедуру (хуже стать не должно):
  • запускаем на консоли сервера NWCONFIG;
  • из главного меню -> Directory Options;
  • Upgrade mounted volumes into the Directory.
На запрос вводим имя/пароль администратора; проверяется наличие в NDS объектов для всех подмонтированных томов (при необходимости - корректируется).
Аватара пользователя
Константин Ошмян
 
Сообщения: 986
Зарегистрирован: 13 авг 2002, 21:36
Откуда: Рига

Сообщение Andrey_27 » 28 мар 2005, 11:50

Случилось чудо!!! В dsrepair ошибок нет, всё ЧЕКАЕТСЯ...
Константин Ошмян, большое ВАМ спасибо!!!
А с брокерами и с сервером сертификатов как быть, оставить как есть или...?
Аватара пользователя
Andrey_27
 
Сообщения: 107
Зарегистрирован: 14 янв 2004, 11:55

Сообщение Константин Ошмян » 28 мар 2005, 12:19

Пожалуйста! :D

Andrey_27 писал(а):А с брокерами и с сервером сертификатов как быть, оставить как есть или...?
Ну тут уже по вкусу... Т.е. если они не используются - то можно безболезненно "или". С другой стороны - брокер нужен для корректной работы NDPS (если у Вас оно используется, то лучше пересоздать проблемные объекты), а сервер сертификатов - для выдачи/подтверждения сертификатов, которые используются, например, при установлении SSL-соединений. Кажется, сервер сертификатов можно потом доставить отдельно, но лучше поискать в knowledgebase на support.novell.com по конкретным кодам ошибок - было множество TID-ов на эту тему.
Аватара пользователя
Константин Ошмян
 
Сообщения: 986
Зарегистрирован: 13 авг 2002, 21:36
Откуда: Рига


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и гости: 6

cron