failed to start x server

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

failed to start x server

Сообщение Владимир Горяев » 20 ноя 2007, 11:47

Ставил как-то SLED на отдельный винт. Все там настроил. XGL, nwclient и прочие конфеты. Поигрался вобчем и в стол убрал.
Намедни достал винт чтоб еще поиграться. Стал загружаться и вылезла вышеназванная бяка.
Далее система говорит - см. мол xorg.93.log. Лог говорит про несовпвдение версий драйвера Nvidia 1.0-8762 и X module 1.0-8776. :shock:
С какого такого подменились версии не пойму.

И как X запустить?
Бардак автоматизировать невозможно!!!
_________________
Аватара пользователя
Владимир Горяев
 
Сообщения: 3473
Зарегистрирован: 05 июн 2002, 13:37
Откуда: Смоленск

Сообщение Игорь Вершинин » 20 ноя 2007, 12:14

Можно как временный вариант подменить драйвера на VESA. Через xorg.conf делается (/etc/X11/...)
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Сообщение Андрей Фисенко » 20 ноя 2007, 13:01

Владимир, попробуй запустить SaX2 - это утиля настройки параметров монитора. Если запускаться не захочет, запусти ее "sax2 -r"
Андрей Фисенко
 
Сообщения: 1308
Зарегистрирован: 05 июн 2002, 08:13
Откуда: Красноярск

Re: failed to start x server

Сообщение Андрей Тр. aka RH » 20 ноя 2007, 14:56

Владимир Горяев писал(а):Лог говорит про несовпвдение версий драйвера Nvidia 1.0-8762 и X module 1.0-8776.

У нас нечто подобное бывает на сервере OES SLES9 с Nvidia - по-моему, как последствие апдейтов rug'ом ( типа ядра ). Чего в данном случае приключилось - конечно, непонятно. А у нас человек перекомпиляет этот драйвер, после чего уже стартуют Иксы.
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

Сообщение Иван Левшин aka Ivan L. » 20 ноя 2007, 15:22

Абсолютно стандартная проблема при обновлении ядра или ксорга - суть в том, что подменяется модуль, ответственный за поддержку GLX. Решение - либо ручками восстановить модуль, либо тупо переставить драйвер. Я, собственно, так и делаю. Иксы, кстати, именно из-за XGL не стартуют - для работы Composite нужна поддержка GLX, а ее то и нету :)
Запустить иксы в ином случае - sax2 -r (как говорил Фис) либо по совету Игоря поколупать /etc/X11/xorg.conf. Первый вариант много предпочтительнее :)
Иван Левшин aka Ivan L.
 
Сообщения: 2392
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение Владимир Горяев » 20 ноя 2007, 16:21

Ковыряние конфига и просто sax2 -r успехом не увенчались.
Но TID подходяший нашелся. Суть коротко:
sax2 -r -m 0=vesa

Всем спасибо.
Бардак автоматизировать невозможно!!!
_________________
Аватара пользователя
Владимир Горяев
 
Сообщения: 3473
Зарегистрирован: 05 июн 2002, 13:37
Откуда: Смоленск


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron