Страшный глюк в iPrint

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Страшный глюк в iPrint

Сообщение puny » 01 ноя 2007, 16:13

После апдейта OES SP2 до OES2 перестала работать вэб-страница iPrint.
Причём все установленные принтеры нормально перенеслись и работают.
Заходишь на страницу iPrint, где установка драйверов для пользователей, - все надписи отображаются такими строками "????????????", броузер говорит что страница загружена с ошибками, а при клике на нужный принтер вместо установки драйвера, вылазит пустая страница...:(. Копание в исходниках ничего не дало, всё упирается в некий бинарный загружаемый модуль mod_ipp.so, который все эти страницы и генерит...:(
Что с этим делать - незнаю, у кого-нибудь оно работает, или так и должно быть...:) ?
puny
 
Сообщения: 54
Зарегистрирован: 18 янв 2005, 12:40

Сообщение Sergant » 01 ноя 2007, 17:02

Ну вы и экстримал !!! :)

Про это писалось в http://novell.org.ru/forum/viewtopic.php?t=9208
Так что ждем-с исправления... Кстати, а патчить пробовали ?

ЗЫ: а каким образом проводился апгрейд с OES до OES2 ? Как произошел апгрейд eDirectory ?
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение puny » 01 ноя 2007, 18:27

Фухх...:) Проблема со шрифтами решилась перезагрузкой апача. Теперь весь тест отображается правильно.
Но проблема со страницами "Страница загружена с ошибкой". Драйверы принтеров так и не ставятся...:( Ошибка при загрузке страницы следующая: "Незавершённая строковая константа"
адрес: http://server.domain.ru/ippdocs/isinstf.htm?
ippPrinterURL=ipp://iprint.domain.ru/ipp/P25&onInstaled=alert&onNotInstalled=install

Апдейт происходил с CD, вставил диск в сервер OES SP2 перезагрузился, сказал апдейтить, апдейт закончился нормально. eDirectory проапдейтилась автоматом, во время всей процедуры.
puny
 
Сообщения: 54
Зарегистрирован: 18 янв 2005, 12:40

Сообщение Антон Фридрих » 02 ноя 2007, 05:47

Все правильно,
во первых зрите в лог C:\NDPS\
во вторых заходите как на http? а принтеры https так? плюс клиент наверное не 4.32 ?
В общем после установки нового клиента и проверки правильной регистрации в нем пользователя а также при входе через https все запускается нормально..... )
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Сообщение puny » 02 ноя 2007, 11:18

Нет, всё неправильно.
Посмотрел лог, - он пустой.
Принтеры HTTP. Пробовал и по HTTPS, ошибка та же.
Клиент версии 4.32.
Не могу поставить новый принтер, кликая по нему, вместо уствновки драйвера появляется пустая страница и "Страница загружена с ошибками".

Кстати попробовал установить принтер вручную, т.е. запустил виндовый мастер установки принтера, указал ему URL принтера типа ipp://server.domain.ru/ipp/P25, принтер, нормально установился, но с веб-станицы не устанавливается...:(
puny
 
Сообщения: 54
Зарегистрирован: 18 янв 2005, 12:40

Сообщение Антон Фридрих » 02 ноя 2007, 13:11

а браузер какой?
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Сообщение puny » 02 ноя 2007, 15:08

Броузер самый крутой...:) - IE 6.0.2800.1106
puny
 
Сообщения: 54
Зарегистрирован: 18 янв 2005, 12:40

Сообщение Владимир Горяев » 02 ноя 2007, 16:10

puny писал(а):Броузер самый крутой...:) - IE 6.0.2800.1106
Самый крутои ето седьмой :lol: , очень смахивающий на FF :lol:
Бардак автоматизировать невозможно!!!
_________________
Аватара пользователя
Владимир Горяев
 
Сообщения: 3473
Зарегистрирован: 05 июн 2002, 13:37
Откуда: Смоленск

Сообщение puny » 18 дек 2007, 11:29

Ещё одна проблема с iPrint выяснилась.
Не ставятся автоматом драйвера принтера на XP. Вот на W2K ставятся, а на XP нет - говорит что на сервере нету подходящего драйвера...:(.
Всё проверил все драйвера есть и привязаны к принтерам и соответствующим системам. В логах полная тишина.
До апгрейда до OES2, на OES1SP2 всё работало нормально.
У кого-нибудь вообще этот зверь работает нормально???!!!
puny
 
Сообщения: 54
Зарегистрирован: 18 янв 2005, 12:40

Сообщение Антон Фридрих » 18 дек 2007, 11:54

Тестирую уже месяца три,пока полет нормальный, иногда даже лучше работает чем из оес1.... с вашей проблемой не встречался, хотя все машины хр
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Сообщение Иван Левшин aka Ivan L. » 18 дек 2007, 12:32

The 4.32 iPrint client is supported on Windows 2000, Windows XP, and Windows 2003. This client may work on Windows 95, 98, and NT, but has not been tested. Microsoft Hotfixes KB884897 and KB893225 should be installed on each workstation that uses the iPrint client on 2000 and XP. See TID 3786843 for more information.
Иван Левшин aka Ivan L.
 
Сообщения: 2392
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение v13 » 18 дек 2007, 19:00

puny писал(а):Ещё одна проблема с iPrint выяснилась.
Не ставятся автоматом драйвера принтера на XP. Вот на W2K ставятся, а на XP нет - говорит что на сервере нету подходящего драйвера...:(.
Всё проверил все драйвера есть и привязаны к принтерам и соответствующим системам. В логах полная тишина.
До апгрейда до OES2, на OES1SP2 всё работало нормально.
У кого-нибудь вообще этот зверь работает нормально???!!!


Проверь дровишки для XP в брокере, привязку их к принтеру.
Не знаю как в oes1, в oes2 их надо отдельно для 2000 и xp настраивать.
Аватара пользователя
v13
 
Сообщения: 660
Зарегистрирован: 31 авг 2007, 09:07

Сообщение Иван Левшин aka Ivan L. » 18 дек 2007, 19:26

v13 писал(а):
puny писал(а):Ещё одна проблема с iPrint выяснилась.
Не ставятся автоматом драйвера принтера на XP. Вот на W2K ставятся, а на XP нет - говорит что на сервере нету подходящего драйвера...:(.
Всё проверил все драйвера есть и привязаны к принтерам и соответствующим системам. В логах полная тишина.
До апгрейда до OES2, на OES1SP2 всё работало нормально.
У кого-нибудь вообще этот зверь работает нормально???!!!


Проверь дровишки для XP в брокере, привязку их к принтеру.
Не знаю как в oes1, в oes2 их надо отдельно для 2000 и xp настраивать.

Да, принтеру в обязательном порядке должны быть сопоставлены дрова. Иначе в ФФ просто ничего ставиться не будет :) В ИЕ7 - честно вылазит окошко "дров нет, идите лесом".
Иван Левшин aka Ivan L.
 
Сообщения: 2392
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

Сообщение puny » 19 дек 2007, 10:52

Да все дрова есть и они сопоставлены системам, в том-то и проблема.
Тем более раньше-то всё работало до апгрейда.
puny
 
Сообщения: 54
Зарегистрирован: 18 янв 2005, 12:40

Сообщение Rex_Com » 21 дек 2007, 12:54

Проблему со шрифтами решил тупо:
1. В апатче прописал что данный раздел http://server/ipp/ в кодировке вин 1251
2. Перекодировал ява переменые из win-1251 в utf-8
/var/opt/novell/iprint/htdocs/nls/ru/
(лаколизаторы хреновы, сайт utf-8, а половина страничек в win1251)


(кстати видемо из-за этих переменныъ и сбоил ява скриптик установки принтера, возмождно из-за перекодировки эксплорер воспринимал некий символ, как перехо на следующую строку или еще чтото :)


Но наблюдаю следующую проблему. подвисание менеджера печати.
1. Все задания на принтерах висят как обрабатываемые.
2. В логах ошибок никаких нет
3. При перезапуске менеджера, он коректно распечатывает все задания, закрываеться и запускаеться без ошибок.

может кто знает как это лечить ?
Rex_Com
 
Сообщения: 2
Зарегистрирован: 21 дек 2007, 12:27

След.

Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1