novell-client и зависимости

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

novell-client и зависимости

Сообщение kudrin » 21 май 2007, 09:23

Система suse 10.2
Ставлю novell-client-1.1-SuSE10.tar.gz
выпадает ошибка
Код: Выделить всё
error: Failed dependencies:
    libbfd-2.16.91.0.2.so is needed by novell-xtier-base-3.1.3-12.suse10.i586
    libexpat.so.0 is needed by novell-xtier-base-3.1.3-12.suse10.i586


стоит libbfd-2.17.50.0.5.so и libexpat.so.1.5.0

сделал как на http://www.novell.com/coolsolutions/feature/16101.html, ошибка с libbfd-2.16.91.0.2.so пропала, но libexpat.so.0 так и требует :(
kudrin
 
Сообщения: 2
Зарегистрирован: 21 май 2007, 09:18

10.2 nwfs or Novell-Client

Сообщение Fly Fox » 23 май 2007, 15:25

10.0 и 10.2 изначально разные вещи, для 10.0 все гораздо проще, а вот в сборке 10.2 нужных клиенту вещей уже нет :-) надеюсь статья ниже сильно поможет, по крайней мере мне - помогла.
http://dev-loki.blogspot.com/2006/12/no ... e-102.html
Fly Fox
 
Сообщения: 10
Зарегистрирован: 30 мар 2007, 18:04

Сообщение Александр Читалкин » 23 май 2007, 15:32

Создай симлинк с именем libexpat.so.0 на реально существующую библиотеку экспата. Ставь без учета зависимостей.
Аватара пользователя
Александр Читалкин
 
Сообщения: 112
Зарегистрирован: 13 ноя 2002, 23:29
Откуда: Москва

Сообщение Fly Fox » 23 май 2007, 16:06

Не поможет. Кто не верит, может легко это проверить. т.к. часть функций в новой библиотеке depricated.
К слову есть бета клиента для linux она прекрасно встает на 10.2 но работает отвратительно, новая бета вышла вчера, еще не проврял.
-----------------------------------------
P. Zhukov
System engineer Novell Consulting Russia
Fly Fox
 
Сообщения: 10
Зарегистрирован: 30 мар 2007, 18:04

Сообщение Александр Читалкин » 23 май 2007, 16:52

Тогда просто поставь эту библиотеку. rpmfind.net.
Аватара пользователя
Александр Читалкин
 
Сообщения: 112
Зарегистрирован: 13 ноя 2002, 23:29
Откуда: Москва

Сообщение Fly Fox » 23 май 2007, 17:52

У этой библиотеки есть свои зависимости, а у них свои, но что-бы не страдать растеканиями по древу "о том как бы это былобы если бы мы начали это делать"
несколькими постами ранее я дал ссылку на статью, где есть два rpm закрывающие для 10.2 эти зависимости. Хочешь поставь библиотеку. я с удовольствием потом почитаю на тему как это у тебя быстро все получилось. (что-бы поставить rpm хватит и символьной ссылки, но вот что-бы работало....)
Fly Fox
 
Сообщения: 10
Зарегистрирован: 30 мар 2007, 18:04

Сообщение Александр Читалкин » 23 май 2007, 23:30

А не надо растекаться. Чтобы работало, нужно дать программе то, что она хочет - а именно .so файл. Если он есть - работать будет. Если нет - нужно подкинуть. Зависимости при установке выставляются, в первую очередь, создателем пакета библиотеки, а не программистами, написавшими ее.
Аватара пользователя
Александр Читалкин
 
Сообщения: 112
Зарегистрирован: 13 ноя 2002, 23:29
Откуда: Москва

Сообщение Dimerson » 24 май 2007, 09:04

Fly Fox писал(а):У этой библиотеки есть свои зависимости, а у них свои, но что-бы не страдать растеканиями по древу "о том как бы это былобы если бы мы начали это делать"
несколькими постами ранее я дал ссылку на статью, где есть два rpm закрывающие для 10.2 эти зависимости. Хочешь поставь библиотеку. я с удовольствием потом почитаю на тему как это у тебя быстро все получилось. (что-бы поставить rpm хватит и символьной ссылки, но вот что-бы работало....)


Блин а разве нет ключей на предмет force-depends у rpm?
Аватара пользователя
Dimerson
 
Сообщения: 2759
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Сообщение Fly Fox » 24 май 2007, 09:34

Уважаемый Александр Читалкин пожалуйста поставте на виртуальную машину SuSE 10.2, потом установите на него Novell Client 1.2 и опешите это в этом форуме...
я надеюсь что kudrin когда спрашивал, хотел простого и эфективного ответа, а вот скопировать приведенную Вами библиотеку будет недостаточно (от себя добавлю, что поставить эти два rpm будет не только намного проще, но и сохранит "целостность" системе, т.к. удалить их будет не проблема и не надо помнить, все левые библиотеки и ссылки на них)
Fly Fox
 
Сообщения: 10
Зарегистрирован: 30 мар 2007, 18:04

Сообщение Андрей Фисенко » 24 май 2007, 10:28

Я, конечно, не волшебник, а Вы не пробовали бету клиента 2.0?
Бета Novell клиента 2.0.0 для openSuSE10.2 - 10 Mb
Андрей Фисенко
 
Сообщения: 1308
Зарегистрирован: 05 июн 2002, 08:13
Откуда: Красноярск

Сообщение Fly Fox » 24 май 2007, 11:09

Пробовали... местами не съедобная :-) но на 10.2 встает на ура. есть более новая сборка, но я ее пока не видел.
Fly Fox
 
Сообщения: 10
Зарегистрирован: 30 мар 2007, 18:04

Сообщение Александр Читалкин » 24 май 2007, 14:57

Уважаемый Fly Fox, к сожалению, kudrin не отписал результат выполнения вашего "простого и эфективного ответа", поэтому неизвестно, сработал он или нет. Предлагаю вам также почитать где-нибудь, что означает циферка 0 в конце libexpat.so.0 (в частности). В солюшене, которым пользовался kudrin, никаких манипуляций с libexpat не происходит. Как и во втором солюшене у /dev/loki. Они почти идентичны. В итоге libbfd был установлен, но expat'а все равно не хватает.

Делая окончательный вывод, предлагаю следующий солюшен. Сначала сказать locate libexpat.so.0. Если результат будет отрицательный (т.е., библиотеки нужной версии у нас нет), установить yast'ом пакет compat-expat1. Пакет rpm для OpenSUSE 10.2/i586 можно взять отсюда: http://rpmseek.com/rpm/compat-expat1-1. ... 7996:0:0:0. Если файл libexpat.so.0 у нас есть и locate нашел его, то следует просто проигнорировать эту зависимость.
Аватара пользователя
Александр Читалкин
 
Сообщения: 112
Зарегистрирован: 13 ноя 2002, 23:29
Откуда: Москва

Сообщение Андрей Фисенко » 24 май 2007, 18:11

Fly Fox писал(а):Пробовали... местами не съедобная :-) но на 10.2 встает на ура. есть более новая сборка, но я ее пока не видел.

Странно, я более новой сборки еще не видел.
Эта от середины апреля сего года пока последняя, доступная бета для 10.2
Андрей Фисенко
 
Сообщения: 1308
Зарегистрирован: 05 июн 2002, 08:13
Откуда: Красноярск

Сообщение kudrin » 24 май 2007, 20:08

Хватит в ромашку играть. Спасибо за совет с rpm, помогло без лишних телодвижений.
До этого libexpat стоял. Именно libexpat.so.0 Устанавливал и последние версии, и собирал из исходников старые - ничего не помогало.
Если файл libexpat.so.0 у нас есть и locate нашел его, то следует просто проигнорировать эту зависимость.

Этот ход ничего не даст.
И до простого решения
cp /usr/lib/libbfd-2.17.50.0.5.so /opt/novell/xtier/lib/libbfd-2.16.91.0.2.so

не каждый дотумкает.
kudrin
 
Сообщения: 2
Зарегистрирован: 21 май 2007, 09:18

Сообщение Александр Читалкин » 25 май 2007, 00:06

Однако странно. Но доверимся факту, хотя не понятно, почему при наличии libexpat.so.0 потребовалось все-таки устанавливать compat-expat1. Могу предположить, что имеет место путаница с путями.
Аватара пользователя
Александр Читалкин
 
Сообщения: 112
Зарегистрирован: 13 ноя 2002, 23:29
Откуда: Москва

След.

Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron