Опять про Patching OES

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Опять про Patching OES

Сообщение Sergant » 10 янв 2007, 11:59

За прошедшие праздники стали доступны новые патчи для OES. При попытке обновления через консоль с помощью команды rug выдается следущее:

The following requested packages will be installed:
evms 2.3.3-52 (oes)
kernel-smp 2.6.5-7.283 (oes)
novell-evms-snapins 1.0.50-1 (oes)
novell-ncp 5.0.1-75 (oes)
novell-ncpserv 1.3-10 (oes)
novell-nss 4.9.28-1 (oes)
novell-sms-zapishim 2.6.5_7.283-1.0.6 (oes)
yast2-core 2.9.98-0.2 (oes)
yast2-packagemanager 2.9.70-0.3 (oes)
yast2-you-server 2.9.17-0.1 (oes)

10 packages will be installed.
This is a 32.29M download.
Do you want to continue? [y/N] y
Download complete
Verifying yast2-you-server
Unable to verify package signature for yast2-you-server; package will be installed because user is trusted
Verifying yast2-packagemanager
Unable to verify package signature for yast2-packagemanager; package will be installed because user is trusted
Verifying yast2-core
Unable to verify package signature for yast2-core; package will be installed because user is trusted
Verifying novell-sms-zapishim
Unable to verify package signature for novell-sms-zapishim; package will be installed because user is trusted
Verifying novell-nss
Unable to verify package signature for novell-nss; package will be installed because user is trusted
Verifying novell-ncpserv
Unable to verify package signature for novell-ncpserv; package will be installed because user is trusted
Verifying novell-ncp
Unable to verify package signature for novell-ncp; package will be installed because user is trusted
Verifying novell-evms-snapins
Unable to verify package signature for novell-evms-snapins; package will be installed because user is trusted
Verifying kernel-smp
Unable to verify package signature for kernel-smp; package will be installed because user is trusted
Verifying evms
Unable to verify package signature for evms; package will be installed because user is trusted
Preparing Transaction
Removing
Transaction failed: Unable to complete RPM transaction:
file /var/opt/novell/log from install of novell-ncpserv-1.3-10 conflicts with file from package novell-filesystem-0.0.1-3
file /var/opt/novell/log from install of novell-ncpserv-1.3-10 conflicts with file from package novell-nrm-1.3-9
file /var/opt/novell/log from install of novell-ncpserv-1.3-10 conflicts with file from package novell-ncpserv-nrm-1.3-2
file /var/opt/novell/log conflicts between attempted installs of novell-nss-4.9.28-1 and novell-ncpserv-1.3-10

До этого сервер регулярно обновлялся таким образом, при чем последний раз где-то в середине декабря. Не понятна причина возникших конфликтов файлов. Кто-нибудь может подсказать причину этой проблемы ?
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение Sergant » 10 янв 2007, 12:32

Пока нашел TID 3045794 примерно на эту тему:
http://www.novell.com/support/search.do ... 2023190342

Однако, вот что получается:

# rug pin patch-11147

ERROR: Unable to find patch 'patch-11147' in any subscribed channel

Эх, разбаловала нас Microsoft своим Windows update :(
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение Sergant » 10 янв 2007, 15:11

Проблема решилась благодаря вышеуказанному TID-у. Т.е. патчится нужно было командой

# rug pin --entire-channel oes

а не

# rug up oes
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 8

cron