Установка iManager на Fedora Core 5

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Установка iManager на Fedora Core 5

Сообщение Alex_Saf » 06 сен 2006, 17:25

Доброго времени суток коллеги!

Есть проблемка с установкой iManager 2.6 на Fedora Core 5 (i386). Установка вылетает с ошибкой о не обходимости устновить compat. Требуемый, согласно док-ции пакет compat-libstdc++-33 в системе установлен.
rpm -qa | grep compat
compat-openldap-2.3.19_2.2.29-4
compat-gcc-32-c++-3.2.3-55.fc5
compat-gcc-32-3.2.3-55.fc5
compat-gcc-32-g77-3.2.3-55.fc5
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh
compat-db-4.2.52-4
compat-libstdc++-33-3.2.3-55.fc5
compat-libf2c-32-3.2.3-55.fc5
compat-libstdc++-296-2.96-135
compat-libgcc-296-2.96-135

Собственно ошибка:
Launching installer...

Preparing CONSOLE Mode Installation...
=============================================
Choose Locale...
----------------

1- English
->2- Русский

CHOOSE LOCALE BY NUMBER: 1
=============================================
-------------------------------------------------------------------------------


=============================================
Compat is required
------------------

Что нужно сделать, чтоб установщик "увидел" нужные либы?
libstdc++.so.5 в /usr/lib присутствует. путь в PATH также.
Спасибо
Alex_Saf
 
Сообщения: 16
Зарегистрирован: 06 сен 2006, 16:11

Re: Установка iManager на Fedora Core 5

Сообщение Dimerson » 06 сен 2006, 21:26

Alex_Saf писал(а):Доброго времени суток коллеги!

Есть проблемка с установкой iManager 2.6 на Fedora Core 5 (i386). Установка вылетает с ошибкой о не обходимости устновить compat. Требуемый, согласно док-ции пакет compat-libstdc++-33 в системе установлен.
rpm -qa | grep compat
compat-openldap-2.3.19_2.2.29-4
compat-gcc-32-c++-3.2.3-55.fc5
compat-gcc-32-3.2.3-55.fc5
compat-gcc-32-g77-3.2.3-55.fc5
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh
compat-db-4.2.52-4
compat-libstdc++-33-3.2.3-55.fc5
compat-libf2c-32-3.2.3-55.fc5
compat-libstdc++-296-2.96-135
compat-libgcc-296-2.96-135

Собственно ошибка:
Launching installer...

Preparing CONSOLE Mode Installation...
=============================================
Choose Locale...
----------------

1- English
->2- Русский

CHOOSE LOCALE BY NUMBER: 1
=============================================
-------------------------------------------------------------------------------


=============================================
Compat is required
------------------

Что нужно сделать, чтоб установщик "увидел" нужные либы?
libstdc++.so.5 в /usr/lib присутствует. путь в PATH также.
Спасибо


Если вы на 1000% уверены что все компоненты есть но этот DAMN rpm дурит с зависимостями - то пакаджи можно устанавливать путем rpm -i Package с ключем Force-Depends [при этом он ложит с прибором на зависимости] при установке пакаджей на другие системы чаще всего это самый простой выход
Аватара пользователя
Dimerson
 
Сообщения: 2749
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Сообщение Alex_Saf » 07 сен 2006, 01:31

Уверен на 10000%, что заявленный пакет стоит.
По вашему совету поставил rpm-ы вручную просто rpm -Uvh. Все нормально - ругони на зависимости не было. Запустил томкат, что он стал слушать порт 8080, а секурный 8443 почему-то нет. Видимо инсталятор, что то должен настроить.
Запуск https://localhost:8443/nps/iManager.html - не удался. Попытка вкючить второй коонектор на 8443 порт в server.xml - также не удалась.
Alex_Saf
 
Сообщения: 16
Зарегистрирован: 06 сен 2006, 16:11


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron