IPX и FreeBSD

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

IPX и FreeBSD

Сообщение Герман » 02 фев 2006, 14:56

Добрый день.
Замучила одна проблемма, может здесь помогут решить.
Не давно настраивали IPX на FreeBSD 4.9 (необходимо для монтирования томов с Novell NetWare). Собрали ядро с IPX, создали виртульные интерфейсы с помошью if_ef.ko, отредактировали rc.conf,установили NCPLIB. Прекрасно все заработало.
Проделываю тут же операцию с FreeBSD 5.4 Никак не могу смонтировать NetWare. Ipxping не идет. При попытке монтирования или ipxping говорит
"could not find server SPRUT
:syserr=Network is down"
обычный ping SPRUT нормально идет (на NetWare поднят еще и IP)
Чем так могут отличаться 4.9 и 5.4?
P.S. Допускаю что проблемма в кривых руках, но уже 25 раз все перепроверил.
Не ругайте, я только учусь.
Герман
 
Сообщения: 46
Зарегистрирован: 22 сен 2004, 16:23
Откуда: Крым

Re: IPX и FreeBSD

Сообщение Аркадий Глазырин » 05 фев 2006, 03:42

Герман писал(а):настраивали IPX на FreeBSD 4.9. Прекрасно все заработало.
Проделываю тут же операцию с FreeBSD 5.4. Никак не могу смонтировать NetWare. Ipxping не идет.


Попробуйте релизную 5.3.
Ясно же, что дело в версиях.
Смотрите связи пакетов.
Аватара пользователя
Аркадий Глазырин
 
Сообщения: 2762
Зарегистрирован: 16 авг 2002, 09:09
Откуда: Екатеринбург

Сообщение Герман » 06 фев 2006, 13:27

Попробуйте релизную 5.3.
Ясно же, что дело в версиях.
Смотрите связи пакетов.

Спасибо за ответ. Но не хотелось бы все пределывать, много чего настроено и работает. Может попробовать обновиться до 6.0? Правда процедура такого обновления мне плохо знакома.
Не ругайте, я только учусь.
Герман
 
Сообщения: 46
Зарегистрирован: 22 сен 2004, 16:23
Откуда: Крым

Сообщение Аркадий Глазырин » 07 фев 2006, 18:26

Герман писал(а):
Попробуйте релизную 5.3.
Ясно же, что дело в версиях.
Смотрите связи пакетов.

Спасибо за ответ. Но не хотелось бы все пределывать, много чего настроено и работает. Может попробовать обновиться до 6.0? Правда процедура такого обновления мне плохо знакома.


В том то и проблема, что "много чего настроено и работает".
Какой-то из пакетов не совместим и гадит.
Аватара пользователя
Аркадий Глазырин
 
Сообщения: 2762
Зарегистрирован: 16 авг 2002, 09:09
Откуда: Екатеринбург

Сообщение Герман » 09 фев 2006, 19:15

Аркадий Глазырин писал(а):
Герман писал(а):
Попробуйте релизную 5.3.
Ясно же, что дело в версиях.
Смотрите связи пакетов.

Спасибо за ответ. Но не хотелось бы все пределывать, много чего настроено и работает. Может попробовать обновиться до 6.0? Правда процедура такого обновления мне плохо знакома.


В том то и проблема, что "много чего настроено и работает".
Какой-то из пакетов не совместим и гадит.

Может подскажите, как эту проверку на совместимость наименьшей кровью сделать, откуда плясать?
Спасибо.
Не ругайте, я только учусь.
Герман
 
Сообщения: 46
Зарегистрирован: 22 сен 2004, 16:23
Откуда: Крым

проблема в организации работы

Сообщение Антон Савельев » 16 мар 2006, 17:15

Комрад,

Имеет смысл взять еще одну тачку (благо что Фря не сильно требовательна к ресурсам), поставить рядом с работающей, и -пробовать-пробовать-пробовать... как завещал великий Ленин...
80*25, DECO (рулит!) в зубы - и сравнивать... нет ничего невозможного...
Антон Савельев
 
Сообщения: 219
Зарегистрирован: 16 авг 2002, 15:31
Откуда: Мурманск

Сообщение zergserg » 26 мар 2006, 11:08

Смотреть нужно в сторону новостей о релизе 5.4, там что то изменялось споддержкой IPX. ну например: http://www.opennet.ru/opennews/art.shtml?num=4981
http://www.opennet.ru/opennews/art.shtml?num=6377
zergserg
 
Сообщения: 18
Зарегистрирован: 20 фев 2006, 10:19


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2