Не могу завести сервер в дерево

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Не могу завести сервер в дерево

Сообщение rocker » 10 июл 2005, 11:44

Првет All .
Мы у себя решили переводить все сервера с Netware на OES, но вот какое дело :
Есть Netware 4.1 (со всеми sp) поднят ldap (nldap.nlm)
nmap показывает, что кроме всего прочего открыты порты 389 и 524, то есть ldap и ncp.

Теперь ставлю допустим OES (или Suse 9.*+NterpriceServices).
Когда дело доходит до конфигурирования Edirectory (ставлю все, что нужно для работы сабжа) Yast говорит, что не может соединится с сервером (корневое дерево, которое я указал ему) + не синхронизировано время, хотя ntp сервер я ему написал верный и сделал ntpdate.
Еще говорит, что ему нужен 636 порт (ssl), а я на корневом сервере пытался поднять ssl, грузил wspssl и ldapssl, но ничего не вышло (((...может дело в этом.
При этом, свое дерево создается успешно и так же успешно работает.

Что же делать ?
rocker
 
Сообщения: 43
Зарегистрирован: 06 апр 2005, 19:51
Откуда: казань

Re: Не могу завести сервер в дерево

Сообщение Андрей Фисенко » 10 июл 2005, 16:42

rocker писал(а):... говорит, что ему нужен 636 порт (ssl)...
Что же делать ?

Да, именно SSL и нужен. На 4.1 заставить его работать не так-то и просто, если он не работает сразу. Посмотрите в сторону серверных сертификатов SSL Certificate IP - SERVER и SSL Certificate DNS - Server (боюсь, что эти объекты появились только с версии 5.х)
В вашем случае может помочь установка "промежуточного" сервера. Например, тот-же OES но на базе Netware 6.5
Можно попробовать так-же сделать in-place upgrade одной из существующей "четверки" до версии 6.5
А уже потом втыкать SLES9 + OES.
Вы читали что по поводу SSL на NW 4.1 на support.novell.com?
Андрей Фисенко, Представитель Novell по Сибири и Дальнему Востоку
Изображение
Андрей Фисенко
 
Сообщения: 1308
Зарегистрирован: 05 июн 2002, 08:13
Откуда: Красноярск

Re: Не могу завести сервер в дерево

Сообщение Пилютик Михаил » 11 июл 2005, 10:37

Уважаемый rocker, я эту задачу у себя решал так.
Сначала ввел в дерево сервер NetWare 6.5 SP3(сервер NetWare 6.5 из Novell OES в дерево ставился, но были проблемы с iManager 2.5). nldap на NetWare 4.11при этом не поднимал.

Сервер OES стал успешно ставиться в дерево после того как master-реплику перенес на сервер с NetWare 6.5 его же сделал Single Time Server.
Пилютик Михаил
 
Сообщения: 305
Зарегистрирован: 09 июл 2002, 15:02
Откуда: Минск

Сообщение rocker » 12 апр 2006, 22:39

Поднимаю старую тему ))

Где-то год назад я пробовал ставить OES beta. Тогда все закончилось на этапе ввода его в существующее дерево на базе Netware 5.1 sp7.
Сейчас, когда вышел OES SP2 и возник вопрос с переносом существующего сервера, я решил вновь попробовать поставить OES.
Сама установка прошла без проблем. На сервере с NetWare 5.1
запущен и настроен LDAP SSL и SLP. (соотвествующие порты открыты и принимают соединения, DISPLAY SLP SERVICES выдает доступные сервисы)
так же поднял SLP и на OES.
OES LDAP (в yast) сконфигурирован успешно.
пытаюсь через yast->Edirectory добавить сервер в дерево:
все этапы проверки портов и авторизация проходит успешно. Дальше следует настройка и установка Edirecotry:
Код: Выделить всё
Configuring and starting eDirectory
This will take a while.........
Configure and start eDirectory using "ndsconfig"

видно, что запущен поцесс ndsconfig:
/usr/bin/ndsconfig add -t KSU_TREE -n o=ksu -a slavrentev.civt.ksu -p 192.168.5.164:524 -d /var/nds/dib -L 389 -l 636 -o 8028 -O 8030
и по top видно, что процесс y2base сильно загружает си-му.
в логах NDSd /var/nds/ndsd.log все ок - ошибок нет, кроме как
Код: Выделить всё
NDS iMonitor 2.3.1 for Novell eDirectory v20210.67 started successfully.
Loader Failed:for dxevent,error dxevent: cannot open shared object file: No such file or directory,errno 2

но на novell.com я прочел, что они убрали его из последней Edirectory.
И вот этот этап висит очень долго, уже 5 часов.Иногда идет обмен пакетами между серверами :
Код: Выделить всё
:20:15.322083 IP xx.xx.x.x.ldap > yy.y.yy.y.12814: FP 45:45(0) ack 40 win 9064
00:20:15.322164 IP yy.y.yy.y.12814 > xx.xx.x.x.ldap: . ack 46 win 5840
00:20:15.322174 IP  lxx.xx.x.x.ldap > yy.y.yy.y.12815: . ack 32 win 7604


Пару раз, когда еще не был сконфигурирован SLP, это длилось минут 10-15 и завершалось ошибкой :
Код: Выделить всё
Unable to bind to eDirectory through LDAP

после которой я все абортил и делал ndsconfig rm -a.
Но теперь, все это зависло надолго ((.
Такое ощущение, что я что-то делаю не так )). Что-то упустил...
Само дерево в отличном стостоянии ,как сервер NetWare.

Может у кого была такая проблема. Просто я уже не знаю, где копать .

Заранее спасибо за ответы.
Последний раз редактировалось rocker 13 апр 2006, 00:54, всего редактировалось 2 раз(а).
rocker
 
Сообщения: 43
Зарегистрирован: 06 апр 2005, 19:51
Откуда: казань

пара ответов

Сообщение Павел Гарбар » 13 апр 2006, 00:43

dxevent - файл для IDM (ранее DirXML). Так они проверяют - установлен IDM или нет. С этим файлом не парься.
Про LDAP. Да, OES Linux пытается достучаться при инсталляции по 636 порту - надо или чтоб LDAP по SSL работал, или чтоб существующий LDAP принимал пароли открытым текстом (по умолчанию не принимает).
Павел Гарбар
 
Сообщения: 686
Зарегистрирован: 05 июн 2002, 09:36
Откуда: Санкт-Петербург

Сообщение rocker » 13 апр 2006, 08:56

в том-то и дело, что, как я понмаю, LDAP SSL поднят - идет обмен апкетами да и, если бы он был не поднят, не прошла бы аутентификация.

до сих пор идет обмен пакетами:
Код: Выделить всё
08:17:49.992896 IP 192.168.5.164.389 > 192.168.5.205.17598: P 1:45(44) ack 32 win 7604
08:17:49.992923 IP 192.168.5.205.17598 > 192.168.5.164.389: . ack 45 win 5840
08:17:49.993123 IP 192.168.5.205.17598 > 192.168.5.164.389: P 32:39(7) ack 45 win 5840
08:17:49.993158 IP 192.168.5.205.17598 > 192.168.5.164.389: F 39:39(0) ack 45 win 5840
08:17:49.993654 IP 192.168.5.164.389 > 192.168.5.205.17598: . ack 40 win 7596

обмен идет не очень активно, но он есть...
rocker
 
Сообщения: 43
Зарегистрирован: 06 апр 2005, 19:51
Откуда: казань

Вот еще

Сообщение Павел Гарбар » 13 апр 2006, 12:01

все же по 389 порту - а это открытый LDAP.
Павел Гарбар
 
Сообщения: 686
Зарегистрирован: 05 июн 2002, 09:36
Откуда: Санкт-Петербург

Сообщение rocker » 13 апр 2006, 12:52

636 порт тоже поднят. вроде бы были соединения и по нему....
rocker
 
Сообщения: 43
Зарегистрирован: 06 апр 2005, 19:51
Откуда: казань

Сообщение Орлов Алексей » 13 апр 2006, 15:53

Для проверки 636 порта воспользуйтесь любым браузеров для ldap, зайтите с правами admin и попробуёте что-нибудь создать в дереве или удалить, если получиться значит ldap работает и воткнуть linux в дерево должно получиться
Даёшь полный контроль над Юзверем!!!
-------------------------------------------------------
Я еще из тех, кто учился азбуке по букварю, а не по клавиатуре....

Иногда пишу в своем блоге на тему ms Lync, directaccess.
Аватара пользователя
Орлов Алексей
 
Сообщения: 953
Зарегистрирован: 04 июн 2003, 12:43
Откуда: Нижний Новгород

Сообщение rocker » 13 апр 2006, 20:15

попробовал сделать :
Код: Выделить всё
#[b]ldapsearch -h 192.168.5.164 -x -b cn=slavrentev,ou=civt,o=ksu[/b]

# extended LDIF
#
# LDAPv3
# base <cn=slavrentev,ou=civt,o=ksu> with scope sub
# filter: (objectclass=*)
# requesting: ALL
#

# SLavrentev, Civt, KSU
dn: cn=SLavrentev,ou=Civt,o=KSU
mail: Sergey.Lavrentev.ru
initials: -
givenName: Lavrentev
sn: Sergey
objectClass: inetOrgPerson
objectClass: organizationalPerson
objectClass: person
objectClass: top
objectClass: ndsLoginProperties

# search result
search: 2
result: 0 Success

# numResponses: 2
# numEntries: 1


кажется все проходит успешно....
rocker
 
Сообщения: 43
Зарегистрирован: 06 апр 2005, 19:51
Откуда: казань

Сообщение rocker » 15 апр 2006, 22:15

Кажется получилось )).
настроил клиента ldap, ну и все, что выше писал.
Правда, не смог создать реплику ( не создалась при инсталляции)
проблема описана здесь http://novell.org.ru/forum/viewtopic.php?t=7727&start=0&postdays=0&postorder=asc&highlight=
rocker
 
Сообщения: 43
Зарегистрирован: 06 апр 2005, 19:51
Откуда: казань


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1