SLES9+LDAP+SAMBA не хочет :)

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

SLES9+LDAP+SAMBA не хочет :)

Сообщение shubhar » 10 май 2005, 18:11

Проблема: Самба не пускает юзеров прописанных в LDAP, кроме самба-рута (он не в LDPAе). Юзеры на лок. станциях (Сузе9.2) логинятся в LDAP нормально. Хоумы по NFSу розданы. Но обращение к [homes]-ресурсам - отлуп.
Настраивалось все через YaST.
настройки SAMBA:
Advanced Settings... -> User Authentication Sources ->
LDAP | ldap://10.11.28.11
Файл smbpasswd
-----
Проверить LDAP подключение -> LDAP подключение впорядке.
-----

при попытке подцепиться к самба-ресурсу в логах вот чего:

/var/log/samba/log.smbd
[2005/05/10 17:57:40, 1] lib/smbldap.c:add_new_domain_info(1314)
failed to add domain dn= sambaDomainName=SL,dc=sales,dc=office,dc=com with: Invalid DN syntax invalid DN
[2005/05/10 17:57:40, 0] lib/smbldap.c:smbldap_search_domain_info(1363)
Adding domain info for SL failed with NT_STATUS_UNSUCCESSFUL
[2005/05/10 17:57:40, 0] lib/username.c:map_username(128)
can't open username map ldapsam:ldap://10.11.28.11. Error No such file or directory

что бы это значило? почему YaST не добавил в схему LDAP "sambaDomainName=SL" при настройке LDAP и САМБы? Мне нужно это руками вписать?

Отзовитесь, плиз, у кого работает!
shubhar
 
Сообщения: 20
Зарегистрирован: 28 дек 2004, 14:45

Сообщение Андрей Фисенко » 11 май 2005, 05:05

А шо за LDAP? Имени кого?
Андрей Фисенко
 
Сообщения: 1308
Зарегистрирован: 05 июн 2002, 08:13
Откуда: Красноярск

Re: SLES9+LDAP+SAMBA не хочет :)

Сообщение Dimerson » 11 май 2005, 05:26

shubhar писал(а):Проблема: Самба не пускает юзеров прописанных в LDAP, кроме самба-рута (он не в LDPAе). Юзеры на лок. станциях (Сузе9.2) логинятся в LDAP нормально. Хоумы по NFSу розданы. Но обращение к [homes]-ресурсам - отлуп.
Настраивалось все через YaST.
настройки SAMBA:
Advanced Settings... -> User Authentication Sources ->
LDAP | ldap://10.11.28.11
Файл smbpasswd
-----
Проверить LDAP подключение -> LDAP подключение впорядке.
-----

при попытке подцепиться к самба-ресурсу в логах вот чего:

/var/log/samba/log.smbd
[2005/05/10 17:57:40, 1] lib/smbldap.c:add_new_domain_info(1314)
failed to add domain dn= sambaDomainName=SL,dc=sales,dc=office,dc=com with: Invalid DN syntax invalid DN
[2005/05/10 17:57:40, 0] lib/smbldap.c:smbldap_search_domain_info(1363)
Adding domain info for SL failed with NT_STATUS_UNSUCCESSFUL
[2005/05/10 17:57:40, 0] lib/username.c:map_username(128)
can't open username map ldapsam:ldap://10.11.28.11. Error No such file or directory

что бы это значило? почему YaST не добавил в схему LDAP "sambaDomainName=SL" при настройке LDAP и САМБы? Мне нужно это руками вписать?

Отзовитесь, плиз, у кого работает!


создайте LDIF и добавьте с помощью slapadd. хотя судя по всему криво нстроено все . У меня работает.
Аватара пользователя
Dimerson
 
Сообщения: 2749
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Re: SLES9+LDAP+SAMBA не хочет :)

Сообщение shubhar » 11 май 2005, 11:21

LDAP имени краснознаменного и орденоносного SLES9 ;)
создайте LDIF и добавьте с помощью slapadd. хотя судя по всему криво нстроено все . У меня работает.

Руками я сделаю. Самбу просто не включал в LDAP до этого, ее просто не было на сервере. Вот решился на это. А криво настроить там трудновато - в YaSTе путей для маневра не много. Скажите, вы руками делали или через YaST?
shubhar
 
Сообщения: 20
Зарегистрирован: 28 дек 2004, 14:45

Re: SLES9+LDAP+SAMBA не хочет :)

Сообщение Dimerson » 11 май 2005, 11:35

shubhar писал(а):LDAP имени краснознаменного и орденоносного SLES9 ;)
создайте LDIF и добавьте с помощью slapadd. хотя судя по всему криво нстроено все . У меня работает.

Руками я сделаю. Самбу просто не включал в LDAP до этого, ее просто не было на сервере. Вот решился на это. А криво настроить там трудновато - в YaSTе путей для маневра не много. Скажите, вы руками делали или через YaST?


Я конечно жутко извиняюсь а проверить после yast'a конфиги слабо ?
Я честно скажу не то что Яста - даже Сузе линух не юзаю ....

:)
Аватара пользователя
Dimerson
 
Сообщения: 2749
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Re: SLES9+LDAP+SAMBA не хочет :)

Сообщение Михаил Григорьев » 11 май 2005, 13:35

Смотрим внимательно smb.conf, в нём должно быть что то похожее на это:

ldap admin dn = "cn=Manager,o=MyORG,c=RU"
ldap ssl = off
passdb backend = ldapsam:ldap://127.0.0.1
ldap delete dn = no
ldap suffix = o=MyORG,c=RU
ldap filter = (&(uid=%u)(objectClass=sambaSamAccount))
ldap passwd sync = yes
ldap group suffix = ou=Groups
ldap user suffix = ou=Users
ldap machine suffix = ou=Computers

Самба конектится к LDAP с правами cn=Manager,o=MyORG,c=RU
Можно заново прописать для него пароль, возхможно YaST его не прописал куда нужно.

Во FreeBSD пароль лежит здесь: /usr/local/private/secrets.tdb
smbpasswd -w LDAP_MANAGER_PASSWORD

shubhar писал(а):что бы это значило? почему YaST не добавил в схему LDAP "sambaDomainName=SL" при настройке LDAP и САМБы? Мне нужно это руками вписать?


Вообще то его sambaDomainName прописывает сама самба при запуске, если его нет то скорее всего самба не подцепилась к LDAP
Аватара пользователя
Михаил Григорьев
 
Сообщения: 1461
Зарегистрирован: 04 июн 2002, 12:22
Откуда: Челябинск

Re: SLES9+LDAP+SAMBA не хочет :)

Сообщение shubhar » 11 май 2005, 18:34

2 all

разобрался! проблема была в DNS. Я его поставил но не конфигурял, т.к. DNS живет на другом сервере. А то что локальный DNS был, но не был настроен, оказалось почему то критично для самбы. Удалил DNS и все заработало
Спасибо всем за советы!
shubhar
 
Сообщения: 20
Зарегистрирован: 28 дек 2004, 14:45


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron