Sybase 12.5 и SLES 9

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Sybase 12.5 и SLES 9

Сообщение Temka » 06 фев 2005, 20:00

Доброго времени суток, Уважаемые.
На сервере стоит SLES 9 (Suse Linux Server ядро 2.6.х), поставил Sybase 12.5
Вот последовательность моих действий...
1.Устанавливаю пакеты
sybase-common....
sybase-ase...
sybase-openclient....
2.Делаю принудительно пользователя sybase (он автоматически создается при установке, как и группа sybase) владельцем директори /opt/sybase-12.5 командой: chown -R sybase /opt/sybase-12.5
3.Перелогиниваемся под пользователем sybase, подсовываю лицензионный файл, в логе получаю

20:54:05 (lmgrd) FLEXlm (v6.1g) started on linux (linux) (2/3/2005)
20:54:05 (lmgrd) FLEXlm Copyright 1988-1999, Globetrotter Software, Inc.
20:54:05 (lmgrd) US Patents 5,390,297 and 5,671,412.
20:54:05 (lmgrd) World Wide Web: http://www.globetrotter.com
20:54:05 (lmgrd) License file(s): /opt/sybase-12.5/SYSAM/licenses/license.dat
20:54:05 (lmgrd) lmgrd tcp-port 29722
20:54:05 (lmgrd) Starting vendor daemons ...
20:54:05 (lmgrd) Started SYBASE (internet tcp_port 32773 pid 5935)
20:54:05 (SYBASE) FLEXlm version 6.1g
20:54:05 (SYBASE) Server started on linux for: ASE_SBE


под root надо даю команду echo '256*1024*1024' | bc > /proc/sys/kernel/shmmax

4. Копирую в папку locales файлы с русской кодировкой
5. запускаю из консоли asecfg
получаю

./asecfg: relocation error: ./asecfg: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

подскажите, что делать.
Спасибо
Temka
 
Сообщения: 2
Зарегистрирован: 06 фев 2005, 19:56

Re: Sybase 12.5 и SLES 9

Сообщение biruk » 07 фев 2005, 22:54

./asecfg: relocation error: ./asecfg: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

подскажите, что делать.
Спасибо

почитать мануал.
видимо, установлена другая версия библитеки.
посмотри куда указывает симлинк /lib/libc.so.6
у меня на
Код: Выделить всё
# ll /lib/libc.so.6
lrwxrwxrwx    1 root     root           13 Oct 29 20:36 /lib/libc.so.6 -> libc-2.3.3.so*

может сайбезу нажна более старая библиотека?
[/quote]
biruk
 
Сообщения: 111
Зарегистрирован: 21 янв 2004, 14:20

Сообщение Temka » 08 фев 2005, 23:21

Странно у меня libc.so.6 не симлинк, эт реальный файл, а вот libc-2.3.3.so нету есть только ld-2.3.3.so
никаких левых пакетов не ставил, только то, что шло в комплекте SLES
Temka
 
Сообщения: 2
Зарегистрирован: 06 фев 2005, 19:56

Сообщение Dimerson » 10 фев 2005, 19:36

Temka писал(а):Странно у меня libc.so.6 не симлинк, эт реальный файл, а вот libc-2.3.3.so нету есть только ld-2.3.3.so
никаких левых пакетов не ставил, только то, что шло в комплекте SLES


надо покурить доку к Sybase на предмет требуемой версии glibc.

Если надо более старую - можно попробовать ее подсунуть через LD_PRELOAD ...

Как по вашему работает Oracle 8.1.7.4 на версиях Linux с несовместимо-новыми glibc ?

:)
Аватара пользователя
Dimerson
 
Сообщения: 2778
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Сообщение biruk » 10 фев 2005, 19:54

Temka писал(а):Странно у меня libc.so.6 не симлинк, эт реальный файл, а вот libc-2.3.3.so нету есть только ld-2.3.3.so
никаких левых пакетов не ставил, только то, что шло в комплекте SLES

еще более странно...
сечас глянул и в слаке и в трастиксе - одинаково:
libc-2.3.3.so - файл
libc.so.6 - симлинк
biruk
 
Сообщения: 111
Зарегистрирован: 21 янв 2004, 14:20


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron