OES 11.1 KVM-QEMU

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

OES 11.1 KVM-QEMU

Сообщение Сумин Евгений » 01 дек 2016, 13:05

Здравствуйте!
При использовании KVM-QEMU столкнулся с проблемой - сервер периодически после запуска нескольких виртуальных машин падает, причем период жизни достаточно произвольный (может несколько часов, а может и несколько дней проработать).

Может кто сталкивался с такой проблемой? Подскажите, куда копать?
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Re: OES 11.1 KVM-QEMU

Сообщение Павел Гарбар » 02 дек 2016, 08:46

Какие-нибудь сообщения перед падением оставляет? Падение - это просто все замирает и ничего не шевелится или самопроизвольно выключается или в перезагрузку уходит? На мониторе есть артефакты?
Ну и простой вопрос - памяти хосту хватает для всех виртуалок или они занимают всю память без остатка?
Павел Гарбар
 
Сообщения: 686
Зарегистрирован: 05 июн 2002, 09:36
Откуда: Санкт-Петербург

Re: OES 11.1 KVM-QEMU

Сообщение Сумин Евгений » 03 дек 2016, 16:02

Памяти хватает - там 32Г а используется меньше половины.
Сервер уходит в перезагрузку. Т.к. процесс происходит в непредсказуемое время - мне за неделю так и не удалось его пронаблюдать... В логах никаких сообщений нет. Создает дамп в /var/crash но что с ним можно сделать - я не знаю...

Память пробовал менять - не помогло.
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Re: OES 11.1 KVM-QEMU

Сообщение Павел Гарбар » 04 дек 2016, 21:14

Похоже на аппаратную проблему.
Последние несколько месяцев в разных конторах наблюдаю схожие симптомы. Компьютеры разные. При обычной работе (чаще при обращении к диску) система замирает (Win разных версий), а потом просто уходит в перезагрузку. Часто после этого слетают настройки BIOS - приходится выставлять заново, а то не грузится с нужного диска.
Павел Гарбар
 
Сообщения: 686
Зарегистрирован: 05 июн 2002, 09:36
Откуда: Санкт-Петербург

Re: OES 11.1 KVM-QEMU

Сообщение Сумин Евгений » 04 дек 2016, 22:58

а это проблема именно KVM или любой виртуалки? - нет данных например по VMWare?

и еще у меня в качестве диска на котором лежат файлы виртуалок используется софтовый линуксовый рэйд... Это не может быть причиной? КАк у других?
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Re: OES 11.1 KVM-QEMU

Сообщение sovchik » 17 дек 2016, 14:08

на софтовом рэйде и xen-е (он тоже на qemu основывается) проблем - тьфу-тьфу - не наблюдаю.
sovchik
 
Сообщения: 311
Зарегистрирован: 31 июл 2012, 23:06
Откуда: Ярославль


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1