Установка Zen 11.2 на SLES 11.2

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Установка Zen 11.2 на SLES 11.2

Сообщение sovchik » 22 ноя 2012, 16:58

В процессе установки Zen 11.2 на SLES 11.2 с использованием sybase столкнулся со следующей проблемой: инсталяция доходит почти до конца и останавливается с ошибкой создания базы. За подробностями отсылают в лог. В логе присутствует тьма вот таких сообщений

<MessageID><![CDATA[0000]]></MessageID><MessageString><![CDATA[Creating Database]]></MessageString><Severity><![CDATA[1]]></Severity><Time><![CDATA[1353575695197]]></Time><Source><![CDATA[Unknown Device]]></Source><ComponentName><![CDATA[Server Install]]></ComponentName><AdditionalInfo /></Message>
<Message><MessageID><![CDATA[0000]]></MessageID><MessageString><![CDATA[DB Creation ( /opt/novell/zenworks/share/sybase/bin/dbinit ) tool failed with return code: 1]]></MessageString><Severity><![CDATA[8]]></Severity><Time><![CDATA[1353575695861]]></Time><Source><![CDATA[Unknown Device]]></Source><ComponentName><![CDATA[Server Install]]></ComponentName><AdditionalInfo><![CDATA[com.novell.zenworks.configure.ConfigureException: DB Creation ( /opt/novell/zenworks/share/sybase/bin/dbinit ) tool failed with return code: 1
at com.novell.zenworks.configure.actions.db.DatabaseConfigureAction.configure(DatabaseConfigureAction.java:272)
at com.novell.zenworks.configure.ZENworksConfigure.execConfigAction(ZENworksConfigure.java:1671)
at com.novell.zenworks.install.customcode.configure.BaseZenConfigAction.install(BaseZenConfigAction.java:60)
at com.zerog.ia.installer.actions.CustomAction.installSelf(DashoA10*..)
at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)
at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)
at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)
at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)
at com.zerog.ia.installer.GhostDirectory.install(DashoA10*..)
at com.zerog.ia.installer.InstallablePiece.install(DashoA10*..)
at com.zerog.ia.installer.Installer.install(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
at com.zerog.ia.installer.Main.main(DashoA10*..)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(DashoA10*..)
at com.zerog.lax.LAX.main(DashoA10*..)
Caused by: com.novell.zenworks.datamodel.exceptions.InternalDataModelException: DB Creation ( /opt/novell/zenworks/share/sybase/bin/dbinit ) tool failed with return code: 1
at com.novell.zenworks.configure.actions.db.SybaseDatabaseConfigure.createDatabase(SybaseDatabaseConfigure.java:198)
at com.novell.zenworks.configure.actions.db.DatabaseConfigureAction.configure(DatabaseConfigureAction.java:198)
... 19 more
]]></AdditionalInfo></Message>


Документация советует ставить Zen 11.2.1 или выше. Но вот проблема в том, что нет отдельного дистрибутива Zen 11.2.1, есть только Zen 11.2.
Статьи предлагают ставить сначала SLES 11.1, на него Zen 11.2, обновлять Zen его средствами, а потом уже поднимать сервер до 11.2.
У меня сервер уже есть и переставлять его не хотелось бы.

Посоветуйте, как можно исправить эту ошибку.
sovchik
 
Сообщения: 309
Зарегистрирован: 31 июл 2012, 23:06
Откуда: Ярославль

Re: Установка Zen 11.2 на SLES 11.2

Сообщение Антон Фридрих » 23 ноя 2012, 10:16

Я же вам указал решение в предыдущем посте.

Прочитайте ТИД http://www.novell.com/support/kb/doc.php?id=7010332 и все заработает
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Re: Установка Zen 11.2 на SLES 11.2

Сообщение sovchik » 23 ноя 2012, 16:01

1. TID относится к external sybase, я пытаюсь использовать embedded. Не пытаться и использовать external?
2. TID относится к обновлению уже установленного zenwork-а, а у меня проблемы с первоначальной инсталяцией.
sovchik
 
Сообщения: 309
Зарегистрирован: 31 июл 2012, 23:06
Откуда: Ярославль

Re: Установка Zen 11.2 на SLES 11.2

Сообщение Dimerson » 24 ноя 2012, 16:05

а если заюзать эестернал а потом экспорт-импорт на вшитую ? обычно дамп с младшей версии на старшую заливать можно ... посему не юзать самую новую субд снаружи.
Аватара пользователя
Dimerson
 
Сообщения: 2758
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Re: Установка Zen 11.2 на SLES 11.2

Сообщение sovchik » 26 ноя 2012, 12:53

попытка, не пытка - попробуем
sovchik
 
Сообщения: 309
Зарегистрирован: 31 июл 2012, 23:06
Откуда: Ярославль

Re: Установка Zen 11.2 на SLES 11.2

Сообщение Антон Фридрих » 26 ноя 2012, 16:32

Вам необходимо обновить пакет CASA, в TID идет речь об обновлении sybase-asa. Проблема наблюдалась на external DB, но есть несколько инцидентов, когда мы видели проблем и на embedded
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Re: Установка Zen 11.2 на SLES 11.2

Сообщение sovchik » 01 дек 2012, 15:53

CASA обновлён до последней версии из репозиториев обновления OES. До чего ещё его необходимо обновить?

попробовал следовать по длинному пути: поставить на SLES 11.1, а потом обновится до SLESL 11.2 - сработало. Пришлось только сделать вот что:
1. ставить сначала sybase, а потом уже ZENworks (указывая при инсталяции, что это remote sybase)
2. в файле /etc/ld.so.conf пришлось дописать пути до библиотек, иначе он их не видел.
В итоге, на SLES 11.1 поставился ZENworks 11.2. Потом его обновил до 11.2.1. Обновил SLES до 11.2 и потом обновил ZENworks до 11.2.2.
При обновлении до ZENworks 11.2.1 пакет sybase поставил изначально руками (как по TID-у). Всё работает, ZENworks доступен.

Вопрос правда остаётся - как поставить с нуля (а не обновить имеющийся) ZENworks 11 на SLES 11.2 (уж если быть точным, то на OES 11 sp1). Снести тот сервер и поставить заново - не вариант: там уже есть задачи, их снимать не хочется.

upd: попробовал установку на другом OES 11 sp1 - при установке базы выдаёт ошибку при установке и предлагает только отменить установку. Попробовал команды создания базы выполнить из консоли - первая же команда говорит "не могу запустить базу данных, ошибка -80". Ошибки одинаковы на обеих OES машинах.
sovchik
 
Сообщения: 309
Зарегистрирован: 31 июл 2012, 23:06
Откуда: Ярославль


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron