Нужно провести глобальное обновление, нужны советы

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 16 мар 2011, 15:09

Ситуация такова.
Несколько серверов с OES2SP1 Linux, один из них кластерный
Около 2 лет обновления не накатывались.
Также стоит GW8 в кластере.
Нужно обновить OES2 до SP3
GW8 также надо обновить до последнего HP

Если я буду обновлять с iso образов, будут ли какие-либо нюансы?
Насколько я понимаю, надо запустить установку и продукт предложит обновление.

Очень интересует опыт обновления.
Как лучше.

Последовательность обновления OES уже найдена, немного непонятно с последовательностью обновления SLES (она, как я понимаю, сможет обновиться с NU)

В данный момент собираю тестовый контур, буду пробовать на нём.
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение $erg » 16 мар 2011, 17:06

alterkpn писал(а):Последовательность обновления OES уже найдена, немного непонятно с последовательностью обновления SLES (она, как я понимаю, сможет обновиться с NU)

В данный момент собираю тестовый контур, буду пробовать на нём.

http://novell.org.ru/forum/viewtopic.php?f=6&t=11127тут есть немного описания, не все что работает на тестовом - работает на боевом.
$erg
 
Сообщения: 231
Зарегистрирован: 05 май 2005, 12:18
Откуда: Minsk, Belarus

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 16 мар 2011, 18:17

Вот завтра и буду пробовать обновление посредством YAST
Отработает корректно или нет - пока непонятно.
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 17 мар 2011, 15:40

Совсем запутался - через YAST как-то не хочет обновляться с инсталляционных дисков более новой версии.
Подскажите каким образом лучше с них обновлять. :(
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 17 мар 2011, 18:56

Ничего не понимаю!
Попробовал обновить с SP1 на SP2 - остался SP1, начал смотреть - пакеты OES показываются ястом как защищённые.
Где я ошибся?
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение Dimerson » 18 мар 2011, 14:05

чем смотрите ... что кажет SPident -vv ? помнится после какого-то SP надо было SPident апдейтить чтоб все было ОК.
Аватара пользователя
Dimerson
 
Сообщения: 2778
Зарегистрирован: 15 сен 2002, 14:39
Откуда: Регион 70

Re: Нужно провести глобальное обновление, нужны советы

Сообщение Антон Фридрих » 20 мар 2011, 19:05

Что значит защищенные? Вы загрузились с диска и подсунули ему SP3? Они защищенные пока не проапдейтится установщик, но и даже тогда я не припомню проблем с установкой галочек.
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 21 мар 2011, 18:23

:~ # rug up
Resolving Dependencies...

ERROR: Dependency resolution failed:
Unresolved dependencies:
Updating novell-migration-gui-base-2.0.0-0.26.x86_64[System packages] to novell-migration-gui-base-2.0.1-0.22.x86_64[-20110317-153222]
novell-client-script-2.0.1-0.12.x86_64[-20110317-153222] needed by novell-migration-gui-base-2.0.1-0.22.x86_64[-20110317-153222]
Installing novell-client-script-2.0.1-0.12.x86_64[-20110317-153222]
novell-qtgui-cli-3.0.2-0.9.x86_64[Novell Open Enterprise Server 2 SP3-20110321-123347] needed by novell-client-script-2.0.1-0.12.x86_64[-20110317-153222]
Installing novell-qtgui-cli-3.0.2-0.9.x86_64[Novell Open Enterprise Server 2 SP3-20110321-123347]
novell-ui-base-3.0.1-0.10.x86_64[-20110317-153222] provides libLDAP.so()(64bit), but has another architecture.
There are no installable providers of libLDAP.so()(64bit) for novell-qtgui-cli-3.0.2-0.9.x86_64[Novell Open Enterprise Server 2 SP3-20110321-123347]

Обновление вроде бы прошло без ругательств, но iManager выдаёт ошибку 503
версия всё равно осталась 2.0.1
И вышенаписанное выдаётся по при rug up

Голову уже сломал.
Как теперь разрешить зависимости просто не представляю.
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение Антон Фридрих » 22 мар 2011, 08:47

Основная проблемная строчка это

novell-ui-base-3.0.1-0.10.x86_64[-20110317-153222] provides libLDAP.so()(64bit), but has another architecture.
Аватара пользователя
Антон Фридрих
 
Сообщения: 606
Зарегистрирован: 09 фев 2006, 07:55
Откуда: Красноярск

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 22 мар 2011, 09:43

А вот как с ней бороться?
Не подскажете?
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 30 мар 2011, 15:01

Получилось Online Update, за всё спасибо.
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08

Re: Нужно провести глобальное обновление, нужны советы

Сообщение alterkpn » 04 май 2011, 09:40

Большое спасибо всем, кто помог.
Обновились корректно и OES2 и GW8
Работают после обновления куда лучше (например у GW заработала у всех пользователей прозрачная аутентификация).
Так что GW8 HP 2 ставить советую - спокойнее на душе становится.
alterkpn
 
Сообщения: 46
Зарегистрирован: 10 дек 2010, 12:08


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron