oes2sp2 and iprint

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

oes2sp2 and iprint

Сообщение Андрей Баталов » 26 ноя 2009, 18:15

Поставил на тестовую машину
oes2sp2 Столкнулся тут проблемой iprint После создания принтера и попытки установки его через http://host/ipp в мозилле
просто белый экран в ослике что 7 что 8 вываливается iprntmsg.js
с сообщением ipd printer not installed Поиск выкидывает в лохматый 2004 и проблемы на nw6.5sp? клиент iprint установлен да при логине в рабочий констекст все нормально принтеры устанавливается Хочется спросить это я один такой счастливый и чего то не прочитал или у всех так
Андрей Баталов
 
Сообщения: 8
Зарегистрирован: 02 июл 2007, 21:08

Сообщение Sergant » 26 ноя 2009, 18:30

А из под IE пробовали ?
Кстати эксперементальную машину ставили в отдельное дерево или боевое ?
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение Андрей Баталов » 27 ноя 2009, 14:10

Sergant писал(а):А из под IE пробовали ?
Кстати эксперементальную машину ставили в отдельное дерево или боевое ?

Пробовал и под IE, результат тот же. Ставил в отдельное тестовое дерево с нуля с последними обновлениями
Андрей Баталов
 
Сообщения: 8
Зарегистрирован: 02 июл 2007, 21:08

Сообщение Sergant » 03 дек 2009, 19:08

Андрей Баталов

Сдается мне, что это глюк SP2. На http://forums.novell.com он отмечен, так что ждем исправлений (SP2a ?)

ЗЫ: в SP2 почему-то конкретно не повезло iPrint-у :(
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение Sergant » 15 дек 2009, 15:44

Вот предложено решение данной проблемы на http://forums.novell.com но для немецого языка.
Попробуйте для русского.

The /var/opt/novell/iprint/htdocs/nls/de/iprntmsg.js file, which is
installed by OES2 SP2, contains unescaped quotation marks (") in the
middle of a text string, thus leading to script errors which result in
failure of attempts to install a printer or to check the installation
status of the printer.

If you encounter this problem just add a backslash (\) before each
quotation mark (") in the middle of the text string in line 131 - or
delete the quotation marks (") in the text string on this line in the
above mentioned file.

SP1 had a similar string but with backslashes.

Why do such new errors get introduced into old code ???? - This bug is
the proof, that absolutely nobody ever tested this script, before
releasing it. And that is something, which should never happen at all.

--
W. Prindl


ЗЫ: Проверил - работает.
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение Андрей Баталов » 15 дек 2009, 18:23

Подтверждаю, действительно работает.
Спасибо большое.
Андрей Баталов
 
Сообщения: 8
Зарегистрирован: 02 июл 2007, 21:08

Сообщение Sergant » 16 дек 2009, 14:43

А тем временем OES2SP2 не доступен для скачивания... В секции Open Enterprise Server нет даже ссылки ссылки на него.
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва

Сообщение Timur Kazimirov » 17 дек 2009, 11:34

Sergant писал(а):А тем временем OES2SP2 не доступен для скачивания... В секции Open Enterprise Server нет даже ссылки ссылки на него.

Да есть - http://download.novell.com/Download?bui ... E531TUqlg~
Timur Kazimirov
 
Сообщения: 1153
Зарегистрирован: 10 фев 2004, 09:56
Откуда: Южно-Сахалинск

Сообщение Sergant » 17 дек 2009, 11:48

Timur Kazimirov писал(а):Да есть - http://download.novell.com/Download?bui ... E531TUqlg~


Угу, тока уже SP2a. Но сегодня.
Sergant
 
Сообщения: 330
Зарегистрирован: 22 сен 2006, 14:41
Откуда: Москва


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

cron