Server halted.... Может чего не так делаю???

Обсуждение технических вопросов по продуктам Novell

Server halted.... Может чего не так делаю???

Сообщение Радев Валерий » 06 ноя 2002, 14:27

Здравствуйте. Периодически (1...2 раза в месяц) на консоли сервера появляется вот такое сообщение:

11-05-2002 12:22:43 pm: SERVER-5.0-4631 [nmID=1001C]
WARNING! Server MELITOPOL2 experienced a critical error. The offending
process was suspended or recovered. However, services hosted by this
server may have been affected.


А в файле abend.log вот какая вот информация:

Server MELITOPOL2 halted Tuesday, November 5, 2002 12:22:39 pm
Abend 1 on P00: Server-5.00a: Page Fault Processor Exception (Error code 00000000)

Registers:
CS = 0008 DS = 0010 ES = 0010 FS = 0010 GS = 0010 SS = 0010
EAX = D460280C EBX = D4262DC9 ECX = 00000064 EDX = 00000000
ESI = D4602820 EDI = D3C03820 EBP = D4602A18 ESP = D4602428
EIP = D3BFDF67 FLAGS = 00010292
D3BFDF67 803B2F CMP [EBX]=?,2F
EIP in BTRIEVE.NLM at code start +0002DF67h

Running process: BSPX Worker 5 Process
Created by: NetWare Application
Thread Owned by NLM: BSPXCOM.NLM
Stack pointer: D4602A74
OS Stack limit: D45FEB00
Scheduling priority: 67371008
Wait state: 5050030 (Blocked on Semaphore)
....
....
Additional Information:
The CPU encountered a problem executing code in BTRIEVE.NLM. The problem may be in that module or in data passed to that module by a process owned by BSPXCOM.NLM.


Наличие Btrieve 6.15- обязательное, работает около 100(+/-10) пользователей, из них с Btrieve около 40...50. (Система "БЭСТ:ЗВИТ 4.0" от ЗАО "Интелект сервис", г. Киев)

Novell 5.0 без сервис-паков, т.к. при установке SP6a - напрочь отказывается работать приложение использующее Btrieve, а перейти на Pervasive 2000 как то не получается, как я его не нагинал...

О железе: i810, Р3-500Mhz, DIMM 256 Mb, HDD 40Gb IDE+10Gb IDE, Intel Pro10/100 - 2 шт., коммутаторы BayStack420-24T, CKC категория 5е.

О наличии НОРМАЛЬНОГО СЕРВЕРНОГО железа рассказывать не надо, сам знаю, но организация - бюджетная и на СЕРВЕР пока денег нет.

Причем, даже после этой ошибки вродебы все работает, в том числе и Btrieve.
Аватара пользователя
Радев Валерий
 
Сообщения: 36
Зарегистрирован: 05 июн 2002, 14:24
Откуда: Мелитополь

Сообщение Мещеряков Андрей » 06 ноя 2002, 16:56

Приветствую!
Скорее всего у вас "сыпется" память. Сервера, собранные на памяти без ECC рекомендуется выключать на ночь.. не для предохранения от несчастных случаев, а что бы сбросить возможные ошибки. В крайнем случае просто перегружать, с тем же эффектом. То, что за исключением этого работает все нормально, значит ошибка не программная. Раз денег нет, попробуйте поискать старую плату хорошего производителя на I440BX и купите DIMM с ECC. А после установки поищите в Setup е платы опции включения ЕСС и включите ее. Наверняка полегчает.

С уважением And
Аватара пользователя
Мещеряков Андрей
 
Сообщения: 1999
Зарегистрирован: 19 сен 2002, 14:55
Откуда: lipetsk

Возможно глючный драйвер RTL8029 на станциях.

Сообщение Boris Morozov » 06 ноя 2002, 23:09

Была у нас когда-то такая фишка. Если не дай бог драйвер от винды, то усе - могила. Убивать немедленно и ставить с Realtek.

А по поводу PVSW 2000 - все должно работать, обновите brequest, но не из SP3 с поддержкой каличного миллениума, а из SP2 - 98 года.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 4

cron