TCP/IP +NW5.1 как Роутер и ping с W98Se = Помогите понять

Обсуждение технических вопросов по продуктам Novell

TCP/IP +NW5.1 как Роутер и ping с W98Se = Помогите понять

Сообщение skoltogyan » 11 окт 2002, 10:56

W98SE-------(0)NW5.1(1)-----(2)NW5.1(3)---

Установил на W98 LanAnalyzer.

C W98 делаю ping интерфейса (0).
И станция и сервак в одном свиче.
Подсеть: 192.168.0.0/255.255.255.0

На станции IP: 192.168.0.10/255.255.255.0
(0)= 192.168.0.2
На станции указано, что default router 192.168.0.2.


C w98 запускаю Аналайзер и подаю команду:
1. ping 192.168.0.2 -l 1444 -n 1
Нормально припингивает, а в аналайзере вижу 2 пакета:
size=1490
Туда - Type=Echo Request
Овет - Type=Echo Reply

2. ping 192.168.0.2 -l 1445 -n 1
Нормально припингивает(
Ответ от 192.168.0.2: число байт=1445 время=2мс TTL=128
), а в аналайзере вижу 3 пакета:
Туда:
1-ый пакет Type=Echo Request;Checksum ERROR size=1486
2-ой пакет Type=7800;Checksum ERROR size=64
Оттуда:
3-ий пакет Type=Echo Reple size=1491

Таким образом, даже если пинговать только интерфейс, что рядом (не зароутером) при -l 1445 и больше, в аналайзере вижу ChecksummError.
Если -l 1444 и меньше, то все нормально.

Это нормально ?
skoltogyan
 
Сообщения: 1885
Зарегистрирован: 12 июл 2002, 19:39
Откуда: Украина, Донецк

Сообщение Citra » 11 окт 2002, 16:44

Смоделировал ту же ситуацию, что и у Вас и наблюдал ту же картину.
В колонке Error пусто. Возможно, это диагностическое сообщение
ICMP. На сервере MTU=1500 и может с этим связано сообщение
Checksumm Error. А рабочая станция под чистым IP-Novell клиентом
работает нормально и в Internet тоже. Еще посмотрю SnifferPro,
сообщу в понедельник.
Citra
 
Сообщения: 20
Зарегистрирован: 25 сен 2002, 13:13

?

Сообщение skoltogyan » 11 окт 2002, 16:51

А при ping замечали, что станция каждый раз перед тем, как Отправить icmp пакет, зачем-то обращается к серверу на 524 ?

И.. на серваке насильно ставилии MTU=1500 И use specife MTU=on ?
ИЛи ставили mtu=1522 ?
skoltogyan
 
Сообщения: 1885
Зарегистрирован: 12 июл 2002, 19:39
Откуда: Украина, Донецк

Сообщение Citra » 14 окт 2002, 17:10

С рабочей станции 192.168.1.7:
ping 192.168.1.254 -l 4096 (это сервер)
SnifferPro выдает следующее:

ICMP: ----ICMP header----

Type = 8 (Echo)
Code=0
Checksum = 53A6 (correct)
Identifier = 256
Sequence number = 19200
[4096 bytes of data]
[Normal end of "ICMP header".]

В секции Ethernet frames:

summary len

ICMP: Echo 1514
IP: D=[192.168.1.254] S=[192.168.1.7] LEN=1480 ID=33354 1514
IP: Continuation of ident=33354
IP: D=[192.168.1.254] S=[192.168.1.7] LEN=1144 ID=33354 1178
IP: Continuation of ident=33354
ICMP: Echo reply 1514
IP: D=[192.168.1.7] S=[192.168.1.254] LEN=1480 ID=14372 1514
IP: Continuation of ident=14372
IP: D=[192.168.1.7] S=[192.168.1.254] LEN=1144 ID=14372 1178
IP: Continuation of ident=14372

Ну и так 4 раза.
Короче говоря, ошибок вроде нет. Похоже, LANalyzer 2.2 некорректно
обрабатывает фрагментацию IP-пакетов или делает это по своему
(приложение, по-моему, 16-разрядное). Я, кстати, пинговал сервер
FreeBSD и наблюдал LANalyzer-ом ту же картину, что и на NW5.0.
На сервере NW50 MTU=1500.






[/img]
Citra
 
Сообщения: 20
Зарегистрирован: 25 сен 2002, 13:13


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 3

cron