Помогите отыскать неисправность...

Обсуждение технических вопросов по продуктам Novell

Вот так получается...

Сообщение ProRus » 12 окт 2004, 07:37

Андрей Тр. aka RH писал(а):Тормозит даже на мелких файлах ? При этом тормозит как и при копировании с сервера, так и при копировании на сервер ? Зависит ли от того, на какой его том копировать - скажем, если скачать что-нить с SYS ? Какие вообще тома - NSS и/или TFS ? При торможении что происходит с утилизацией CPU ( какова нагрузка ) ? Ну и хорошо бы параметры кэша посмотреть ( для соотв. файловых систем, соответственно ). Какая версия клиента .. какой используется протокол - на проблемном сервере и на остальных, где летает ?

Тормозит на всем... :( Загрузка процессора при этом не более 25 процентов). Копирование в обе стороны одиинаково... Скорость увеличивается если копировать на полупустой том, уменьшается если на забитый. Система TFS с жатием и 64 блоком. Летает при копировании Winda - Winda.

Тут потестил:
Получилось...
Сервер:
Голый 5.1. сервер без паков + 3Com905 + RAID 5 (34 Гб) + 512 ОЗУ.
Создал том SYS - 9Гб (64к + компрессия), PROBA - 10 Гб (64к без компрессии), PROBA2 -15Гб (4к без компрессии).

Клиент:
Windows 2000 + NwClient 4.90 SP1a

При поднятом TCP
файл 406 мб копируется на том SYS 2,25 мин.
файл 406 мб копируется на том PROBA 2,20 мин.
файл 406 мб копируется на том PROBA2 2,35 мин.

При поднятом IPX
файл 406 мб копируется на том SYS 2,50 мин.
файл 406 мб копируется на том PROBA 2,40 мин.
файл 406 мб копируется на том PROBA2 2,35 мин.

Получается что средняя скорость 180 мегобайт в минуту.
Разве это нормально при сетке 100 Мб?
Пробные компутеры были подключены напрямую кабелем.

При копировании с сервера Windows 2000 даже через свитчь скорость порядка 500-700 мегобайт в минуту.

Где что не так? Что подправить?
Еслиб не моя любовь в Novell'у ужеб давно перевел все под AD. :wink:
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Re: Вот так получается...

Сообщение Сергей Дубров » 12 окт 2004, 08:33

ProRus писал(а):Получается что средняя скорость 180 мегобайт в минуту.
Разве это нормально при сетке 100 Мб?
Пробные компутеры были подключены напрямую кабелем.

При копировании с сервера Windows 2000 даже через свитчь скорость порядка 500-700 мегобайт в минуту.

Зачем врать-то? Сетка 100мбит => предельная скорость будет порядка 10мбайт/сек или ~600мбайт/мин. Но 10мбайт/сек - это крайне редко достижимый идеал, так что про 700 вы погорячились.

А вот у меня на 5.1 стабильно 8-9мбайт/сек, и даже когда клиентов больше, чем один. "Что я делаю неправильно?" (с) :lol:
Аватара пользователя
Сергей Дубров
 
Сообщения: 2081
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Re: Вот так получается...

Сообщение ProRus » 12 окт 2004, 09:19

Сергей Дубров писал(а):Зачем врать-то? Сетка 100мбит => предельная скорость будет порядка 10мбайт/сек или ~600мбайт/мин. Но 10мбайт/сек - это крайне редко достижимый идеал, так что про 700 вы погорячились.

А вот у меня на 5.1 стабильно 8-9мбайт/сек, и даже когда клиентов больше, чем один. "Что я делаю неправильно?" (с) :lol:


Ну ладно, погарячился. :) но как добиться хоть ваших результатов?
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Сообщение Андрей Тр. aka RH » 12 окт 2004, 09:50

Хм .. ради интереса закачал сейчас 1.1Гб файл на 5.1SP7 - за порядка 3 мин, т.е. около 6Мб ( реальных ) / с. Тот же файл с 6.5SP2 с гигабитной сетевой скачался за 160 с. Тома везде, правда, NSS.

Может, дело в вашем RAIDe ? И еще я не понял, какой смысл что-либо пробовать на голом сервере, без каких-либо SP ? Если не 7-ой, то какой-то из поновее поставьте для начала.
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

Сообщение Станислав Дронкин » 14 окт 2004, 20:57

Не знаю как у коллеги, а у меня все решилось. SP7 не причем. При внимательном изучении информации на консоле, обнаружилась старая как мир проблема: порт на свиче - 100 Full Duplex, сетевая карта - 100 Half Duplex. Не обратил сразу внимания, т.к. на свиче режим установлен принудительно и обычно этого было достаточно. Установил на сетевой карте жестко 100FDX - всё в норме (6-9 мб/с). Спасибо за внимание. :-)
Станислав Дронкин
 
Сообщения: 56
Зарегистрирован: 19 июн 2002, 15:33
Откуда: Саратов

Сообщение PavelKHTW » 14 окт 2004, 22:15

Станислав Дронкин писал(а):Не знаю как у коллеги, а у меня все решилось. SP7 не причем. При внимательном изучении информации на консоле, обнаружилась старая как мир проблема: порт на свиче - 100 Full Duplex, сетевая карта - 100 Half Duplex. Не обратил сразу внимания, т.к. на свиче режим установлен принудительно и обычно этого было достаточно. Установил на сетевой карте жестко 100FDX - всё в норме (6-9 мб/с). Спасибо за внимание. :-)

- Чтобы не было
Не обратил сразу внимания, т.к. на свиче режим установлен принудительно и обычно этого было достаточно.
советую всем почитать статью на cisco.com Troubleshooting Cisco Catalyst Switches to NIC Compatibility Issues http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml#intro
PavelKHTW
 
Сообщения: 1037
Зарегистрирован: 08 окт 2003, 13:02
Откуда: Украина

Поменял на NSS

Сообщение ProRus » 16 окт 2004, 11:46

Все решилось заменой томов на NSS.
Сделал все тома кроме SYS NSS стало все просто летать...
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Пред.

Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Иван Левшин aka Ivan L. и гости: 3