DS 6.21: кто больше?

Обсуждение технических вопросов по продуктам Novell

DS 6.21: кто больше?

Сообщение Мещеряков Андрей » 08 сен 2004, 16:49

Тема является прямым порождением проекта NVSTAT :D Так как чудо-машинерия никак не желает работать на 4.х, Магомету остается только одно :) .. то есть врезать в дерево 4.х (4.2 , DS 6.11 в моем случае) сервер 6.0 sp3 минимум.

Объектом для установки выбран старый компьютер с систю платой ASUS Slot1 на каком-то раннем VIA чипсете, поддерживающем тем не менее ECC не только на бумаге, но и в жизни. Три модуля 128 М ЕСС и Р2 на 350Мhz - не много, но ничего более подходящего найти не удалось. Кроме того, на борту контроллер системы Tekram DC 395 и HDD IBM на 8G.

Все телодвижения проводим пока в тестовой сети, где установлена 4.2sp9+bm3.5sp3 для достоверности. Из bm поднят и сконфигурирован только прокси. Сервер сертификатов установлен, но объекты СA и Key не создавались.

6.0 ставилась только на IPX, потому с минимально возможным набором утилит и в свое временное дерево. Установка прямо в существующее дерево невозможна. После завершения установки на нее установлен sp5e.

С установочного диска запущена утилита развертывания и произведена "подготовка дерева к установке eDirectory 8.6.2" На 4.2 кроме того, уставнолены две дополнительные заплатки: preds8a и nlslsp6. Если с сервером лицензий в общем все ясно, то нужность первой заплатки под сомнением.

На 6.0sp5 убито временное дерево и произведена установка в дерево 4.2. Проблема с синхронизацие времени игнорируется, установка проводится дальше. Предупреждающее сообщение только одно: что в дереве уже существует класс SAS и оно тоже игнорируется. Результатом является вполне работоспособная система (отчет dsrepair-a о синхронизации реплик на 2х серверах - Ок) Время, согласно TiDу о невозможности 4.х выступать первичным сервером времени для 6.0 не имеет места быть. Ничего, сделаем 6.0 источником...

Предидущая установка закончилась обновлением DS на 4.2 до 6.21. В результате dsrepair начал выдавать предупреждающие сообщения "remote partition - 630 -<NW4.2>". Попытки вылечить ситуацию успехов не имели: на 4.2 находится 1 неустранимая ошибка, на 6.0 их 60, устранение их не дает ничего. Вдобавок сервера очень неохотно устанавливают связь друг с другом - соединение происходит в момент запуска и тут же теряется, потом такого счастья можно и не дождаться. Одним словом, обновление DS на пользу четверке явно не пошло.

Каково ваше мнение, кабальерос?
Аватара пользователя
Мещеряков Андрей
 
Сообщения: 1999
Зарегистрирован: 19 сен 2002, 14:55
Откуда: lipetsk

Сообщение Мещеряков Андрей » 09 сен 2004, 16:37

Дополнительные проблемы :
Оказывается, у ВМ3.5 проблемы с сервером лицензий v5! Сначала он просто отказывался грузить снапины управления, выдавая ложное сообщение о "поврежденности или отстутствия путей к модулям bscom, bsmon и restrict " , потом, когда в win32 скопировали файл nlsapi32 загрузил, но твердит об отстутвии лицензий! Интересно, можно ли сделат даун - грейт этой заразе? :)
Аватара пользователя
Мещеряков Андрей
 
Сообщения: 1999
Зарегистрирован: 19 сен 2002, 14:55
Откуда: lipetsk

Re: DS 6.21: кто больше?

Сообщение Михаил Григорьев » 16 сен 2004, 17:13

Мещеряков Андрей писал(а):Тема является прямым порождением проекта NVSTAT :D Так как чудо-машинерия никак не желает работать на 4.х, Магомету остается только одно :) .. то есть врезать в дерево 4.х (4.2 , DS 6.11 в моем случае) сервер 6.0 sp3 минимум.


Читаем доку на NVStat

Системные требования:
Платформа: *nux/NetWare 6.x/WinNT/2000/2003
....


Собственно что требуется то от меня я не пойму???? Лично я даже не проверял работоспособность NVStat на NW5.1

В документации четко написано требования, если на NW4.2 NVStat не работает то остаётся только развести руками, я же не могу 4.2 переписать... :?

NVStat тестировался на NW6.0 (без SP и с SP), тестировался на RedHat, FreeBSD, ASPLinux, SUSE Linux, WinNT4, Win2000, WinXP, Win2003

Мещеряков Андрей писал(а):В файле nvstat.conf допустим ли синтаксис
"\\server/volume:<patch>
Судя по всему - нет. А у меня прокси стоит на другом сервере :)


Абсольютно точно, НЕТ, не допустим.

Единственное что приходит в голову это попробовать поставить на 4.2 Perl, а на 6.0 базу mysql и запинывать логи с 4.2 в базу на 6.0
NVStat это позволяет.

Либо копировать каким либо образом логи с 4.2 на 6.0

Дааа... еще... если возникают вопросы по NVStat, то лучше пообщиться по аске, так и быстрее и удобнее...

P.S. моя аска: 161867489
Аватара пользователя
Михаил Григорьев
 
Сообщения: 1462
Зарегистрирован: 04 июн 2002, 12:22
Откуда: Челябинск

Re: DS 6.21: кто больше?

Сообщение Мещеряков Андрей » 17 сен 2004, 08:31

Григорьев Михаил писал(а):Собственно что требуется то от меня я не пойму???? Лично я даже не проверял работоспособность NVStat на NW5.1



Да ничего :) Посто думалось, что этим текстом можно дополнить документацию по развертыванию системы. А аську попробую :)
Аватара пользователя
Мещеряков Андрей
 
Сообщения: 1999
Зарегистрирован: 19 сен 2002, 14:55
Откуда: lipetsk


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и гости: 3

cron