Partition are not all synhcronized??????

Обсуждение технических вопросов по продуктам Novell

Partition are not all synhcronized??????

Сообщение sereganv » 20 авг 2004, 13:29

Сервер Novell Netware 4.1 периодически стал выдавать сообщение "The mirrored partition on this system are not all synchronized".
Что делать и из-за чего такое могло случится? Помогите пожалста, а то я в нетвари не рублю, совсем.... Ж:)
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение sereganv » 20 авг 2004, 16:51

В мониторе один из дисков в состоянии Inactive. Не решится ли проблема если установить значение Active?
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение Музалёв Николай » 20 авг 2004, 17:57

Желательно сначала определиться - почему он выпал в инактив.
Вариант - случайный сбой зеркала. Маловероятно, но бывает... Тогда вставить его назад будет можно.
(Кстати, а то, что у вас зеркало, и какая дискоая подсистема - мы должны догадываться, или как?)
А вот если диск и в самом деле помре, то безрассудные манипуляции могут только усугубить.
В любом случае - все маневры ТОЛЬКО после создания ( и проверки, что действительно создалось) резервной копии.
Если есть вопросы что и как делать - не стесняйтесь задавать, даже самые .
armoracia rusticana (lat.), "блины" и "фиги" всех видов, а также смайлики - крайне не желательны !
Музалёв Николай
 
Сообщения: 3027
Зарегистрирован: 04 июн 2002, 19:58
Откуда: Беларусь. МИНСК.

Сообщение sereganv » 23 авг 2004, 08:30

2 SCSI диска в массиве RAID ? (скорее всего зеркальная пара - RAID 0) точно не знаю, сервер ставил не я. Подскажите где можно посмотреть.
Пару раз сервер вырубался - села батарея на UPS.
На сервере лежат базы 1C (каждый день 2 раза копируются на другой компьютер), нужно ли еще что то сохранять (файлы настроек сервера например ...)?
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение Музалёв Николай » 23 авг 2004, 12:26

Хм... если
зеркальная пара - ...

, то предполагается все таки 1 (??) .
По поводу посмотреть - то вы уже указали, что в МОНИТОРЕ. Значит можно предположить, что зеркало программное.
armoracia rusticana (lat.), "блины" и "фиги" всех видов, а также смайлики - крайне не желательны !
Музалёв Николай
 
Сообщения: 3027
Зарегистрирован: 04 июн 2002, 19:58
Откуда: Беларусь. МИНСК.

Сообщение Gluck » 23 авг 2004, 12:52

Ïîïðîáóéòå çàïóñòèòü âðó÷íóþ ñèíõðîíèçàöèþ ðàçäåëîâ, ò.å. âûïîëíèòü ñ êîíñîëè REMIRROR PARTITION, è èñïîëüçóÿ MIRROR STATUS ñìîòðèòå èäåò èëè íåò ïðîöåññ ñèíõðîíèçàöèè ðàçäåëîâ.
Аватара пользователя
Gluck
 
Сообщения: 27
Зарегистрирован: 16 июн 2004, 08:24
Откуда: Êðàñíîÿðñê

Сообщение sereganv » 23 авг 2004, 13:10

Точно RAID 1 (ошибся в терминологии :) ) и программный.

Сегодня в обед перезагрузил сервер, все нормально второй диск перешёл в Active, автоматом запустился процесс Remirror-га.
Инетресно надолго это счастье, или скоро кончится .....
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение sereganv » 24 авг 2004, 08:36

Счастье длилось недолго, утром та же самая фигня - второй диск в состоянии Inactive :(
Что делать???
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение Музалёв Николай » 24 авг 2004, 11:06

2 раза - это уже тендннци....(С)
Следовало бы убедиться , что второй диск мсправен, уж очень стало похоже, что он собрался в дальний полёт...
Может быть так: откл. зеркало, выкл. срвер, снять проблемный диск, поставить кудалибо и тщательно его погонять. И смореть... Для гоняния - какую либо программу на запись-чтение постоянно, часов на 12.... Сразу можно предложить пакет от PORTLOCKa. Без денег он работает на первом гиге (??), но этого должно вполне .
Ну и попутно чуть пошаманить - прожать весь скази-шлейф: передернуть разьемы, проверить замки контактных вилок, терминатор шлейфа....
armoracia rusticana (lat.), "блины" и "фиги" всех видов, а также смайлики - крайне не желательны !
Музалёв Николай
 
Сообщения: 3027
Зарегистрирован: 04 июн 2002, 19:58
Откуда: Беларусь. МИНСК.

Сообщение sereganv » 24 авг 2004, 12:13

Спасибо за совет.
Так и сделаю...
О результатах напишу.
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение sereganv » 24 авг 2004, 12:54

Решил перед снятием диска, проверить виден ли диск вообще.
В мониторе попробовал установить для него значение Active - никакого эффекта.

Заглушил сервер (down), вышел в дос (exit), запустил сервер снова (server) .... второй диск в Active идет процесс Remirror-га. По моему все таки дело не в железяке, а в Novell.

Теперь даже не знаю стоит ли снимать, проверять или нет?
Есть ли в Novell какой нибудь системный log, как в Win2000 например?
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Сообщение PavelKHTW » 24 авг 2004, 13:43

sereganv писал(а):Заглушил сервер (down), вышел в дос (exit), запустил сервер снова (server) .... второй диск в Active идет процесс Remirror-га. По моему все таки дело не в железяке, а в Novell.

Как раз из этого следует то, что дело в винчестере. Если помните замечательный винчестер от Fujitsu(определенных серий) - пока был холодный работал, нагревался - падал. Вот и ваш стартует, OS запускает синхронизацию, а потом отвал.
PavelKHTW
 
Сообщения: 1037
Зарегистрирован: 08 окт 2003, 13:02
Откуда: Украина

Сообщение sereganv » 24 авг 2004, 15:24

Ладно винт я все равно проверю.

Вчера вечером процесс "зеркалирования" нормально завершился (проверил перед тем как идти домой), ночью на сервере никто не работает, базы автоматом не архивируются, диски не проверяются...

Тем не менее с утра диск отвалился :( (до начала работы с ним)
sereganv
 
Сообщения: 9
Зарегистрирован: 20 авг 2004, 13:24

Ситуация явно связана с железом, не теряйте времени

Сообщение Boris Morozov » 25 авг 2004, 00:09

на поиски глюков в Netware, это не оно. Попробуйте ради интереса поменять подключение винтов к контроллеру и посмотрите, какой начнет отваливаться. Если будет отваливаться этот же винт, то ищите ему замену.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск

Сообщение Роман Иванов » 25 авг 2004, 16:57

бывали ситуации когда подобные проблемы возникали на винтах висящих на одном SCSI канале один из них начинал сбоить, причем сбои иногда не очевидные - не появдение БЭД-блоков, а например нестабильное чтение (что видно в любой програмке как скачок скорости чтения-записи)... лечится заменой винта ибо всерно скоро гакнется.
---
а ночью по умолчанию сервер может сильно винт трепать, например если у вас включено сжатие инфы на томе :)
Роман Иванов
 
Сообщения: 257
Зарегистрирован: 05 май 2003, 17:25
Откуда: Москва, Курск

След.

Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron