Падает сервер.

Обсуждение технических вопросов по продуктам Novell

Падает сервер.

Сообщение Ekrysanov » 08 июн 2004, 09:59

Установлен nw6+sp4. Серевер нормально работает недели две и падает. Сегодня опять выпал и загрузил debugger.
Debug выдал кучу всяких параметров
Например: eax=000004c flags=0000002
В конце была строчка:
86719797 56 push esi.
Кто нибудь подскажите в чем дело.
Ekrysanov
 
Сообщения: 19
Зарегистрирован: 27 апр 2004, 12:14
Откуда: Челябинск

Re: Падает сервер.

Сообщение Аркадий Глазырин » 08 июн 2004, 10:09

Ekrysanov писал(а):Установлен nw6+sp4. Серевер нормально работает недели две и падает.
Кто нибудь подскажите в чем дело.


NW 6 требует достаточно мощного "железа". А что у Вас?
Celeron-733MHz с обычной нетестированной памятью без ECC.
Вы бы ещё на AMD 5x86-P133 с SIMM-ами поставили. :lol:
Аватара пользователя
Аркадий Глазырин
 
Сообщения: 2762
Зарегистрирован: 16 авг 2002, 09:09
Откуда: Екатеринбург

Сообщение Ekrysanov » 08 июн 2004, 10:16

У нас IBM eServer x225
Intel Xeon 2,66GHz with Cashe size 512 Kb and Installed Memory 512 Mb.
Ekrysanov
 
Сообщения: 19
Зарегистрирован: 27 апр 2004, 12:14
Откуда: Челябинск

Сообщение Аркадий Глазырин » 08 июн 2004, 10:52

Ekrysanov писал(а):У нас IBM eServer x225
Intel Xeon 2,66GHz with Cashe size 512 Kb and Installed Memory 512 Mb.


(Вижу намёк понят. :D )

Какие паки стоят? Включен ли HT.
Как именно "падает"?
Причина онкологий - иммунодефицит. Он вызывается загаром, нервотрёпкой, прививками от гриппа, генномодифицированными дрожжами, например "Саф-Момент", приёмом наркотиков, особенно героиновой группы. + Грибы и паразиты.
Аватара пользователя
Аркадий Глазырин
 
Сообщения: 2762
Зарегистрирован: 16 авг 2002, 09:09
Откуда: Екатеринбург

Сообщение Ekrysanov » 08 июн 2004, 11:53

Сервер примерно раз в две недели отключается от сети. Сама ОС работает, а сети нет. Приходится перезагружать сервер.
Сегодня остановился и вызвал debug.
SP 4. Насчет HT не знаю.
Ekrysanov
 
Сообщения: 19
Зарегистрирован: 27 апр 2004, 12:14
Откуда: Челябинск

Сообщение Аркадий Глазырин » 08 июн 2004, 12:18

Ekrysanov писал(а):Сервер примерно раз в две недели отключается от сети. Сама ОС работает, а сети нет. Приходится перезагружать сервер.
Сегодня остановился и вызвал debug.
SP 4. Насчет HT не знаю.


Так он весь "валится" или только сетевой интерфейс отключается?

Включение/отключение HT смотрится в BIOS в разделе свойств процессора.
Лучше его выключать.
Причина онкологий - иммунодефицит. Он вызывается загаром, нервотрёпкой, прививками от гриппа, генномодифицированными дрожжами, например "Саф-Момент", приёмом наркотиков, особенно героиновой группы. + Грибы и паразиты.
Аватара пользователя
Аркадий Глазырин
 
Сообщения: 2762
Зарегистрирован: 16 авг 2002, 09:09
Откуда: Екатеринбург

Сообщение Музалёв Николай » 08 июн 2004, 12:28

Дык
...и падает

или просто
...сети нет..

??

Если последнее, то есть ИМНО, что это проделки сетевой карты.
В следующий раз попробуйте уточнить, что значит нет сети:
- проверьте текущее состояние сетевой подсистемы командой CONFIG с консоли - там что видно?;
- попробуйте "попинговать" сетевой интерфейс серверными утилитами PING или IPXPING - хоть кто видит карту?;
- посмотрите в MONITORe статистику и состояние сетевой подсистемы - нет ли там много ошибок или другого криминала?;
- можно ли восстановиться по команде REINITIALIZE SUSTEM из модуля INETCFG или только перезагрузкой?
В общем - полнее и точнее, пожалуйста...

А пока как первое лекарство - попробуйте заменить сетевой драйвер на новое/старое, и то же и относительно сопутствующих модулей - MSM и т.д.... вплоть до стека протоколов (IP).
armoracia rusticana (lat.), "блины" и "фиги" всех видов, а также смайлики - крайне не желательны !
Музалёв Николай
 
Сообщения: 3026
Зарегистрирован: 04 июн 2002, 19:58
Откуда: Беларусь. МИНСК.

Сообщение Ekrysanov » 08 июн 2004, 12:44

Сегодня, пробовал пинговать сервер не отвечал. Также пробовал пинговать второй сервер (WinNT) он тоже не отвечал.
Ekrysanov
 
Сообщения: 19
Зарегистрирован: 27 апр 2004, 12:14
Откуда: Челябинск

Сообщение Влад А.Сокол aka Akina » 08 июн 2004, 18:18

А сам себя сервер с консоли пингует по адресу сетевого интерфейса? а локалхост? т.е. что отвалилось - карта от стека или стек от ядра... а в логе консоли ничего нет насчет деактивации карты или отвязки протокола?
Влад А.Сокол aka Akina
 
Сообщения: 1326
Зарегистрирован: 05 июн 2002, 09:24
Откуда: Зеленоград, Москва, Россия

А посмотрите в Monitor в этот момент в разделе

Сообщение Boris Morozov » 08 июн 2004, 19:17

System Resources -> Lsl Packet Receive Buffers.
Не близко его значение к 10000?
И не стоит ли у вас Netmail случаем на сервере.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск

Re: А посмотрите в Monitor в этот момент в разделе

Сообщение Ekrysanov » 09 июн 2004, 06:33

Boris Morozov писал(а):System Resources -> Lsl Packet Receive Buffers.
Не близко его значение к 10000?

Какое именно значение? Там 6 параметров и все намного больше 10000. Только cashe movable memory=0
NetMail не установлен.
Ekrysanov
 
Сообщения: 19
Зарегистрирован: 27 апр 2004, 12:14
Откуда: Челябинск

А надо найти LSL Packet Receive buffers

Сообщение Boris Morozov » 09 июн 2004, 19:30

и Enter надавить. Откроется список модулей, сверху будет тот, кто больше всех отожрал. Обычно это TCPIP. Стать на него и посмотреть Number in Use.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск

Re: А посмотрите в Monitor в этот момент в разделе

Сообщение Сергей aka m0p3e » 09 июн 2004, 23:06

Boris Morozov писал(а):И не стоит ли у вас Netmail случаем на сервере.


Опс. А что может быть с NetMail-ом? Просто была как раз такая проблема на серве с ним. В чем дело выяснить не удалось. NetMail перенес на другой серв.
Аватара пользователя
Сергей aka m0p3e
 
Сообщения: 159
Зарегистрирован: 05 июн 2002, 11:32
Откуда: Москва

Я в принципе разобрался в ситуации и знаю методы борьбы

Сообщение Boris Morozov » 09 июн 2004, 23:51

Ситуация в Новелле известная, о чем можно судить даже по комментарию к патчу на TCPIP, который сегодня положили.
Суть в том, что в некоторых случаях стек TCPIP не может завершить соединение и оно остается в состоянии Finwait2. Соответственно не освобождаются какие-то блоки и растет число этих самых LSL packet receive buffers. Когда оно достигает максимальной границы, сервер перестает отвечать на сетевые запросы.
Я наблюдал такие вещи при работе PROXY агента нетмайла при съеме почты с mail.ru - почему-то только оттуда, с остальными почтовиками все нормально. Причем я смотрел трассу пакетов, по ним видно что бедный сервак отчаянно пытался разорвать соединение, слал всякие страшные команды, но никак. Эти соединения хорошо видны в TCPCON - соответственно я и лечил ситуацию с помощью кнопки Del. Буфера кушаются достаточно медленно, поэтому раз в пару дней, заглянув туда, можно это дело отследить, не доводя до зависона и перезагрузок.
Сейчас на 6.5 + Netmail 3.52 это как-то рассасывается само, хотя буферов все равно около 100~200 все равно висит, что не есть нормально. Оно в принципе более-менее стало работоспособно, начиная с какого-патча и на 6. А тогда я просто фильтром запретил серверу снимать почту с mail.ru.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3