MySQL под NetWare 5.1 SP7

Обсуждение технических вопросов по продуктам Novell

MySQL под NetWare 5.1 SP7

Сообщение ProRus » 13 май 2004, 20:00

Поставил Perl, PHP, Apache. Все работает нормально...
Нужно MySQL запустить...
Посоветуйте какая версия лучше и устойчивее работает на пятерке?
Смотрел на родном сайте пишут что все версии под Novell 6.
Киньте ссылочкой если не сложно откуда мускуль можно дернуть...
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Сообщение Квашук aka Novell_maNiac! » 13 май 2004, 20:40

у меня так
MYSQLD.NLM (Address Space = OS)
Loaded from [DATA:/MYSQL/BIN/]
MySQL Database Server
Version 4.00q December 15, 2003
(c) 2003 Novell, Inc. Portions (c) 2003 MySQL AB. All Rights Reserved.

это mysql-standard-4.0.18-pc-netware-i686.zip+libc_all.exe+cldap_all.exe
последних версий с developer.novell.com...... естественно базы должны лежать на NSS томах ....
MasterCNE,CNE 6,MCP,CNS 2006
Аватара пользователя
Квашук aka Novell_maNiac!
 
Сообщения: 189
Зарегистрирован: 16 авг 2002, 04:38
Откуда: Национальный банк Траст

Проблема.

Сообщение ProRus » 14 май 2004, 08:42

Версию mysql-standard-4.0.18-pc-netware-i686.zip так и не нашел...
Скачал mysql-standard-4.0.18a-pc-netware-i686.zip.
Том NSS, все LibC и CLDAP поставил свежие и последние...
Пробую сделать по написаному...
SERVER: SEARCH ADD SYS:MYSQL\BIN
Install the initial database, if needed, by executing mysql_install_db at the server console.
Start the MySQL server using mysqld_safe at the server console.

При mysql_install_db выдает следующее на консоле:
Module name is MYSQL_IN.NLM not MYSQL_INSTALL_DB.NLM
Module name is MY_PRINT.NLM not MY_PRINT_DEFAULTS.NLM
Loaded canot find public symbol: zRootKey for module MYSQLD.NLM
Error processing External Records.
И сответственно ждет нажатия кнопки и выгружается после нажатия.

Подскажите что не так?
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Сообщение Сулейменов Олжас » 14 май 2004, 09:33

Ничего удивительного!
Ведь
Novell NetWare downloads (platform notes)
Note: The following packages require NetWare 6 SP2 or higher (with the latest LibC), and an NSS volume for the data directory.
http://dev.mysql.com/downloads/mysql/4.0.html

Жалко, что нет для версий 5.х, а что делать? :roll:
Аватара пользователя
Сулейменов Олжас
 
Сообщения: 281
Зарегистрирован: 17 июн 2003, 10:00
Откуда: г. Казань

Сообщение Квашук aka Novell_maNiac! » 14 май 2004, 09:50

тут 2 выхода либо подождать выхода свежих LIBC либо взять версию 4.0.17 либо 4.0.16 если надо я могу прислать ...
MasterCNE,CNE 6,MCP,CNS 2006
Аватара пользователя
Квашук aka Novell_maNiac!
 
Сообщения: 189
Зарегистрирован: 16 авг 2002, 04:38
Откуда: Национальный банк Траст

Все ок...

Сообщение ProRus » 14 май 2004, 10:12

Квашук aka Novell_maNiac! писал(а):тут 2 выхода либо подождать выхода свежих LIBC либо взять версию 4.0.17 либо 4.0.16 если надо я могу прислать ...

Спасибо всем...
Запустилась версия 4.017.
Но вот почему он все равно выдает сообщение
Module name is MY_PRINT.NLM not MY_PRINT_DEFAULTS.NLM
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Почему перегружается?

Сообщение ProRus » 20 май 2004, 13:31

Все вроде вышеописанное работает...
Но сервер почемут перегружается при использовании на сайте PHP...
Работает, работает, и вдруг перегружается сам... ничего не говорив на консоле...
Может кто скажет, как решить проблему...?
Больше на сервере ничего нет.
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 7

cron