перенос сервера

Обсуждение технических вопросов по продуктам Novell

перенос сервера

Сообщение Андрей Волконский » 18 апр 2004, 02:55

Руководство решило приобрести новый сервер.
Впредверие этого замечательного события решили поэксперементировать с переносом данных
на новый сервер.
Поставил тестовый комп,установил на него Новелл 5,опробовал на нём копирование/восстановление НДС,всё замечательно.
Проблемы начались когда попробовал перенести НДС с рабочего сервера на новый.
Обьекты все перенеслись,НО...
1 ошибка:The volume ID cannot be resolved in this database.
--конечно,volume ID на новом сервере будет другим,как это устранить?
2 ошибка:Could not find or add Directory Service volume object error 610.Trustees are not checked on this volume.
--вследствие этой ошибки,как я понимаю,пропадают все права пользователей на том.
Нашел выход с помощью утилиты setright,которая восстанавливает права,но отчего
выскакивает подобная ошибка и можно ли без лишней головной боли перенести НДС
вместе с правами ?(Атрибуты НДС я восстанавливал:-)
Андрей Волконский
 
Сообщения: 6
Зарегистрирован: 18 апр 2004, 02:49

Re: перенос сервера

Сообщение Larico » 18 апр 2004, 23:05

Андрей Волконский писал(а):...можно ли без лишней головной боли перенести НДС
вместе с правами ?(Атрибуты НДС я восстанавливал:-)
Вы несколько неправильно трактуете права НДС в данном контексте (насколько я его понял). Права на файловую систему хранятся не в НДС, а на томе!
В вашем случае вполне подойдет другой тип переезда с одного сервера на другой: Pre-Migration. Т.е. вы ставите сервер в данном режиме, а потом переносите на него существующий, и таким образом получаете точную копию своего сервера на новом железе - для того этот режим и сделан.
Либо нужно ставить новый сервер в сущ. дерево, а затем переносить данные вместе с правами, после чего поменять скрипты на новый сервер, перенести мастер реплику на него, а затем вынести старый сервер. Всё.
CNA 6 Certified;
Salesperson 2004
Аватара пользователя
Larico
 
Сообщения: 974
Зарегистрирован: 13 май 2003, 13:57
Откуда: Матрице все равно .....

Сообщение Андрей Волконский » 19 апр 2004, 02:54

А что это за режим Pre-Migration?В книгах(по крайней мере в моих) о нём не упоминается? Если можно,подробней!!! :arrow: Novell5.0 без сервис-паков
Андрей Волконский
 
Сообщения: 6
Зарегистрирован: 18 апр 2004, 02:49

Сообщение Larico » 19 апр 2004, 11:05

Андрей Волконский писал(а):А что это за режим Pre-Migration?В книгах(по крайней мере в моих) о нём не упоминается? Если можно,подробней!!! :arrow: Novell5.0 без сервис-паков
Вставляете СД с дистрибутивом, грузитесь, и на какой-то из начальных страничек есть выбор:
-New server
-Pre-Migration
-Upgrade
Писать что это и как тут не буду - пальцы устанут. Читайте readme к NwDeploy или документацию по установки нетвари (доступна для скачивания в pdf-ах, если у вас её нет).

Еще: я бы однозначно рекомендовал ставить как минимум 5.1 и с оверлея с как минимум 5-м сервис-паком (можно и с 6-ым 7-мым - читайте поднятые по этому поводу теме).

Еще 2: если есть вопросы что такой оверлей, что такое NwDeploy - то сначала в поиск, а потом уже вопросы.
CNA 6 Certified;
Salesperson 2004
Аватара пользователя
Larico
 
Сообщения: 974
Зарегистрирован: 13 май 2003, 13:57
Откуда: Матрице все равно .....

Сообщение Андрей Волконский » 20 апр 2004, 01:32

что такое nwdeploy знаю, но про оверлей так и не нашёл? :(
Андрей Волконский
 
Сообщения: 6
Зарегистрирован: 18 апр 2004, 02:49

Сообщение Владимир » 20 апр 2004, 02:52

В данном случае оверлей - это дистрибутив Netware с интегрированным SP. Для 5.1 их можно выкачать например отсюда http://support.novell.com/filefinder/9331/index.html
Владимир
 
Сообщения: 179
Зарегистрирован: 22 июн 2002, 12:18
Откуда: г.Мирный

Сообщение Андрей Тр. aka RH » 20 апр 2004, 04:35

Larico писал(а):Еще: я бы однозначно рекомендовал ставить как минимум 5.1 и с оверлея с как минимум 5-м сервис-паком (можно и с 6-ым 7-мым - читайте поднятые по этому поводу теме).
Однако .. ИМХО выбор, что именно ставить, определяется в первую очередь наличием у человека соответствующих лицензий. А то он выкачает ISO, и .. ? Хотя если это хитрый маркетинговый ход salesperson - типа есть у вас 5.0, но я однозначно рекомендую как минимум 5.1 ( что, конечно, лучше, чем 5.0 - не спорю ). Ну и кроме того, не так уж и обязательно с оверлейного CD, можно и потом отдельно SP накатить.
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

Сообщение Larico » 20 апр 2004, 10:40

Андрей Тр. aka RH писал(а):Однако .. ИМХО выбор, что именно ставить, определяется в первую очередь наличием у человека соответствующих лицензий. А то он выкачает ISO, и .. ? Хотя если это хитрый маркетинговый ход salesperson - типа есть у вас 5.0, но я однозначно рекомендую как минимум 5.1 ( что, конечно, лучше, чем 5.0 - не спорю ). Ну и кроме того, не так уж и обязательно с оверлейного CD, можно и потом отдельно SP накатить.
ОК. я поясню почему так написал:
1. С оверлея, потому как в нем масса обновленных модулей (а зачастую и заново переписаных), пофиксены некоторые траблы (в том числе и инсталяционные).
2. 5.1 - только из личного опыта работы с 5.0 и 5.1, в котором 5.1 однозначно выиграла, потому как в ней опятьже многое пофиксено.
CNA 6 Certified;
Salesperson 2004
Аватара пользователя
Larico
 
Сообщения: 974
Зарегистрирован: 13 май 2003, 13:57
Откуда: Матрице все равно .....


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 9