Сервера разных версий Netware в одном дереве

Обсуждение технических вопросов по продуктам Novell

Сервера разных версий Netware в одном дереве

Сообщение OlegA » 23 мар 2004, 06:28

Можно ли устанавливать сервера Netware разных версий 4.11 и 6.0 в одном дереве, но в разные контесты. Будут ли конфликты между серваками.
OlegA
 
Сообщения: 40
Зарегистрирован: 16 мар 2004, 06:17
Откуда: Иркутск

Сообщение Павел Орлов aka XerX » 23 мар 2004, 10:42

Установить то можно .... даже в одинаковые контексты....
проблемы могут возникнуть (и возникнут скорее всего)
из - за разницы между NDS и eDir
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Сообщение Андрей Тр. aka RH » 23 мар 2004, 12:07

Если не ошибаюсь, до сих пор изредка выпускают обновленную DS в т.ч. и для 4.11 - чтобы обеспечить ее совместимость с NDS8/eDir ( при том, что 4.11 сама по себе не поддерживается ). Хотя сам не проверял .. но в целом же в доке ( по 6.0 ) должно быть все написано - с какими серверами / версиями DS в дереве она уживается.
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

DS 6.21 прекрасно уживается с 8.7 у меня

Сообщение Boris Morozov » 24 мар 2004, 01:08

уже полгода, сервера в одном контексте. Меньше 6.17 будут конфликтовать и не синхронизироваться. С 6.17 могут быть ? в объекте сервера.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск

Сообщение OlegA » 30 мар 2004, 08:41

Учтановил 9 пак для Netware 4.11, текущая версия DS 6.11. Как поднять DS до версии 6.21. Вычитал вроде бы эта последняя версия DS для Netware 4.11.
OlegA
 
Сообщения: 40
Зарегистрирован: 16 мар 2004, 06:17
Откуда: Иркутск

Сообщение Владимир Горяев » 30 мар 2004, 09:33

ds621.txt
NOVELL TECHNICAL INFORMATION DOCUMENT

TITLE: NDS Update for Netware 4.11, 4.2 DS v 6.21
TID #: 2966639
README FOR: ds621.exe

SUPERSEDES:
fds621.exe

NOVELL PRODUCTS and VERSIONS:
NDS - NW42
Server 4.x - EOL
NDS - EOL

ABSTRACT:

This update to Novell Directory Services is intended for NetWare 4.11 and
4.2 servers.

This update requires that a NetWare 4.11 server be running Support Pack
Version 9.

DS 6.21 provides the following updates to facilitate migration to later
versions of NetWare and eDirectory:
- Pre-Migration GUID generation
- Enhanced Auxiliary Class handling
- Enhancements to allow for coexistance with NetWare 6.5
- Synchronization update for eDirectory 8.6.x or higher on NT servers

Additional steps to allow these enhancements may be required. Please refer
to the Issue Section for further information.

Updated files since the last public release of DS 6:
DS.NLM v 6.21
DSREPAIR v 4.73a
SGUID.NLM v 1.00

***** DO NOT APPLY THIS DS UPDATE TO A NETWARE 5.x or HIGHER SERVER!!!! ****


-----------------------------------------------------------------
DISCLAIMER
THE ORIGIN OF THIS INFORMATION MAY BE INTERNAL OR EXTERNAL TO
NOVELL. NOVELL MAKES ALL REASONABLE EFFORTS TO VERIFY THIS
INFORMATION. HOWEVER, THE INFORMATION PROVIDED IN THIS DOCUMENT
IS FOR YOUR INFORMATION ONLY. NOVELL MAKES NO EXPLICIT OR IMPLIED
CLAIMS TO THE VALIDITY OF THIS INFORMATION.
-----------------------------------------------------------------


INSTALLATION INSTRUCTIONS:

This update is for NetWare 4.11 and 4.2 servers only!
NetWare 4.11 should be patched to Support Pack 9.

**** NOTE **** Always make a backup copy of original files.

******************* Proactive NOTE *************************************
As with all patches, take standard precautionary disaster recovery steps. This
includes loading "LOAD DSREPAIR -RC" at the server console which, on
a Netware 4.11 server, will create a file called SYS:\SYSTEM\DSREPAIR.DIB.

Running a DSREPAIR -RC on a regular basis provides additional disaster recovery
for the database. This will put a copy of the database in the SYS:\SYSTEM
directory by default and this file should be copied to another directory such
as SYS:\SYSTEM\DSR_DIB so it will not be overwritten the next time it is run.
**************************************************************************

1. Log into the network as ADMIN or a user with rights to the SYS:SYSTEM of
the file server. Locate the following files in the SYS:\SYSTEM sub-directory:
DS.NLM
DSREPAIR.NLM
You may or may not find all of the files mentioned above, additionally, one
or more of the files may be flagged Read-Only. Rename these files to *.OLD.

2. Unload all DS dependant NLM's (DSREPAIR.NLM, DSVIEW.NLM, etc.)
Copy the NLM files provided in this update to the SYS:SYSTEM directory
of the NetWare 4.11 OR 4.2 file server.

3. At the file server console of the server being upgraded (or using
RCONSOLE) toggle to the system console screen.

4. At the system console screen enter the command "SET DSTRACE = *." and
press <Enter> to reload the Directory Services (DS.NLM) without downing
the server. You may also issue the following commands at the console:
"UNLOAD DS" and "LOAD DS" .

5. You should then observe that the new DS.NLM is loaded. Should you receive
an "Error -603" when the new SGUID.NLM module loads simply load the new
DSREPAIR.NLM and run Advanced Options | Global Schema Operations |
Post NetWare 5 Schema Update.
You will then need to re-run the "SET DSTRACE=*." command or unload and
re-load DS.NLM. Additional information can be found in the Issue Section of
this update.

This update to Directory Services is recommended when running in a mixed
tree with NetWare 5.x NDS 8 and later servers. It is also recommended
that this update be applied prior to upgrading the server to NetWare 6.x
or greater.

ISSUE:

FIXES INCLUDED IN DS 6.21
(Supercedes DS.NLM 6.19 found in the last 6.x public release file - DS617.EXE)
- NetWare 6.5 reports -609 during install

***************** NOTE ***************

This update provides several enhancements that will allow a NetWare 4.x server
to
coexist in mixed rings while upgrading to the latest versions of NetWare and
eDirectory.
1. Enhanced Auxiliary class support. No longer will objects associated with
auxiliary classes show up as unknown while being viewed from a management
interface such as ConsoleOne when reading the database from a DS 6 based
server. To enable/disable the new auxiliary class support you must type the
following commands at the server console:
SET DSTRACE=AUXSUPPORT ON
SET DSTRACE=AUXSUPPORT OFF
These settings are persistant.
Additional information can be found in TID 10083622

2. This version of DS.NLM also prepares objects for a migration to NetWare
6.x and eDirectory 8.6.2 or higher by giving them a GUID attribute and value.
This attribute is used by NSS volumes for volume trustee right associations.
This attribute is given to object by a new NLM - SGUID.NLM. Additonal steps
may be required to allow for this functionality. (Please reference TID
10083319)
Additional information on installation and how the three included NLM's
perform this function can be found by referencing
TID 10081527

3. This update also addresses problems with DS 6.x synchronizing to 8.6.x or
8.7.x
running on a NT SERVER in a mixed ring with NetWare 4.x. For this
synchronization update to function you must issue a "SET DSTRACE=!ne" command
at the console prompt. This command should also be placed in your autoexec.ncf.
Please note that this switch is only required when eDirectory is running on a
NT
server.

*********************************************

FIXES INCLUDED IN DS 6.19
(Supercedes DS.NLM 6.17 found in the last 6.x public release file - DS617.EXE)
- Objects with aux classes will not show as unknown
- Along with new SGUID.NLM will force GUID generation prior to upgrade

FIXES INCLUDED IN DS 6.17
(Supercedes DS.NLM 6.16 found in the last 6.x public release file - DS616.EXE)
- 8.6.2 server running on Win2K can't communicate via IPX to NetWare 4.x
servers
Note: You must issue a SET DSTRACE=!ne
- We have a problem where eGuide modifies a Fax/phone number attribute

FIXES INCLUDED IN DS 6.16
(Supercedes DS.NLM 6.15 found in partner release file - DS615.EXE)
- Schema sync fails with a -652 duplicate manditory error when Zen for
Servers 3.0 is installed with DS 6x in the ring

FIXES INCLUDED IN DS 6.15
(Supercedes DS.NLM 6.14 found in public release file - DS614.EXE)
- Invalid API version -683 when declaring new epoch with 4.x server holding
master
- Server to Server Authentication fails when the server object is
unknown due to auxillary classes being associated to NCP server objects.
These servers will remain unknown from a 4.x server's prospective but now
we can continue to synchronize with them.
- ArcServe queues being purged by the backlinker
- Synchronization fails with -746 zero time stamp messages on the [this] acl

FIXES INCLUDED IN DS 6.15
(Supercedes DS.NLM 6.14 found in public release file - DS614.EXE)

----------------------------------------------------------------------
Changes in DSREPAIR.NLM 4.73a
(Supercedes DSREPAIR.NLM 4.73)
- Adds Internal Novell Support switches

Changes in DSREPAIR.NLM 4.73
(Supercedes the last public release of 4.72D)
- Aux class enhanced code for new DS.NLM

Changes in DSREPAIR.NLM 4.72D
(Supercedes the last public release of 4.72C)
- Objects synch over and over with a NetWare 4.11 server in the ring

NOTE: DO NOT USE THIS DSREPAIR ON A NON-ENGLISH SERVER! There have been message
changes.

Self-Extracting File Name: ds621.exe

Files Included Size Date Time
..\
DS621.TXT (This file)
DS.NLM 416099 6-19-2003 12:37:06 pm
DSREPAIR.NLM 188213 6-10-2003 3:31:54 pm
SGUID.NLM 4288 2-27-2003 10:42:36 am



-----------------------------------------------------------------
Any trademarks referenced in this document are the property of their respective
owners. Consult your product manuals for complete trademark information.
-----------------------------------------------------------------

Бардак автоматизировать невозможно!!!
_________________
Аватара пользователя
Владимир Горяев
 
Сообщения: 3473
Зарегистрирован: 05 июн 2002, 13:37
Откуда: Смоленск

Сообщение Владимир » 30 мар 2004, 09:42

Может проще ссылку на тид? А то очень много инфы в форум. Читать не удобно.
Владимир
 
Сообщения: 179
Зарегистрирован: 22 июн 2002, 12:18
Откуда: г.Мирный

Сообщение Владимир Горяев » 30 мар 2004, 09:51

Владимир писал(а):Может проще ссылку на тид? А то очень много инфы в форум. Читать не удобно.
Можно, но лениво. А README под рукой 8)
Бардак автоматизировать невозможно!!!
_________________
Аватара пользователя
Владимир Горяев
 
Сообщения: 3473
Зарегистрирован: 05 июн 2002, 13:37
Откуда: Смоленск

Сообщение Smith » 30 мар 2004, 09:53

OlegA писал(а):Учтановил 9 пак для Netware 4.11, текущая версия DS 6.11. Как поднять DS до версии 6.21. Вычитал вроде бы эта последняя версия DS для Netware 4.11.


возьми здесь и замени

http://support.novell.com/cgi-bin/searc ... 966639.htm
Пришел, увидел и ушел....
Аватара пользователя
Smith
 
Сообщения: 6
Зарегистрирован: 26 авг 2003, 13:49
Откуда: Minsk, Беларсь

Сообщение Владимир » 30 мар 2004, 09:53

Владимир Горяев писал(а):
Владимир писал(а):Может проще ссылку на тид? А то очень много инфы в форум. Читать не удобно.
Можно, но лениво. А README под рукой 8)

Понял, не дурак ... :-) Но все-же...
Владимир
 
Сообщения: 179
Зарегистрирован: 22 июн 2002, 12:18
Откуда: г.Мирный

Сообщение Владимир Горяев » 30 мар 2004, 10:45

Владимир писал(а):Понял, не дурак ... :-) Но все-же...
Оверквотинг не есть хорошо, конечно, но Правила форума не запрещают. Как бы тему во Флейм (еще хуже оверквотинга) не перенесли :D
Бардак автоматизировать невозможно!!!
_________________
Аватара пользователя
Владимир Горяев
 
Сообщения: 3473
Зарегистрирован: 05 июн 2002, 13:37
Откуда: Смоленск

Слить два дерева

Сообщение OlegA » 01 апр 2004, 13:47

Имеется сеть с серверами Netware 4.11 SP9 , версия DS 6.21. При установке нового сервера Netware 6.0 SP 1, в существующее дерево добавить не получилось, пришлось создавать новое дерево. Теперь пытаюсь слить два дерева, но проблемы возникают из за разных схем, слияние требует что схемы были идентичны. Как их сделать идентичными, не знаю. Ставить на новый сервер 4.11 как-то уже не хочется, сделать апгрейд на трех работающих серварах 4,11 нет возможности, люди работают и по выходным, оставить сервера в разных деревьях, не приемлимо для пользователя, так как придется логинется два раза в разных деревьях. Что делать в данной ситуации???
OlegA
 
Сообщения: 40
Зарегистрирован: 16 мар 2004, 06:17
Откуда: Иркутск

Сообщение Павел Орлов aka XerX » 01 апр 2004, 13:57

Ну в общем-то я предупреждал.... :roll:
Но в принципе все решаемо....
надо всего-лишь почитать доку по подготовке дерева 4.11 к установке 6.0 ....

вот дока по вопросу... поиск занял 3 секунды... ну неужели сложно пользоваться http://support.novell.com :?:

http://support.novell.com/cgi-bin/searc ... 075926.htm
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Сообщение OlegA » 15 апр 2004, 13:29

Поставить Netware 6.0 в дерево сервера 4.11, частично получилось. Но почему то 6-ка не хочет синхронизироваться с с другими серварами 4.11. В autoexec.ncf на 6-ке выставил теже параметры , что касается временной зоны и перехода на летнее время ,что и на серверах 4.11
SET TIME ZONE = IRK-8:00DLR
SET DAYLIGHT SAVINGS TIME OFFSET = 1:00:00
SET START OF DAYLIGHT SAVINGS TIME = (MARCH SUNDAY LAST 2:00:00 AM)
SET END OF DAYLIGHT SAVINGS TIME = (OCTOBER SUNDAY LAST 2:00:00 AM)
SET DEFAULT TIME SERVER TYPE = SECONDARY

может, что то еще надо прописать.

Как только установил 6-ку, то пользователи из под W2K не могут войти в сеть, а пользователи из под Win98 входят без проблем.
Очень нужен совет :cry:
OlegA
 
Сообщения: 40
Зарегистрирован: 16 мар 2004, 06:17
Откуда: Иркутск


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 8

cron