Отключение фильтрации блокирует консоль

Обсуждение технических вопросов по продуктам Novell

Отключение фильтрации блокирует консоль

Сообщение Лебедев Виктор » 24 дек 2003, 11:26

NW5.1SP6 + BM3.7SP2
Делаю:
unload ipflt31
unload ipflt
unload filtsrv
Первый раз это проходит, все нормально работает. Вновь фильтрацию включить можно.
При повторной попытке отключить фильтрацию "виснет" где-то после выгрузки ipflt31. На консоли висит сообщение о его выгрузке. Дальше глухо. Резко возрастает утилизация. Сервер работает, все сервисы в норме. Фильтрация отсутствует, естественно. "Альтернативную" системную консоль включить дает сколько угодно раз. Но с нее ничего не запускается. При попытке запуска хоть чего они тоже блокируются.
Попытки выгрузить модули из адресного пространства OS не проходят. Модули начинают ожидать "семафора" и висят.
Restart/Down в принципе сделать можно. Процесс останова сервера длится долго. Однако видно, что сервер уходит в down не успев размонтировать все тома. При загрузке ошибки в файловой системе лезут потом (в основном на томе с кэшем BM, том SYSTEM успевает размонтироваться).
Сообщений об ошибках НЕТ. Самое непонятное - никаких!
Кто нибудь втречал подобное? Что делать?
Я понимаю, там при загрузке модулей фильтрации что-то может "глючить". В конце концов, фильтры в NDS-е, могли "слететь", например. С такими вещами все понятно. А здесь ему на чем спотыкаться?
Лебедев Виктор
 
Сообщения: 133
Зарегистрирован: 05 июн 2002, 09:03
Откуда: Пермь

А зачем это делать?

Сообщение Boris Morozov » 24 дек 2003, 23:34

По моему уже давно фильтры входят в действие сразу после сохранения.
Во всяком случае у меня по моему это еще на 5.1 было. Сейчас так точно на Nw6sp3 без проблем реагирует на изменения через Filtcfg.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск

Сообщение Лебедев Виктор » 30 дек 2003, 09:53

В общем все как обычно...
На "авось" решился и поставил "field patch 3E". "Авось" вроде помог - в "патче" есть новый модуль IPFLT31. IMHO, было неправильное освобождение памяти. Почему сервер "авост" не выдавал я так и не понял.
Лебедев Виктор
 
Сообщения: 133
Зарегистрирован: 05 июн 2002, 09:03
Откуда: Пермь


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

cron