MySQL+PHP

Обсуждение технических вопросов по продуктам Novell

MySQL+PHP

Сообщение Игорь Вершинин » 28 авг 2003, 13:24

Проблема эта уже обсуждалась, но на форуме я так ответа и не нашел. При попытке открыть страницу phpMyAdmin (администрирование MySQL) вылетает сообщение:

PHP Warning: open_basedir restriction in effect. File is in wrong directory in sys:/apache/nwdocs/phpmyadmin/index.php on line 9

PHP Fatal error: Failed opening required './libraries/grab_globals.lib.php' (include_path='.;sys:/php/includes;data:/site/www/inc') in sys:/apache/nwdocs/phpmyadmin/index.php on line 9


Указание ведущей точки в пути (./libraries/grab_globals.lib.php) или ее отсутствие (libraries/grab_globals.lib.php) ни на что не влияет. Через Apache 1.3.27 открыт доступ во все директории.

php версии 4.2.4-dev
MySQL 4.0.7-gamma
Apache 1.3.27
Netware 6 sp3 + postfix
тома все NSS
Мне показалось, что PHP не может сконектится с MySQL. Что и как надо прописать в php.ini для этого?
По отдельности и php работает нормально (проверялось на демках из поставки php), и MySQL (тест из readme - создание БД и запрос к ней через консоль).
php.ini установлен по умолчанию. Изменения лишь в нескольких строках, добавлен еще один путь в переменную <include_path>, отключена загрузка php_ldap.nlm (с ней тоже ничего не работало), прописан параметр mysql.default_port = 3306
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Сообщение Михаил Григорьев » 29 авг 2003, 12:08

Тольео что скачал phpMyAdmin 2.5.3-rc3 и поставил на NW6.0+SP2+PostFix+ Apache 1.3.28 + PHP4.2.4 + Perl5.8 + MySQL 4.0.12

Все завелось с пол пинка... даже настраивать ничего не пришлось
Аватара пользователя
Михаил Григорьев
 
Сообщения: 1461
Зарегистрирован: 04 июн 2002, 12:22
Откуда: Челябинск

Сообщение Игорь Вершинин » 29 авг 2003, 17:18

У меня на текущий момент такая ситуация:

Apache 1.3.28 (последний с сайта)
PHP 4.2.4
MySQL 4.0.14
Netware 6 sp3 + postfix + LibC от 30 июля (тоже последний)

По отдельности и PHP работает, и MySQL тоже. Скрипт mysql.php из /php/webdemo также все исправно показывает. Т.е. связка PHP+MySQL+Apache работает. Но на нашем сайте работать не хочет. Если интересно как это выглядит, то www.ailant.com.ru . Нормальная работа MySQL по ссылке www.ailant.com.ru/mysql.php
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Сообщение Andrey Karyagin » 29 авг 2003, 19:16

Проблема обсуждалась недавно на форуме news://novell.devsup.php

Yes, I did have to install something extra. I had to install the latest C
Libraries--the June release of LDAP libraries for C. The error messages
were something like:

Warning: pen_basedir restriction in effect. File is in wrong directory in
sys:/apache/htdocs/phpmyadmin/index.php on line 9.
Fatal error: Failed opening required '.libraries/grab/globals.lib.php
(include_path='.;sys:/php/includes') in
sys:/apache/htdocs/phpmyadmin/index.php on line 9.

I commented out open_basedir="..." (This is in the config.inc.php file
which is in the root of phpMyAdmin directory).
Also, if you copy phpMyadmin folder in the root of htdoc, then add this:

$cfg ['PmaAbsoluteUri'] = 'http://yourServer/phpmyadmin/'; (This must be
set to the address of the root directory of your phpMyAdmin.)


"jlocatell" <jlocatell@datamarkets.com.ar> wrote in message
news:jzSRa.17998$2k7.12136@prv-forum2.provo.novell.com...
> Kathleen
>
> Hi,
>
> actually, we're not able of run this utility, appears as not finding the
php
> libraries needed. I wonder if you'd need to configure something
additional.
>
> regards
>
> "Kathleen Androlewicz" <kathleen.androlewicz@ngc.com> wrote in message
> news:nLCRa.17366$2k7.2225@prv-forum2.provo.novell.com...
> > For me, version 2.5.1 and 2.5.2 both worked on my test Netware AMP
server.
> > The deployment guide shows 2.3.2.
> >
> > "jlocatell" <jlocatell@datamarkets.com.ar> wrote in message
> > news:pkzRa.17082$2k7.12380@prv-forum2.provo.novell.com...
> > > Hi
> > >
> > > Which version of this app is able of run onto NW6 Sp 3 with PHP
version
> > > 4.2.4 on Apache 1.3.27?
> > >
> > > wait for comments...
> > >
> > > -jl
> > >
> > >
> >
> >
>
>
Andrey Karyagin
 
Сообщения: 204
Зарегистрирован: 06 авг 2002, 15:56
Откуда: United Card Service

Сообщение Михаил Григорьев » 30 авг 2003, 10:20

Возможно проблема только на Apache 1.3.27 На 1.3.28 с phpMyAdmin 2.5.3-rc всё в норме... Ничего не пришлось даже настраивать, он сам все нашел и понял, тока сказал переменную $cfg ['PmaAbsoluteUri'] установить и все
Аватара пользователя
Михаил Григорьев
 
Сообщения: 1461
Зарегистрирован: 04 июн 2002, 12:22
Откуда: Челябинск

Сообщение Игорь Вершинин » 01 сен 2003, 10:13

Да нет. У меня сейчас 1.3.28 версия Apache. И переменные все как надо установлены.... Не работает. Если подключаемые библиотеки скинуть в основную директорию (где лежит index.php), то тогда все нормально. Относительно нормально. Но это не нормально. :)
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Сообщение Игорь Вершинин » 01 сен 2003, 10:53

Все. Проблема решилась.

Hi Patrick,

What version of NetWare are you using?

This could be due to the open_basedir directive in php.ini. Try with
that directive disabled like:
open_basedir =

Thanks,
Ananth.

Patrick Corrigan wrote:

> Does anyone have working php.ini anc config.inc.php files that you are
> willing to share, with user names, passwords, etc. changed, of course?
>
> I have tried everything to get phpMyAdmin to run, and nothing seems to
> be able to get rid of the "Failed opening required
> './libraries/grab_globals.lib.php'" error.
>
> Thanks.
>

Надо просто либо очистить переменную open_basedir в php.ini. Либо перечислить там те пути, откуда можно подгружать файлы. По умолчанию там указан лишь путь в текущий каталог.
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 5

cron