Сервер 5.1 вставляю в дерево с 4.11 - странные вещи

Обсуждение технических вопросов по продуктам Novell

Сервер 5.1 вставляю в дерево с 4.11 - странные вещи

Сообщение Сергей Дубров » 30 июл 2003, 13:33

Вроде не первый раз это уже делаю, но вот... Было два тестовых дерева - первое с одним сервером 4.11 и второе с одним 5.1. Снёс с NW5.1 дерево, вставляю 5.1(sp5) в существующее с 4.11 (sp9) (нужно именно так). Все подготовительные операции сделаны, DS - 6.17, NLS сервис установлен.

Втыкаю 5.1 в дерево с 4.11, начинаю в соотв. с ТИДом 10063721 восстанавливать нужные объекты (до этого в дереве 5.1 не было, чистый 4.11). Имею несколько странных моментов:

1. PKIDIAG на последнем (6-ом) шаге говорит, что "The IP address in KMO SSL CertificateIP (xxnw51.inp.nsk.su.O=BINP) does not match the default IP address (*.*.*.*).
Step 6 failed -659.

При этом IP Показывается правильный. Ключ /ip *.*.*.* не помог.

2. В соотв. с ТИДом 10058071 переустанавливаю LDAP: STARTX -> Install -> LDAP server - remove -> reboot сервер, опять STARTX -> Install -> выбираю LDAP -> просит ввести имя юзера с правами на контейнер с сервером - ввожу админа и... обламываюсь: "This user does not have sufficient right..."

3. В C1 не могу посмотреть свойства у свежесозданных KMO: "SSL CertificateIP" и "SSL CertificateDNS" - просто молча ничего не открывается при выборе по правой кнпке

4. Не все объекты вижу в контейнере Security, создался только CA.

Блин, последний раз приживлял 5.1 в дерево с 4.11 only так давно, что успел всё позабыть. Подскажите, кто помнит лучше, как проблемы преодолевать. ТИДы изучил все, какие нашёл...
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Доигрался, блин...

Сообщение Сергей Дубров » 30 июл 2003, 16:15

При попытке добавить [root] реплику на NW5.1 она оставалась перманентно в состоянии New. А добавлять стал из-за необходимости иметь bindery context, в одном из тидов по поводу insufficient rights при переустановке LDAP упоминают необходимость наличия bindery context-а на сервере (TID10057710).

В общем, пПрождав пару часов, решил убрать New replica из replica ring силовыми методами + по одному из тидов продекларировал new epocha для схемы. Результат:

ошибка SkulkSchema failed, partition busy (-654)
и
ошибка failed, partition busy (-654).

По поводу последней ошибки, как я понимаю - полный кирдык. Ладно, если что, у меня образы дисков (Ghost for NW) есть для обоих серверов, если что - завтра откачусь в исходную позицию.
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Сообщение Андрей Троценко » 30 июл 2003, 16:25

Сергей, по-моему, в Вашем случае можно удалить новый сервер из NDS (C1 или PARTMGR) - операция изменения раздела оборвется.
Аватара пользователя
Андрей Троценко
 
Сообщения: 529
Зарегистрирован: 31 июл 2002, 13:54
Откуда: Киев, Украина

Буду пробовать завтра...

Сообщение Сергей Дубров » 30 июл 2003, 16:40

Андрей Троценко писал(а):Сергей, по-моему, в Вашем случае можно удалить новый сервер из NDS (C1 или PARTMGR) - операция изменения раздела оборвется.

Да, спасибо за идею, действительно это может помочь. Но пробовать буду уже завтра, сейчас домой пора...
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Re: Сервер 5.1 вставляю в дерево с 4.11 - странные вещи

Сообщение Андрей Казимиров » 31 июл 2003, 06:01

Сергей Дубров писал(а):...Блин, последний раз приживлял 5.1 в дерево с 4.11 only так давно, что успел всё позабыть. Подскажите, кто помнит лучше, как проблемы преодолевать. ТИДы изучил все, какие нашёл...

Сергей у меня недавно была подобная проблема (ТИДы не спасли :-)),
убил неделю на эксперименты, плюнул на все, поставил 4.11, затем сверху накатил 5.1. Вся процедура - 1.5 часа.
Всеже если сможете решить задачу "правильно", напишите плиз, очень интересно.
Андрей Казимиров
 
Сообщения: 11
Зарегистрирован: 15 янв 2003, 13:57

Re: Сервер 5.1 вставляю в дерево с 4.11 - странные вещи

Сообщение Сергей Дубров » 31 июл 2003, 09:25

Андрей Казимиров писал(а):
Сергей Дубров писал(а):...Блин, последний раз приживлял 5.1 в дерево с 4.11 only так давно, что успел всё позабыть. Подскажите, кто помнит лучше, как проблемы преодолевать. ТИДы изучил все, какие нашёл...

Сергей у меня недавно была подобная проблема (ТИДы не спасли :-)),
убил неделю на эксперименты, плюнул на все, поставил 4.11, затем сверху накатил 5.1. Вся процедура - 1.5 часа.
Всеже если сможете решить задачу "правильно", напишите плиз, очень интересно.

Меня вариант с установкой сначала 4.11, а потом поверх 5.1 не устраивает - железо такое, что под него нет драйверов под 4.xx.

Сейчас сдела вот что - снёс реплику с NW5.1 (DSREPAIR -XK2), убрал сервер из replica ring, потом полностью удалил DS с сервера. В оставшемся дереве подчистил все следы пребывания 5.1 - удалил контейнер security и все объекты, связанные с удалённым сервером, т.е. вернул дерево с 4.11 в исходное состояние.

Дальше ещё раз прогнал на этом дереве NWDEPLOY - NDS соответствует, подготовка к NDS8 прошла (хотя это и делалось раньше).

Теперь опять пытаюсь вставить существующий 5.1 (на котором снесен DS) в существующее дерево с чистым 4.11 (DS 6.17). Вижу дерево, добавляю - и NWCONFIG навечно зависает. Вчера, кстати, было точно также - ждал час, сегодня - полтора - не появляется сообщения об успешной инсталляции. Но сервер в дереве виден, про установленную синхронизацию с существующим 4.11 было доложено. Что за бардак? Неужели действительно 5.1 так хреновенько приживается в дерево с чистым 4.11? Собственно, весь вчерашний геморрой был от того, что я ещё и реплику попытался сделать на 5.1, а она навечно в New осталась.

Я вспомнил свои прошлые успешные попытки с вживлением 5.1 в дерево 4.11/4.20 - во-первых, это была инсталляция нового, а не установка деревянного сервиса на сервер 5.1 с установкой в существующее дерево. Во-вторых, каждый раз это был NDS v7 (сейчас ставлю 8, 8.82).

Ну, какие-нибудь идеи ещё будут?

Или в самом деле, просто инсталлировать 5.1 с нуля и вставить его в существуюшее дерево (с оверлейного диска, сразу с сервис-паком), а не так как делал я - установка в отдельное дерево, снос дерева, установка в существующее.

Дополнение: сейчас посмотрел консоль сервера 4.11 (с мастер-репликой), на экране Directory services постоянно идёт сообщение:

Schema has NOT completed synchronizing with <XXNW51.CSD.BINP>.
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Сообщение Павел Орлов aka XerX » 31 июл 2003, 10:32

Возможно я повведу совсем не туда... но ... Какие протоколы установлены на 5.1 и 4.11 ? У меня возникали подобные глюки при установки 5.1 с присутствующим IP - была какая-то проблема с перебором протоколов... и установка сервера в дерево так никогда и не завершалась... - решилось просто - установкой сервера 5.1 только с IPX с последующим поднятием IP
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Может быть так и есть...

Сообщение Сергей Дубров » 31 июл 2003, 11:13

Павел Орлов aka XerX писал(а):Возможно я повведу совсем не туда... но ... Какие протоколы установлены на 5.1 и 4.11 ? У меня возникали подобные глюки при установки 5.1 с присутствующим IP - была какая-то проблема с перебором протоколов... и установка сервера в дерево так никогда и не завершалась... - решилось просто - установкой сервера 5.1 только с IPX с последующим поднятием IP

На 5.1 установлены IP и IPX, мне сразу нужен был сервер именно с ними обоими (для тренировки сначала и поставил его в отдельное дерево).

Может быть, вариант вставки сервера без IP, а только с IPX-ом и решит проблему, надо будет попробовать. Что нужно закоментировать для сноса IP на сервере, у которого снесено дерево (у меня все в autoexec, из-за агрегирования линков в inetcfg не засунешь)? Или надо честно снести IP именно инсталлятором? Сервер неохота переставлять с нуля, там уже кое-чего понаставлено, и это "кое-чего" надо в новое дерево ввести.

Кстати, на другом форуме, совсем недавно, человек пожаловался на абсолютно ту же проблему - ставил 5.1SP6(оверлей) в дерево к NW4.11+SP9+DS6.17 (почти точно, как у меня, только мой 5.1 - с сп5). Говорит, что без проблем ввести 5.1 в дерево к 4.11 у него получилось только с исходным 5.1, без сервис-пака.
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Сообщение Павел Орлов aka XerX » 31 июл 2003, 11:20

А вот у меня NW 5.1 с оверлееным SP5 даже устанавливаться не захотел... 8-) на старенький Compaq DL 380
полез на новел - они говорят что возможно что это из-за RW болванки...
А на счет протоколов - по моему достаточно бинды снять....
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Да, у меня тоже...

Сообщение Сергей Дубров » 31 июл 2003, 12:05

Павел Орлов aka XerX писал(а):А вот у меня NW 5.1 с оверлееным SP5 даже устанавливаться не захотел... 8-) на старенький Compaq DL 380
полез на новел - они говорят что возможно что это из-за RW болванки...

...не первый оверлейный диск заработал (с сп5). Пошёл нормально англо-испанский :roll:

Павел Орлов aka XerX писал(а):А на счет протоколов - по моему достаточно бинды снять....

Сейчас так и сделал - в очередной раз вынес 5.1 из дерева, удалил на нём DS, в autoexec-е закомментировал всё, что относится к TCPIP, загрузился. Сеть есть, по display servers вижу всех. Ставлю DS, установка в существующее, выбираю из списка и... всё. В отличии от варианта с поднятым IP, в котором после появления окна на тему несинхронизированного времени больше ничего на экране не возникало, здесь появилось обычное окно с сообщением: "Installing Directory Services... ". Жду уже двадцать минут - ничего не происходит, давно должно было завершиться, в дереве-то всего полтора десятка объектов. Сервер в дереве появился, на консоли сообщение Established communication with server .*.CSD.BINP возникло. Да, и на консоли сервера 4.11 опять аюсолютно та же самая диагностика:

Schema has NOT completed synchronizing with <XXNW51.CSD.BINP>.

В общем, на мой взгляд, наблюдается несостыковка версий DS 8.82 (из сп5 nw5.1) и DS6.17. Монстры, кто что может сказать по этому поводу? Вариант с установкой 5.1 без СП буду пробовать,о, наверное, уже на следующей неделе, на другом железе, а этого монстра с установленным 5.1+сп5 трогать не хочется - вдруг заборю?

Дополнение: по TID10014285 включил на 4.11 (master):

SET DSTRACE=+SCHEMA
SET DSTRACE=*SSD
SET DSTRACE=*SSA

По экрану полетели обновления (очень быстро), с перемежающимся сообщением SkulkSchema error -722. Пошёл искать дальше...

Мда, круто, нашёл по строке Skulk error (один TID всего) очень "обнадёживающий" solution:

The problem requires a dial in by Novell's Resolution Engineers.

Блин, неужели действительно, как посоветовал Николай Музалёв, придётся ставить 5.1 заново, с NDS7, а потом уже апгрейдится на NDS8 (eDir)? Круто Новел работает, совместимость просто никакая...
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Сообщение Андрей Тр. aka RH » 31 июл 2003, 13:02

Им сейчас не до того, похоже - они ж к сдаче 6.5 готовятся, вон пошли релизы DS с фиксами под 6.5, 6.21 для 4.11 / 4.2, 7.62b для 5.1. А люди, встраивающие 5 в 4, видимо, где-то в конце списка. В том числе и по этой причине я в свое время изо всех сил старался избегать заниматься подобными вещами - благо были возможности совмещать приятное с полезным ( новые сервера - апгрейд до текущей версии ). Прошу прощения за флейм :?

Кстати, а версии DSREPAIR стоят какие ?
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

Сообщение Сергей Дубров » 31 июл 2003, 13:29

Андрей Тр. aka RH писал(а):Им сейчас не до того, похоже - они ж к сдаче 6.5 готовятся, вон пошли релизы DS с фиксами под 6.5, 6.21 для 4.11 / 4.2, 7.62b для 5.1. А люди, встраивающие 5 в 4, видимо, где-то в конце списка.

Похоже так, гонка с катастрофическим ухудшением качества продуктов. И эти люди ещё про совместимость мелкомягким пеняли...

Андрей Тр. aka RH писал(а):В том числе и по этой причине я в свое время изо всех сил старался избегать заниматься подобными вещами - благо были возможности совмещать приятное с полезным ( новые сервера - апгрейд до текущей версии ). Прошу прощения за флейм :?

У нас апргейд не пройдет, к сожалению...

Кстати, а версии DSREPAIR стоят какие ?

На 5.1 - 85.19, на 4.11 - 4.72d
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Сообщение Константин Ошмян » 31 июл 2003, 20:01

Сергей, приветствую!
[...] после появления окна на тему несинхронизированного времени [...]
Извини за глупый вопрос, но время у тебя нормально засинхронизировано, от одного источника?
Аватара пользователя
Константин Ошмян
 
Сообщения: 958
Зарегистрирован: 13 авг 2002, 21:36
Откуда: Рига

Про время...

Сообщение Сергей Дубров » 01 авг 2003, 06:41

Константин Ошмян писал(а):Сергей, приветствую!
[...] после появления окна на тему несинхронизированного времени [...]
Извини за глупый вопрос, но время у тебя нормально засинхронизировано, от одного источника?

С синхронизацией вообще интересно - исходно у меня единственный 4.11 выставлен в SINGLE и берёт время (по древнему rdate) с внешнего источника (местный юникс). Когда я добавляю 5.1 в это дерево, я его делаю (чтобы избежать конфликта) SECONDARY, но мне так и не удалось заставить в таком раскладе заставить заработать синхронизацию на 5.1! SAP adversiting для времени на 4.11 выставлен, но - не работает.

Синхронизацию удавалось победить только поменяв ролями 4.11 и 5.1 - на 5.1 взводил NTP от ближайшего time source и делал его SINGLE, а 4.11 менял на SECONDARY и ЯВНО прописывал сервер с 5.1 в качестве источника, по SAP-ам тоже не хотел работать.

В общем получается интересный момент - когда я вставляю первый 5.1 в дерево, в котором есть только 4.11/4.2, то пока я не отберу у 4.11 роль SINGLE - синхронизация не наступит, т.е. в момент иснталляции в существующее дерево я обязательно вижу на 5.1 этот фиолетовый экран с предупреждением про невозможность засинхронизировать время.
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

Сообщение Павел Орлов aka XerX » 01 авг 2003, 09:00

А вот это уже интересно.... (на счет времени)
А вот если сделать 4.11 и 5.1 оба праймари... и указать в качестве внешнего источника времени друг друга и юникс....
правда на 5.1 придется SCMD.nlm грузить и всю эту бодягу настраивать....
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

След.

Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 8

cron