При запуске phpMyAdmin

Обсуждение технических вопросов по продуктам Novell

При запуске phpMyAdmin

Сообщение ProRus » 07 июл 2003, 15:46

При запуске phpMyAdmin/index.php выдает следующее...
Novell 5.1. SP 6 + MySQL 4.0.13 + Apache 1.3.27

Warning: open_basedir restriction in effect. File is in wrong directory in sys:/apache/htdocs/phpmyadmin/index.php on line 9
Fatal error: Failed opening required './libraries/grab_globals.lib.php' (include_path='.;sys:/php/includes') in sys:/apache/htdocs/phpmyadmin/index.php on line 9

В чем причина?
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Сообщение Музалёв Николай » 07 июл 2003, 19:15

ProRus писал(а):(include_path='.;sys:/php/includes') in sys:/apache/htdocs/phpmyadmin/index.php on line 9

А точка с запятой в пути - это правильно?
armoracia rusticana (lat.), "блины" и "фиги" всех видов, а также смайлики - крайне не желательны !
Музалёв Николай
 
Сообщения: 3026
Зарегистрирован: 04 июн 2002, 19:58
Откуда: Беларусь. МИНСК.

А как надо?

Сообщение ProRus » 08 июл 2003, 05:25

А как надо?
Я уже все пробовал и так и сяк...
Такой папки вообще не существует, это так по умолчанию в php.ini написано.
Мне так кажется что нехватает какихт библиотек, немогу понять каких...
LibC самые свежие вчера скачал, поставил.

Не отрабатываются require('./libraries/grab_globals.lib.php'),
может он неможет свои библиотеки найти?
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка

Сообщение Андрей Троценко » 08 июл 2003, 13:10

IMHO, ключевая фраза "open_basedir restriction in effect" - стоит проверить, разрешен ли в конфигурации Apache доступ в указанную директорию (секция вроде нижеследующей):

<Directory "sys:/apache/libraries/"> # или куда он ссылается ?
# Options Indexes FollowSymLinks
AllowOverride None
#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all
</Directory>

Может у Вас "AllowOverride All" - тогда нужно смотреть sys:/apache/htdocs/phpmyadmin/.htaccess

Еще: http://bugs.php.net/
Аватара пользователя
Андрей Троценко
 
Сообщения: 529
Зарегистрирован: 31 июл 2002, 13:54
Откуда: Киев, Украина

Вот так...

Сообщение ProRus » 09 июл 2003, 06:35

Оказывается все работает...
Просто не находит данной библиотеки на которую ссылается require('./libraries/grab_globals.lib.php').

Пробовал создать самый простой PHP и перенаправление на другой PHP в томж каталоге перенаправление работает, но при перемещении файла в каталог ниже, php его не обнаруживает ... :((

Как сделать чтоб правильно понимал место нахождения данного файла?

Походу чтот сдесь нетак...
require('./libraries/grab_globals.lib.php')
ProRus
 
Сообщения: 49
Зарегистрирован: 04 окт 2002, 06:46
Откуда: г. Дудинка


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

cron