Интересная бага с RCONAG6 и NW51sp6

Обсуждение технических вопросов по продуктам Novell

Интересная бага с RCONAG6 и NW51sp6

Сообщение Alex-M » 11 июн 2003, 14:46

Есть интересная трабла.
Имеем сервера, на которые ставились nw51sp6 и nici 2.4.2. После постановки оных имеем следующее:
- при загрузке в самом начале кто-то (похоже XMGR или CCS) ругаются на неверный/несконфигурённый NICI или сертификат. Но далее грузится нормально.
- далее, при загрузке RCONAG6 он ругается "SAS_CryptInit failed. KeyMaterial not found.". Соответственно, невозможно подключиться по SecureIP (port 2036). По Unsecure (2034) - OK!
- SSL в принципе работает (ибо есть сертификаты), т.е. работают AdminServer, Web Manager и т.п.
Вопрос - где грабли? Нужно пересоздать сертификаты? Если да - с какими параметрами?

Далее ещё чудесатее! :-) Ставим в это дерево сервер с NW51sp6 overlay CD. Всё прекрасно. Ставим поверх NICI 2.4.2. И получаем:
- пункт 1 полностью (ругань CCS или XMGR на проблемы с NICI, но далее всё пучком).
- пункта 2 нет как класса!. Т.е. RCONAG6 не ругается, в TCPCONе появляется порт 2036 и можно юзать СекуреИП! :shock:
- ну, про остальное и говорить нечего... :-)

Повторяю - разница только в дистрибутиве (интегрированный пак и последовательно установленный), NICI ставилось и там и там.
Где копать?
Вагончик тронется, НОВЕЛЛ - останется!!!
Alex-M
 
Сообщения: 298
Зарегистрирован: 21 авг 2002, 16:46
Откуда: Москва, МИД России

Сообщение Михаил Григорьев » 11 июн 2003, 14:59

Точно не скажу НО возможно дело в версии TCP/IP вернее по умолчанию она вроде 56bit
Возможно NICI 2.4.2 нужно TCP/IP 128bit

Не факт конечно... но вдруг
Аватара пользователя
Михаил Григорьев
 
Сообщения: 1461
Зарегистрирован: 04 июн 2002, 12:22
Откуда: Челябинск

Re: Интересная бага с RCONAG6 и NW51sp6

Сообщение alexp_mac » 11 июн 2003, 15:08

по п1 это нормально, тид про это есть. По остальному по-моему надо ставить в разных вариантах и трахаться. А оверлей какой-то нетакой, у меня сигнатуре левел 2 везде, так при установке с оверлея устанавливаемый сервер абендится.
alexp_mac
 
Сообщения: 788
Зарегистрирован: 28 июн 2002, 10:50

Сообщение Alex-M » 11 июн 2003, 15:30

Григорьев Михаил Стоит везде 128 бит... С самого начала (Нетварь сама 128-битная).

Алексей Подгорчук Имеется в виду ТИД про гонки между SAS и NILE? :-) Читал, не то... Пробовал SAS v.1.72 - не лечится...
И потом: а) SSL то работает (значит и SAS и NILE) и б) почему на сервере с оверлея СекуреИП работает?
Я ж говорю - сервера абсолютно одинаковые, за исключением дистрибутива - все без пака, один - с ним. Я понимаю, если б всё было наоборот! :-) Тогда были бы крики про глючный оверлей и т.д. и т.п... Но ситуация обратная.
Вагончик тронется, НОВЕЛЛ - останется!!!
Alex-M
 
Сообщения: 298
Зарегистрирован: 21 авг 2002, 16:46
Откуда: Москва, МИД России

Сообщение alexp_mac » 11 июн 2003, 20:14

[b]Алексей Подгорчук[/b] Имеется в виду ТИД про гонки между SAS и NILE? :-)

Так ругается
http://support.novell.com/cgi-bin/searc ... 077215.htm
alexp_mac
 
Сообщения: 788
Зарегистрирован: 28 июн 2002, 10:50

Сообщение Alex-M » 11 июн 2003, 20:33

Алексей Подгорчук Похоже на то... По крайней мере про "0 minutes" там что-то есть. Просто это проскакивает в самом начале, ещё до загрузки CONLOG-а и не попадает в лог.
Но это есть на всех серверах. И не вызывает проблем (как и написано в ТИДе :-) ).
А по поводу RCONAG6 ERROR SAS SAS_CryptInit failed... никаких мыслей?
У меня есть идея (бред, но всё же...) скопировать всё содержимое SYS:SYSTEM (за исключением, конечно, уникальных файлов, типа nicifk, products.dat, *.ncf и прочего) с того сервера, где работает, туда, где не работает. Мэй би поможет... :-) Иль сертификаты пересоздать, что-ли?..
Вагончик тронется, НОВЕЛЛ - останется!!!
Alex-M
 
Сообщения: 298
Зарегистрирован: 21 авг 2002, 16:46
Откуда: Москва, МИД России

Сообщение alexp_mac » 11 июн 2003, 21:01

[quote="Alex-M"][b]Алексей Подгорчук[/b] Похоже на то... По крайней мере про "0 minutes" там что-то есть. Просто это проскакивает в самом начале, ещё до загрузки CONLOG-а и не попадает в лог.

(я тоже потел минут двадцать пока успел прочесть и записать)

Но это есть на всех серверах. И не вызывает проблем (как и написано в ТИДе :-) ).



А по поводу RCONAG6 ERROR SAS SAS_CryptInit failed... никаких мыслей?
У меня есть идея (бред, но всё же...) скопировать всё содержимое SYS:SYSTEM (за исключением, конечно, уникальных файлов, типа nicifk, products.dat, *.ncf и прочего) с того сервера, где работает, туда, где не работает. Мэй би поможет... :-) Иль сертификаты пересоздать, что-ли?..[/quote]


Я-бы начал с сертификатов, т.к. файлы отвечающие за криптографию впринципе можно найти и руками посравнивать, а то как-то сервер жалко вот так его пахать.
alexp_mac
 
Сообщения: 788
Зарегистрирован: 28 июн 2002, 10:50


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot], Yahoo [Bot] и гости: 4

cron