Zen works 4

Обсуждение технических вопросов по продуктам Novell

Zen works 4

Сообщение Nurgul » 31 янв 2003, 11:05

При запуске NALDESK.exe (данный файл лежит на sys:\public) выходит сообщение Application Explorer:


The version of NT service you have loaded is out of date. Please install version 20010726.


OS server: Netware 6+SP2, Zen works for Desktops 4, Client 4.83+SP1 (WinXP).
P.S. Агент Zen works 4 не установлен на рабочей станции, работает обычный клиент.
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

Сообщение Андрей Тр. aka RH » 31 янв 2003, 12:12

У меня аналогичная вещь была с ZfD3.2 SP1 под NW5.1, клиент WinXP 4.83SP1. Причем сообщение выдавалось не стабильно, а лишь иногда (?). Разбираться еще не пытались, т.к. все происходило в условиях тестирования - пока процесс приостановлен ( не устраивает требование членства пользователей в Power Users ).

P.S. Кстати, вот здесь говорится, что аналогичная ошибка возникает из-за недостаточных прав пользователя для апдейта службы в Виндоуз ( если запускать NAL из PUBLIC, то приложению может захотеться обновить его на станции; не уверен, как с этим сейчас в ZfD4 - думаю, там такие же требования к локальным правам пользователей ). http://support.novell.com/cgi-bin/searc ... 023981.htm
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

zfd4

Сообщение Константин Матвеев » 31 янв 2003, 13:05

при установке клиента32 на рабочую станцию, не нужно выбирать nal, поскольку он не работает с ZfD4. у него свой собственный легкий (400 кило) агент, которому кстати и не нужен клиент32. просто надо его установить на рабочую станцию (можно даже без клиента32) и nal будет работать нормально.

единственное в чем я не уверен – в правильности запуска naldesk. по-моему в черверке просто запускается nal. если не прав – пожалуйста поправьте.
Константин Матвеев, MCNE
Аватара пользователя
Константин Матвеев
 
Сообщения: 252
Зарегистрирован: 10 июл 2002, 13:49
Откуда: Москва

не работают политки

Сообщение Nurgul » 31 янв 2003, 16:54

Работу Application Launcher настроила через naldesk.exe.

Необходимо сынтегрировать работу client32 и zen 4, без установки агента zen 4.
Теперь вторая проблема: не работают политики, ни импорт, ни пользовательские политики.
search policy проверяла все нормально.

где искать уже не знаю, подскажите......
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

Effective Policies

Сообщение Константин Матвеев » 31 янв 2003, 17:38

Effective Policies что говорят для конкретного объекта?
Константин Матвеев, MCNE
Аватара пользователя
Константин Матвеев
 
Сообщения: 252
Зарегистрирован: 10 июл 2002, 13:49
Откуда: Москва

Сообщение Андрей Тр. aka RH » 31 янв 2003, 17:40

Из общих соображений - патчи для ZEN4 ни в чем не помогают ? http://support.novell.com/cgi-bin/searc ... i?10077083
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

Есть

Сообщение Nurgul » 31 янв 2003, 17:45

В Effective Policies есть пользовательская политика.
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

посмотрите

Сообщение Константин Матвеев » 31 янв 2003, 18:00

посмотрите следующее:

http://support.novell.com/cgi-bin/searc ... 077450.htm


кстати, wsreg проходит нормально?
Константин Матвеев, MCNE
Аватара пользователя
Константин Матвеев
 
Сообщения: 252
Зарегистрирован: 10 июл 2002, 13:49
Откуда: Москва

Рабочие станции импортируются, но возникают ошибки

Сообщение Nurgul » 31 янв 2003, 18:14

Фрагмент zenwsimp.log:

Jan 31, 2003 7:14:26 PM java.net.SocketException: Error 0
Jan 31, 2003 7:15:13 PM Connection opened: 192.168.9.102/192.168.9.102
Jan 31, 2003 7:15:13 PM request = <TOKEN_OBJECT_SEARCH>LKonduzbaeva00:40:05:5D:D3:3EWIN95.Otd_control.KGIP.COMITTEES
Jan 31, 2003 7:15:14 PM Found workstation: LKonduzbaeva00:40:05:5D:D3:3EWIN95.Otd_control.KGIP.COMITTEES
Jan 31, 2003 7:15:14 PM Could not get the workstation ID.LKonduzbaeva00:40:05:5D:D3:3EWIN95.Otd_control.KGIP.COMITTEES
Jan 31, 2003 7:15:14 PM Connection closed: 192.168.9.102/192.168.9.102
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

wsreg32.log

Сообщение Константин Матвеев » 05 фев 2003, 16:53

а что говорит wsreg32.log?
там тоже ошибки?
прицитируйте.....
Константин Матвеев, MCNE
Аватара пользователя
Константин Матвеев
 
Сообщения: 252
Зарегистрирован: 10 июл 2002, 13:49
Откуда: Москва

WSREG32

Сообщение Nurgul » 06 фев 2003, 18:16

*****(1)***** 28.01.03 13:06:59
WSREG-v3.0 This log file is reporting activity on a WM_USER_LOGIN_EVENT event.
WSREG-v3.0 This workstation is already registered. The workstation needs to be imported into the tree.
WSREG-v3.0 The program finished running.
*****(2)***** 31.01.03 10:45:40
WSREG-v3.0 This log file is reporting activity on a WM_SERVICE_START_EVENT event.
WSREG-v3.0 While contacting the Work Station Import Service, an error -1 was encountered, and error description <A tree name is required since the naming and/or location is based on the user.> was reported.
WSREG-v3.0 Registration will not occur for this event.
WSREG-v3.0 The program finished running.
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

Сообщение ILCooL » 07 фев 2003, 11:18

По вопросу интеграции zen 4 с клиентом, первое решение, которое нашли: скопировали файлы naldesk.exe nalexp32.dll zenapp32.dll в папку с клиентом, правда выдавало у нас другое сообщение.... Но хотелось бы получить и более автоматизированное решение

импорт проходит после запуска анрега... :shock:
Аватара пользователя
ILCooL
 
Сообщения: 53
Зарегистрирован: 06 июн 2002, 12:38
Откуда: Minsk

Как решение интеграция client32 и zen 4

Сообщение Nurgul » 07 фев 2003, 12:37

Проблему интеграции client32 и zen 4 решила так:
1. установила на администраторскую машину агента zen 4
2. локальные файлы агента скопировала на сервер
3. на всех машинах запустила nalntsrv install start (у нас машины XP)
4. запускаю Application Explorer с сервера, как и раньше, версия Application Explorer 4.0, с помощью naldesk.exe
5. ошибок никаких пока нет, приложения запускаются нормально.

Машины регистрируются и импортируюся, работает удаленное управление, но вот только в логах такие ошибки (см.выше темы).
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

Сообщение Иван Левшин aka Ivan L. » 07 фев 2003, 12:53

Насколько я понимаю - после 28.01.03 изменили политику именования объектов Workstation в дереве. И теперь пытаемся при создании объекта применять в имени имя пользователя (скорее всего). В такой ситуации у меня была та же проблема - тогда, после муторного изучения ТИДов и совещаний с Андрей Тр. aka RH (привет, Андрей!) мы пришли к выводу, что импорт надо проверить сначала без использования имени пользователя в имени машины. Т.е. в имени использовать либо стандартный <имя машины>+<МАС>, либо что-то в том же духе. Вот так у Вас проходит регистрация машины в дереве или нет?
И еще - опытным путем выяснил, что wsreg32 при работе использует данные из реестра - ветка HKEY_LOCAL_MACHINE\Software\Novell\Workstation Manager\Identification. Если там забиты неправильные данные (я с этим столкнулся) - она не забивает их правильными и вообще вываливает ошибки! У меня тогда было состояние, близкое к паранойе :) Попробуйте очистить все текстовые поля в этой ветке и попробовать зарегистрировать машину в дереве
Иван Левшин aka Ivan L.
 
Сообщения: 2363
Зарегистрирован: 05 июн 2002, 18:36
Откуда: Новомосковск, Тул. обл.

импорт рабочих станций

Сообщение Nurgul » 07 фев 2003, 13:36

Ситуация такая: раньше стоял zen 3, сынсталлировала zen 4.
Все объекты рабочих станций и политики удалила, перед тем как инсталлировать zen 4.
После инсталляция заново настроила политики: container, server, service location, workstation.
Формирование имени рабочей станции: User+MAC+OS
Такое же именование было и с zen 3.

Сейчас попробую очистить ветку реестра и заново зарегистрироваться.
Nurgul
 
Сообщения: 23
Зарегистрирован: 26 июн 2002, 07:01

След.

Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 8

cron