Перестала стартовать novell-nss, что можно сделать?

Обсуждение технических вопросов по продуктам Novell под Linux, а также *nix систем

Перестала стартовать novell-nss, что можно сделать?

Сообщение BDmV » 15 сен 2015, 17:05

После обновления SLES11 SP3 перестала пускаться nss
server:/# rcnovell-nss start
Starting Novell Storage Services (NSS)
ERROR: modinfo: could not find module nwraid
ERROR: Cannot find nwraid.ko
.......... ABORTING /sbin/rcnovell-nss ..........
nss: Failed to set the NSS_TZOffset, returned 2
mknod: missing operand after `0'
Try `mknod --help' for more information.
chgrp: cannot access `/dev/zapi': No such file or directory
chmod: cannot access `/dev/zapi': No such file or directory
Scan devices and mount pools
NSS is NOT fully running!

Подскажите, пожалуйста что можно с этим сделать?

ЗЫ. Пытался сделать как написано в https://www.novell.com/support/kb/doc.php?id=7006656 , но каталога /weak-updates/updates/ у меня просто нет.
прописал линки из др. каталога и при запуске получил:
FATAL: Error inserting nwraid (/lib/modules/3.0.101-63-default/weak-updates/updates/nwraid.ko): Invalid module format
BDmV
 
Сообщения: 178
Зарегистрирован: 17 апр 2003, 20:24
Откуда: г. Видное

Re: Перестала стартовать novell-nss, что можно сделать?

Сообщение Ковалев Артем » 15 сен 2015, 17:50

берем картину мироздания и тупо смотрим - что к чему...
Аватара пользователя
Ковалев Артем
 
Сообщения: 910
Зарегистрирован: 29 мар 2004, 11:44
Откуда: Москва

Re: Перестала стартовать novell-nss, что можно сделать?

Сообщение Константин Ошмян » 15 сен 2015, 20:19

BDmV писал(а):Пытался сделать как написано в https://www.novell.com/support/kb/doc.php?id=7006656 , но каталога /weak-updates/updates/ у меня просто нет.
прописал линки из др. каталога и при запуске получил:
FATAL: Error inserting nwraid (/lib/modules/3.0.101-63-default/weak-updates/updates/nwraid.ko): Invalid module format
Странно. На моих серверах OES такие каталоги есть:
Код: Выделить всё
lx4:/lib/modules/3.0.101-0.47.55-default/weak-updates/updates # ls -l
total 8
lrwxrwxrwx 1 root root   52 Jul 31 11:34 admindrv.ko -> /lib/modules/3.0.76-0.11-default/updates/admindrv.ko
lrwxrwxrwx 1 root root   51 Jul 31 11:32 adminfs.ko -> /lib/modules/3.0.76-0.11-default/updates/adminfs.ko
lrwxrwxrwx 1 root root   54 Jul 31 11:32 adminfsdrv.ko -> /lib/modules/3.0.76-0.11-default/updates/adminfsdrv.ko
lrwxrwxrwx 1 root root   48 Jul 31 11:34 kmdb.ko -> /lib/modules/3.0.76-0.11-default/updates/kmdb.ko
lrwxrwxrwx 1 root root   50 Jul 31 11:34 libnss.ko -> /lib/modules/3.0.76-0.11-default/updates/libnss.ko
drwxr-xr-x 2 root root 4096 Jul 31 11:34 ncs
lrwxrwxrwx 1 root root   50 Jul 31 11:34 ndpmod.ko -> /lib/modules/3.0.76-0.11-default/updates/ndpmod.ko
lrwxrwxrwx 1 root root   50 Jul 31 11:34 nebdrv.ko -> /lib/modules/3.0.76-0.11-default/updates/nebdrv.ko
lrwxrwxrwx 1 root root   49 Jul 31 11:32 novfs.ko -> /lib/modules/3.0.76-0.11-default/updates/novfs.ko
lrwxrwxrwx 1 root root   47 Jul 31 11:34 nss.ko -> /lib/modules/3.0.76-0.11-default/updates/nss.ko
lrwxrwxrwx 1 root root   51 Jul 31 11:34 nsscomn.ko -> /lib/modules/3.0.76-0.11-default/updates/nsscomn.ko
lrwxrwxrwx 1 root root   54 Jul 31 11:34 nsslibrary.ko -> /lib/modules/3.0.76-0.11-default/updates/nsslibrary.ko
lrwxrwxrwx 1 root root   53 Jul 31 11:34 nsslnxlib.ko -> /lib/modules/3.0.76-0.11-default/updates/nsslnxlib.ko
lrwxrwxrwx 1 root root   50 Jul 31 11:34 nsslsa.ko -> /lib/modules/3.0.76-0.11-default/updates/nsslsa.ko
lrwxrwxrwx 1 root root   53 Jul 31 11:34 nssmanage.ko -> /lib/modules/3.0.76-0.11-default/updates/nssmanage.ko
lrwxrwxrwx 1 root root   51 Jul 31 11:34 nsszlss.ko -> /lib/modules/3.0.76-0.11-default/updates/nsszlss.ko
lrwxrwxrwx 1 root root   50 Jul 31 11:34 nwraid.ko -> /lib/modules/3.0.76-0.11-default/updates/nwraid.ko
lrwxrwxrwx 1 root root   47 Jul 31 11:32 pmd.ko -> /lib/modules/3.0.76-0.11-default/updates/pmd.ko
drwxr-xr-x 5 root root 4096 Jul 31 11:32 vigil
lrwxrwxrwx 1 root root   48 Jul 31 11:34 zapi.ko -> /lib/modules/3.0.76-0.11-default/updates/zapi.ko
lx4:/lib/modules/3.0.101-0.47.55-default/weak-updates/updates #

На втором сервере, который не патчился несколько месяцев, кернел чуть старее (3.0.101-0.47.52-default), но в папке /lib/modules/3.0.101-0.47.52-default/weak-updates/update/ ссылки точно такие же (ссылаются на модули из папки /lib/modules/3.0.76-0.11-default/updates/).
А что за странная версия кернела у вас (3.0.101-63-default)? У меня в списке установленных и возможных обновлений такого вообще нет.
Аватара пользователя
Константин Ошмян
 
Сообщения: 972
Зарегистрирован: 13 авг 2002, 21:36
Откуда: Рига


Вернуться в *nix

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron