проблемма открытия файла более одним пользователем

Обсуждение технических вопросов по продуктам Novell

проблемма открытия файла более одним пользователем

Сообщение UA4WKK » 28 янв 2005, 16:10

Возникла проблемма открытия файлов на вновь созданном сервере NW6.5SP2 более чем одним пользователем. Есть некая база.mdb, в мониторе файл не залочен. При открытии 2-м пользователем возникает ошибка о том, что таблица открыта эксклюзивно другим пользователем. В какие настройки смотреть?
С почтением,
Дмитрий
UA4WKK
 
Сообщения: 10
Зарегистрирован: 08 апр 2003, 16:32

Сообщение Rogi » 30 янв 2005, 23:44

может монопольно открываеш ?
Rogi
 
Сообщения: 8
Зарегистрирован: 14 янв 2005, 18:13
Откуда: Вологда

Сообщение UA4WKK » 31 янв 2005, 08:15

Rogi писал(а):может монопольно открываеш ?

на консоли в мониторе вижу, что файл Not Locked, да и копировать его могу. Были замечены подобные странности в работе, открытии файлов другими приложениями (Word, Excel)
UA4WKK
 
Сообщения: 10
Зарегистрирован: 08 апр 2003, 16:32

Сообщение gbh » 31 янв 2005, 10:48

Так Access (раз mdb) по другому вроде и не работает. У меня тоже есть mdb на 4.11 , проблема такая же, но NetWare здесь ни причем, это проблемы access, а если еще ODBC юзаете, то тем более. ODBC дает только монопольный доступ.
gbh
 
Сообщения: 80
Зарегистрирован: 26 июн 2004, 13:53
Откуда: Санкт-Петербург

Сообщение UA4WKK » 31 янв 2005, 11:12

gbh писал(а):Так Access (раз mdb) по другому вроде и не работает. У меня тоже есть mdb на 4.11 , проблема такая же, но NetWare здесь ни причем, это проблемы access, а если еще ODBC юзаете, то тем более. ODBC дает только монопольный доступ.

При копировании этой базы на др. сервер 5.1 все замечательно работает. Обращение к базе клиентом происходит на через источник ODBC, клиентской программе указан путь к базе через мапированный диск.
UA4WKK
 
Сообщения: 10
Зарегистрирован: 08 апр 2003, 16:32

Сообщение gbh » 31 янв 2005, 11:33

Обращение к базе клиентом происходит НЕ (наверно) через источник ODBC, клиентской программе указан путь к базе через мапированный диск.
Всё аналогично. На 4.11 у меня это не катит, т.е. к файлам которые связаны он обращается нормально, но когда открывает внутреннии файлы mdbхе, там глюк и происходит.
gbh
 
Сообщения: 80
Зарегистрирован: 26 июн 2004, 13:53
Откуда: Санкт-Петербург

Сообщение Алексей Волков » 31 янв 2005, 11:39

Для начала:
SET CLIENT FILE CACHING = OFF
SET LEVEL 2 OPLOCKS ENABLED = OFF
Алексей Волков
 
Сообщения: 292
Зарегистрирован: 14 окт 2003, 19:21
Откуда: Kiev

Сообщение UA4WKK » 31 янв 2005, 13:13

Алексей Волков (Alexi) писал(а):Для начала:
SET CLIENT FILE CACHING = OFF
SET LEVEL 2 OPLOCKS ENABLED = OFF

Эти параметры вычитал в каком то ТИДе, но не было возвожности перезагрузить, что и сделал. Проблемма решилась.
Спасибо.
UA4WKK
 
Сообщения: 10
Зарегистрирован: 08 апр 2003, 16:32

Сообщение Роман Иванов » 31 янв 2005, 21:25

а зачем перегружать?
Роман Иванов
 
Сообщения: 257
Зарегистрирован: 05 май 2003, 17:25
Откуда: Москва, Курск

Сообщение UA4WKK » 01 фев 2005, 09:00

Роман Иванов писал(а):а зачем перегружать?

а чем объяснить решение проблеммы только после перезагрузки? Изменение параметров без оной не привело к желаемым результатам.
Хотя, возможно, повлияли изменения других параметров, в чем я сомневаюсь. Менял кол-во открытых файлов, локов, etc (as far as i remember)
С почтением,
Дмитрий.
UA4WKK
 
Сообщения: 10
Зарегистрирован: 08 апр 2003, 16:32


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 17

cron