Размонтируются тома... Помогите кто может!!!

Обсуждение технических вопросов по продуктам Novell

Размонтируются тома... Помогите кто может!!!

Сообщение Сумин Евгений » 02 мар 2004, 11:38

Проблема такая:
- при чтении с сети файла с размером порядка 100 мБ и больше размонтируются тома, в том числе и SYS, после чего сервак умирает...
Подскажите что делать! Пожалуйста!!!

Конфигурация:
NW6+SP2, SCSI Tekram DC 320U (драйвер LSI_U3NW), NSS.
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Сообщение Павел Орлов aka XerX » 02 мар 2004, 12:42

Вопрос:
именно размонтируются тома на сервере или отваливаются сетевые диски ???
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Сообщение Сумин Евгений » 02 мар 2004, 12:53

Именно размонтируются... Том SYS и Work. На ворке собственно база. Не могу понять откуда ноги растут. Сервак ругается ошибка по адресу...
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Сообщение Павел Орлов aka XerX » 02 мар 2004, 13:01

Что из железа менялось на сервере ?
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Сообщение Сумин Евгений » 02 мар 2004, 13:10

Не то чтобы менялось... Сервак новый. Он проработал с месяц. Выплыло это вчера, когда бухгалтер делал архив 1С (до сих пор выгрузка была меньше...) Со временем архив рос, рос и "выросло" :)

Я провел ряд экспериментов - все четко повторяется с любым большим файлом, даже не имеющим отношения к 1С. Это может быть например *.avi... Главное размер.
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Сообщение Павел Орлов aka XerX » 02 мар 2004, 13:28

Исключаем железо:
1) При установке сервака добавлялось ли некое железо не входящее в стандартную поставку ? Если да - вынимаем.
2) Исключаем сетевое оборудование (что в общем-то очень маловероятно) - подключаем к серваку некий комп (или ноутбук) кроссовером и пытаемся утянуть этот же файл.

Исключаем нетварь:
3) Ставим Последние сервис-паки на сервак и на файловую систему.

Исключаем клиента:
4) Ставим последние паки на клиента ( я бы всетаки предпочел 4.83 с паками а не 4.9)
CNE 5, 6
Павел Орлов aka XerX
 
Сообщения: 284
Зарегистрирован: 26 июн 2002, 17:17
Откуда: Москва

Сообщение Сумин Евгений » 02 мар 2004, 15:34

Такой сбой происходит даже при копировании средствами самого сервака, т.е. File Brauser, поэтому клиент и сетевое оборудование не причем, железяк дополнительных не доставлял...
SP4 попробую поставить в субботу (постараемя дожить в таком режиме). Отпишу, чего получилось...

Неужели ни у кого ничего похожего не происходило? - Наверное я самый везучий :)
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Может быть и контроллер и даже настройки биоса.

Сообщение Boris Morozov » 03 мар 2004, 03:59

У нас в середине 90 была такая фигня. Типа белые сервера с крутыми мамами по тем временам, с крутыми DPT контроллерами давали аналогичную ситуацию на 4.11.Сменили железо и все прекратилось.
Очень уж похоже на какой-то конфликт оборудования, если только не дефект.
Я вот как-то сдуру один раз включил на маме TOP Performance - вот веселуха была.
Boris Morozov
 
Сообщения: 1333
Зарегистрирован: 05 июн 2002, 22:24
Откуда: Минск

Сообщение Сумин Евгений » 06 мар 2004, 16:54

Наверное действительно аппаратный конфликт...
Я поставил еще один винт в тот же сервак - с ним все нормально...
Если проблема с винтом - плохо конечно - на нем том SYS.
На всякий случай привожу лог консоли после размнтирования. Может кто-нибудь еще что-нибудь посоветует:

Deactivating pool "WORK"...
Dismounting Volume WORK
Deactivating pool "SYS"...
Deactivating volume "SYS"...

6 Mar 2004 14:50:01 NSS<COMN>-3.02-xxxx: comnPool.c[2519]
Pool SYS: System data I/O error 20204(zio.c[1895]).
Block 416587(file block -416587)(ZID 1)


6 Mar 2004 14:50:01 NSS<COMN>-3.02-xxxx: comnVol.c[7701]
Volume SYS: System data I/O error 20204(zio.c[1895]).
Block 416587(file block -416587)(ZID 1)



6 Mar 2004 14:50:01 NSS<ZLSS>-3.02-1437: zio.c[1388]
Failed to queue a Read Request at volume block: 0x376028 file block: 0x127D
on Volume: WORK.


6 Mar 2004 14:50:01 NSS<ZLSS>-3.02-1437: zio.c[1388]
Failed to queue a Read Request at volume block: 0x376029 file block: 0x127E
on Volume: WORK.

CONLOG-3.00-8: Write to system console log failed:
No such file or directory.
CONLOG-3.00-11: System console logging stopped Sat Mar 6 14:50:01 2004.

6 Mar 2004 14:50:02 NSS<COMN>-3.02-xxxx: comnPool.c[2519]
Pool WORK: System data I/O error 20204(zio.c[1895]).
Block 2913797(file block 13067)(ZID 3)

Deactivating pool "SYS"...
[/img]
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Сообщение Андрей Тр. aka RH » 06 мар 2004, 17:59

Сумин Евгений писал(а):Pool SYS: System data I/O error 20204(zio.c[1895]).
Block 416587(file block -416587)(ZID 1)
zERR_WRITE_FAILURE 20204 /* the low level async block WRITE failed*/
По-моему из этого следует, что у вас на SYS какие-то аппаратные ошибки. Почему это проявляется только при чтении больших файлов .. А SYS и WORKS при этом ведь на разных жестких дисках ? Какие винты, кстати ?

Например :

Device deactivation during NSS background check process - TID10077382

http://support.novell.com/cgi-bin/searc ... 077382.htm
Даешь отдельный раздел по ZENworks ... :bad-words: .. и печати !
Аватара пользователя
Андрей Тр. aka RH
 
Сообщения: 3937
Зарегистрирован: 18 июн 2002, 11:27

Сообщение Сумин Евгений » 06 мар 2004, 18:15

SYS и WORK на одном физическом винте. Винт Seagate ST318406LW
Я поставил второй винт - с ним все нормально. При размонтировании томов SYS и WORK том DATA (на втором винте) остается и с ним можно полноценно работать. Т.Е. наверное проблема с самим винтом... Но почему только для больших файлов - не понимаю. Я попробовал поменять контроллер - не помогло.
Сумин Евгений
 
Сообщения: 153
Зарегистрирован: 06 июл 2002, 15:53
Откуда: Киев

Сообщение Аркадий Глазырин » 06 мар 2004, 21:57

У меня такое было. Почему-то отваливался один винчестер полностью.
NW 5.1
До сих пор не понял в чём дело. Может быть причина в том, что на одном из томов того диска свободного места была около гига. Я про реально свободное. Казало гигов шесть,однако там и компрессированные и неудалённые до конца.

Когда наш Oracle админ начинал бакапить скрипты и сервер (это гигиов пять), то винт отваливался.

Почистил винчестер, удалил файлы без возможности восстановлени и проблема вроде бы больше не появлялась.
Аватара пользователя
Аркадий Глазырин
 
Сообщения: 2762
Зарегистрирован: 16 авг 2002, 09:09
Откуда: Екатеринбург


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron