После установки eDir 8.7 на одном из NW5.1 не заработал LDAP

Обсуждение технических вопросов по продуктам Novell

После установки eDir 8.7 на одном из NW5.1 не заработал LDAP

Сообщение Сергей Дубров » 04 сен 2003, 14:38

Опупея продолжается :lol:. Напомню - имею стендовое дерево с трёмя серверами - 4.11+sp9+ds6.21 и два NW5.1+sp5+NDS8.82c. Мастер-реплика - на 4.11 (это в данном контексте не принципиально).

Ставили eDir на 5.1 (первый в дереве 5.1). У него есть одна специфическая особенность, не знаю, железо виновато или что - после перезагрузки он очень долго (минут 30-40-50) не может установить коннект с держателем мастер-реплики. Со вторым 5.1 такой проблемы нет, коннектится сразу после загрузки. Установления коннекта можно добиться, запустив dsrepair full unattended на 4.11.

Что произошло - ставили eDir 8.7 на первый 5.1. После первой перезагрузки коннект с 4.11, как всегда, сразу не восстановился. Тут надо было, пока 5.1 ждал ввода имени и пароля для админа, пустить dsrepair на сервере с мастер-репликой и, после установления связи, двигаться дальше. Этого сделано не было (отвлекли), в результате при продолжении установки вылетали маты на LDAP и NMAS. Результат - не создались объеты "LDAP Group - " и "LDAP Server - ". Создал их руками, сделал нужные ссылки внутри (как учит Новел), дал права (срисовал с "живого" LDAP-а) - и всё равно - не заработало! NLDAP грузится без ругани, но порты 389 и 636 - не слушает. Когда ставили eDir на второй 5.1, с ним никаких приключений не было - всё встало влёт, все объекты на месте, LDAP и LDAPS - работают как часы. Хочется понять, что не так на первом сервере.

При загрузке по экрану летели какие-то ошибки (до conlog-а), выловил, нашёл CCS.NLM: Waiting to initialize. (0 minutes) - оказалось, ложная тревога. Перерыл все найденные тиды на тему ldap-а, в одном из них - TID10054559 - рекомендуется просто снести с сервера edir и ldap и поставить их заново (с edir ldap нельзя переустановить отдельно. Там, правда, объясняется это для 8.5, но для 8.7, как я понимаю, всё точно также). Мне переустанавливать edir на этом сервере категорически не подходит - это первый 5.1 в дереве и он держатель CA, KAP, W0 и пр. криптокухни и мне совершенно не хочется восстанавливать потом это хозяйство руками. Как это делать - представляю, приходилось этим заниматься, но в данном конкретном случае основная идея - пройти все этапы инсталляции и апгрейдов "чисто", без ручного вмешательства.

Так что можно сделать с неработающим LDAP-ом? Есть какие-либо средства отладки, диагностики? Почему я здесь не гнушаюсь "ручной" работы - понятно, что недоустановка LDAP-а и NMAS-а вызвана причиной, которую можно было обойти с помощью вовремя запущенного dsrepair-а, поэтому хочется добиться работы LDAP-сервера без переустановки и восстановления сертификатов и пр. CA. Кстати, в conlog-е никаких ошибок на тему LDAP-а нет, только NMAS ругается (разборки с ним - следующий этап, сначала - LDAP):

NMAS.NLM could not load method CertMutual (-1656)
NMAS.NLM could not load method DIGESTMD5 (-1656)
NMAS.NLM could not load method Simple Password (-1656)
NMAS.NLM could not load method X509 Certificate (-1656)
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН

После установки eDir 8.7 на одном из NW5.1 не заработал LDAP

Сообщение Владимир Семиколенных » 04 сен 2003, 15:37

Была аналогичная фигня после установки патча 8.7.0.4.
LDAP, до этого нормально работавший, работать перестал.
В Reame к патчу:
IMPORTANT!!!!!
THE NEW NLDAP IN THIS PATCH REQUIRES A SCHEMA UPDATE IN ORDER TO FUNCTION!
После апдейта схемы и удаления объектов LDAP server & LDAP group (а потом создания их заново) всё зашуршало.
В.
Владимир Семиколенных
 
Сообщения: 174
Зарегистрирован: 10 июн 2002, 16:03
Откуда: Мурманск

Сообщение Михаил Григорьев » 05 сен 2003, 08:37

Сергей.... читаем здесь.... может поможет
Аватара пользователя
Михаил Григорьев
 
Сообщения: 1461
Зарегистрирован: 04 июн 2002, 12:22
Откуда: Челябинск

Сообщение Лебедев Виктор » 05 сен 2003, 08:55

Сергей, есть ли у Вас возможность проверить как расширилась схема для LDAP? Проверить бы что она не с NDS 7 "началаcь", а с NDS 8.
У меня была такая ситуация (все один в одному) на первом сервере с NW 5.1. Потом когда сервер из режима "проб и ошибок" перевел в боевой, все было нормально ... до момента когда довел NDS до 8.83 - потом опять легкие повреждения. Shemax-ом сравнивал схемы - вроде все в порядке, но по косвенным признакам все же получается: схема расширена для LDAP к NDS 7. С учетом того что дистрибутив NW 5.1 поставлялся с двумя NDS (7 и 8) - может быть в "схеме" установки Novell сделал ошибки? Странно еще и то что этот "бред" сопровождает "первые" сервера с 5.1 в дереве; вторые-то становятся как миленькие.
Лебедев Виктор
 
Сообщения: 133
Зарегистрирован: 05 июн 2002, 09:03
Откуда: Пермь

Ура!

Сообщение Сергей Дубров » 05 сен 2003, 10:05

Григорьев Михаил писал(а):Сергей.... читаем здесь.... может поможет

Миша (и Андрей Фисенко) - спасибо, повторное расширение схемы помогло, LDAP заработал! Блин, видел же то обсуждение, а применить к себе - не сообразил...
Аватара пользователя
Сергей Дубров
 
Сообщения: 2072
Зарегистрирован: 05 июн 2002, 06:07
Откуда: Новосибирск, ин-т ядерной физики СО РАН


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron