Срочно! После установки NW6SP3 появилась проблема с буквой Э

Обсуждение технических вопросов по продуктам Novell

Срочно! После установки NW6SP3 появилась проблема с буквой Э

Сообщение Игорь Вершинин » 22 апр 2003, 12:58

Как ее можно решить? И вообще, она решаема или надо откатится назад на SP2? Не хотелось бы, так как в SP3 многие вещи для NSS исправлены.
Проблема заключается в том, что русская буква "Э" отображается как "\". Символ для наименования файлов и каталогов запрещенный. Теперь файлы, наименование которых содержало букву "Э", неудаляются, неотображаются. Плохо. :(
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Это с каким lconfig.sys ?

Сообщение skoltogyan » 22 апр 2003, 15:06

Это с lconfig.sys
1. Eng
2. Rus (CP866)
3. Rus (CP866) исправленным Подойниковым ?

С какой ОС и какой там клиент ?

(Ответа у меня нет, я для себя уточняю обстаятельства)
skoltogyan
 
Сообщения: 1884
Зарегистрирован: 12 июл 2002, 19:39
Откуда: Украина, Донецк

Сообщение Игорь Вершинин » 22 апр 2003, 16:09

NW6. Ставилась изначально английской. Постепенно на нее накатывались сервис-паки и пост-фиксы. Докатились до вот этой ситуации. Никаких lconfig'ов нет.
Исправляется проблема (если это можно так назвать) утилитой FixNames.nlm. В файлах с нечитабельной Э меняются имена на длинный набор "псевдо-уникодовских" знаков. Но файлы сразу начинают быть доступными. Их можно переименовать во что-либо более читабельное и работать с ними. НО... создавать новые файлы и каталоги с именами, содержащими букву "Э", нельзя! сразу после создания эта буква отображается как "\" и работать с данным файлом снова нельзя.
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

У меня так

Сообщение skoltogyan » 22 апр 2003, 16:22

1.Поставил NW6
2. Заменил c:\nwserver\lconfig.sys на lconfig.sys от Подойникова (это Русский lconfig.sys, правленный Андреем Подойниковым)
3. Только после этого на тома начинаю писать русские названия.

Клиент 3.32sp1(eng) on W98SE
NW6+SP3

Проблемы с Русской "Э" и "э" нет(или не увидел, какое именно название каатлога или файла Вы создавали).?
skoltogyan
 
Сообщения: 1884
Зарегистрирован: 12 июл 2002, 19:39
Откуда: Украина, Донецк

Сообщение Игорь Вершинин » 22 апр 2003, 18:42

Клиент неважен. Так как подобная проблема проявляет себя и на консоли сервера. Через ConsoleOne подобные файлы и каталоги вообще не видны. Через NWAdmin32 видны, но с ними сделать ничего нельзя. Так же и через Explorer, FAR, TotalCommander.
Каталог, для примера, пусть называется "Экология".
Попробую сегодня поставить lconfig.sys. Не знаю, поможет ли это сейчас. И вообще, зачем это надо было, если раньше все великолепно и так работало. :(
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Временное решение проблемы.

Сообщение Андрей Фисенко » 23 апр 2003, 07:33

А, может, и постоянное.
Проверено на Netware 6.5 Beta2 и Beta3.
Nw6SP3 у меня пока нету, а то бы проверил тоже.
Действительно, буквы Э и э ну ни в какую.

Что сделал:
1. полный бэкап томов (с правами, ессно)
2. замена "родного" lconfig.sys (Eng) на "подойниковский" (http://www.nwsoft.ru/download/lconfig_s ... nw5x-6.zip)
3. Перезагрузка сервака. (как результат - имеем пустые тома, кроме SYS)
4. Удаление томов (я удялал пулы) и создание заново.
5. Буквы Э и э работают
6. Восстановление данных на томах с бэкапа.

Две мысли:
1. Проверить все-таки "родной русский" LC_866.007
2. Таки проверить на NW6SP3
Андрей Фисенко, Представитель Novell по Сибири и Дальнему Востоку
Изображение
Андрей Фисенко
 
Сообщения: 1308
Зарегистрирован: 05 июн 2002, 08:13
Откуда: Красноярск

NW6 +Sp3 + lconfig.sys от Подойникова..

Сообщение skoltogyan » 23 апр 2003, 09:39

В этом случае нет и не было проблем с Э и э.
skoltogyan
 
Сообщения: 1884
Зарегистрирован: 12 июл 2002, 19:39
Откуда: Украина, Донецк

Сообщение Игорь Вершинин » 23 апр 2003, 09:47

Полночи не поспал зато есть некоторые результаты.

1) SP3 воткнул все же свой lconfig.sys для английской версии (тот, что используется по умолчанию при отсутствии lconfig.sys в каталоге c:\nwserver); его удаление и возвращение обратно никоим образом картину не меняло (естественно).

2) Установка патченного lconfig.sys на "живых" томах и данных привела к тому, что все названия с русскими буквами (или почти все) исчезли.

3) Rebuild для пула делать не стал, так как данные бекапить было не на что. А данные жалко.

4) Сейчас проводится частичный бекап. Вечером будем все пересоздавать. Заодно и rebuild попробую.

5) Каталоги, созданные при наличии патченного lconfig.sys на сервере, после удаления lconfig.sys исчезли. Нет их. Т.е. его не видно, но при попытке создать каталог с таким же именем система ругается, говоря о наличии данного каталога.

6) Выводов получилось два. Или Novell исправил ошибки в NSS в SP3 и все заработало как и должно было бы работать (но что-то как-то не верится), или исправление других ошибок выявило эту - проблема с отображением расширенных символов (хотя по рекламным заявлениям Novell тома NSS хранят все имена в Unicode, тогда использование расширенных символов по меньшей мере странно). Видимо, надо ждать патча. И использовать пока исправленный lconfig.sys.
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Сообщение Сергей Каретин » 23 апр 2003, 12:08

Игорь, ну тебе же конкретно был расписан по пунктам метод замены lconfig, то что ты натворил не могло не произойти, и Novell тут не при чем, хотя, прибив lconfig, помоему, ты должен вернуть те файлы, которые ты имел без него.
Сергей Каретин
 
Сообщения: 201
Зарегистрирован: 05 июн 2002, 08:21
Откуда: Ярославль

Сообщение Игорь Вершинин » 23 апр 2003, 16:50

Прибив lconfig я вернулся к началу - большая буква Э не отображается, вместо нее отображается символ \ . До установки SP3 такого не было. Все файлы, разумеется, снова появились. Все-таки я склонен верить, что это проблемы у программистов Novell. В документации и файлах readme ни слова не сказано про возникновение подобных проблем. Путь решения есть, мне он не нравится, так как бекапить надо около 100 гиг информации. Повреждено на самом деле чуть больше двух сотен непринципиальных файлов. Это можно было бы и незаметить, если не принимать во внимание то, что в каждом профиле, хранимом на сервере, был файл "Экранная лупа.lnk"... профили теперь недоступны.
Файлы можно было бы и удалить, но они не удаляются....

Тема ясна. Ее можно закрыть. Спасибо.
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград

Сообщение Сергей Каретин » 24 апр 2003, 09:07

На последок.
Ну ведь для чего-то были придуманы те самые lconfig? И если заведомо было известно что на томе будут использоваться русские буковки, надо было сразу позаботиться, и использовать необходимый lconfig.
Сергей Каретин
 
Сообщения: 201
Зарегистрирован: 05 июн 2002, 08:21
Откуда: Ярославль

Сообщение Игорь Вершинин » 24 апр 2003, 15:10

Сергей Каретин писал(а):На последок.
Ну ведь для чего-то были придуманы те самые lconfig? И если заведомо было известно что на томе будут использоваться русские буковки, надо было сразу позаботиться, и использовать необходимый lconfig.


А если у меня еще будет использован украинский язык и польский с греческим одновремено. Как быть в этой ситуации? Я-то поверил в рекламные заверения Novell о нормальной поддержке Уникода на томах NSS.
Аватара пользователя
Игорь Вершинин
 
Сообщения: 387
Зарегистрирован: 05 июн 2002, 20:34
Откуда: Волгоград


Вернуться в Novell

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5